aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-08-03 20:51:18 +0800
committermat <mat@FreeBSD.org>2013-08-03 20:51:18 +0800
commit3e657489e209d0aec5331fd70f19c96df0146a59 (patch)
tree8f1b59cfbbd73620cc4a151c90372baa46f5e797 /lang
parentd04bb2c0dac4bb4b830d050a163327ba8477d204 (diff)
downloadfreebsd-ports-gnome-3e657489e209d0aec5331fd70f19c96df0146a59.tar.gz
freebsd-ports-gnome-3e657489e209d0aec5331fd70f19c96df0146a59.tar.zst
freebsd-ports-gnome-3e657489e209d0aec5331fd70f19c96df0146a59.zip
Convert to new perl framework.
Diffstat (limited to 'lang')
-rw-r--r--lang/parrot/Makefile3
-rw-r--r--lang/rakudo/Makefile4
2 files changed, 3 insertions, 4 deletions
diff --git a/lang/parrot/Makefile b/lang/parrot/Makefile
index f930409eadf1..1d5ad80c25a0 100644
--- a/lang/parrot/Makefile
+++ b/lang/parrot/Makefile
@@ -35,8 +35,7 @@ MAKE_JOBS_UNSAFE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_PERL5= yes
-USES= bison
+USES= bison perl5
MAN1= ops2c.1 \
parrot.1 \
diff --git a/lang/rakudo/Makefile b/lang/rakudo/Makefile
index 2f64562efb5b..34ba7f16ef76 100644
--- a/lang/rakudo/Makefile
+++ b/lang/rakudo/Makefile
@@ -35,7 +35,8 @@ CONFIGURE_PARROT_ARGS= --cc=${CC} --cxx=${CXX} --ld=${CC} --ccflags="${CFLAGS}"
CONFIGURE_ARGS= --with-parrot=${PREFIX}/bin/parrot \
--with-nqp=${PREFIX}/bin/nqp
-USES= bison
+USES= bison perl5
+USE_PERL5= build
.include <bsd.port.pre.mk>
@@ -43,7 +44,6 @@ USES= bison
BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
-USE_PERL5_BUILD= yes
USE_GMAKE= yes
MAN1= perl6.1 rakudo.1