aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2014-09-27 16:31:58 +0800
committerriggs <riggs@FreeBSD.org>2014-09-27 16:31:58 +0800
commit42744e3c059a69be53f5e8a1c54325632f565c7a (patch)
treed805f87c01e88809871cf9b9851ba01afb7daaf3 /lang
parent8249d7a3475801269ff15bcd83575b3605ef5713 (diff)
downloadfreebsd-ports-gnome-42744e3c059a69be53f5e8a1c54325632f565c7a.tar.gz
freebsd-ports-gnome-42744e3c059a69be53f5e8a1c54325632f565c7a.tar.zst
freebsd-ports-gnome-42744e3c059a69be53f5e8a1c54325632f565c7a.zip
Modernise databases/freetds port
- Retire databases/freetds-msdblib port (no longer needed, recently updated upstream version has necessary compat option which is now enabled in the freetds port) - Fix LIB_DEPENDS in dependent ports - Bump PORTREVISION in freetds and dependent ports PR: 193850 Submitted by: 5u623l20@gmail.com (maintainer)
Diffstat (limited to 'lang')
-rw-r--r--lang/php5/Makefile2
-rw-r--r--lang/php5/Makefile.ext4
-rw-r--r--lang/php53/Makefile2
-rw-r--r--lang/php53/Makefile.ext4
-rw-r--r--lang/php55/Makefile2
-rw-r--r--lang/php55/Makefile.ext4
-rw-r--r--lang/php56/Makefile2
-rw-r--r--lang/php56/Makefile.ext4
8 files changed, 12 insertions, 12 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 22cdd9d460a1..2ea6c6ccbd4e 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -3,7 +3,7 @@
PORTNAME= php5
PORTVERSION= 5.4.33
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
MASTER_SITE_SUBDIR= distributions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 2bd34ba59ea4..dd15b6851644 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -185,7 +185,7 @@ CONFIGURE_ARGS+=--with-mcrypt=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "mssql"
-LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds
CONFIGURE_ARGS+=--with-mssql=${LOCALBASE}
.endif
@@ -557,7 +557,7 @@ post-extract:
.if ${PHP_MODNAME} == "pdo_dblib"
. if ${PORT_OPTIONS:MMSSQL}
-LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds
. else
LIB_DEPENDS+= libct.so:${PORTSDIR}/databases/freetds
. endif
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index 2b96d3df0db7..b0f539a07c2a 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -3,7 +3,7 @@
PORTNAME= php53
PORTVERSION= 5.3.29
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
MASTER_SITE_SUBDIR= distributions
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index d2271e7a5805..721fa72e9817 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -181,7 +181,7 @@ CONFIGURE_ARGS+=--with-mcrypt=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "mssql"
-LIB_DEPENDS+= libsybdb.so.5:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so.5:${PORTSDIR}/databases/freetds
CONFIGURE_ARGS+=--with-mssql=${LOCALBASE}
.endif
@@ -563,7 +563,7 @@ CONFIGURE_ARGS+=--with-unixODBC=${LOCALBASE}
.if ${PHP_MODNAME} == "pdo_dblib"
.if ${PORT_OPTIONS:MMSSQL}
-LIB_DEPENDS+= libsybdb.so.5:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so.5:${PORTSDIR}/databases/freetds
.else
LIB_DEPENDS+= libct.so.4:${PORTSDIR}/databases/freetds
.endif
diff --git a/lang/php55/Makefile b/lang/php55/Makefile
index 9b30650401b7..770658ca43d1 100644
--- a/lang/php55/Makefile
+++ b/lang/php55/Makefile
@@ -3,7 +3,7 @@
PORTNAME= php55
PORTVERSION= 5.5.17
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
MASTER_SITE_SUBDIR= distributions
diff --git a/lang/php55/Makefile.ext b/lang/php55/Makefile.ext
index 8d4077162553..c330c85aae91 100644
--- a/lang/php55/Makefile.ext
+++ b/lang/php55/Makefile.ext
@@ -185,7 +185,7 @@ CONFIGURE_ARGS+=--with-mcrypt=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "mssql"
-LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds
CONFIGURE_ARGS+=--with-mssql=${LOCALBASE}
.endif
@@ -561,7 +561,7 @@ post-extract:
.if ${PHP_MODNAME} == "pdo_dblib"
. if ${PORT_OPTIONS:MMSSQL}
-LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds
. else
LIB_DEPENDS+= libct.so:${PORTSDIR}/databases/freetds
. endif
diff --git a/lang/php56/Makefile b/lang/php56/Makefile
index 98d5a19af4ea..e2716e6d3e8c 100644
--- a/lang/php56/Makefile
+++ b/lang/php56/Makefile
@@ -3,7 +3,7 @@
PORTNAME= php56
PORTVERSION= 5.6.0
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
MASTER_SITE_SUBDIR= distributions
diff --git a/lang/php56/Makefile.ext b/lang/php56/Makefile.ext
index a6e6175b19a3..d293fa272e8b 100644
--- a/lang/php56/Makefile.ext
+++ b/lang/php56/Makefile.ext
@@ -185,7 +185,7 @@ CONFIGURE_ARGS+=--with-mcrypt=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "mssql"
-LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds
CONFIGURE_ARGS+=--with-mssql=${LOCALBASE}
.endif
@@ -564,7 +564,7 @@ post-extract:
.if ${PHP_MODNAME} == "pdo_dblib"
. if ${PORT_OPTIONS:MMSSQL}
-LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds
. else
LIB_DEPENDS+= libct.so:${PORTSDIR}/databases/freetds
. endif