aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2009-05-09 08:53:57 +0800
committeracm <acm@FreeBSD.org>2009-05-09 08:53:57 +0800
commit460477bcb91c46647dd52fdce3ba56af6e4b38de (patch)
tree0a34b2ad25bfe618c84457f63204ca7748da32a0 /lang
parent0f9f3eeea25acd08c535cb764d11b8c9a94d48b7 (diff)
downloadfreebsd-ports-gnome-460477bcb91c46647dd52fdce3ba56af6e4b38de.tar.gz
freebsd-ports-gnome-460477bcb91c46647dd52fdce3ba56af6e4b38de.tar.zst
freebsd-ports-gnome-460477bcb91c46647dd52fdce3ba56af6e4b38de.zip
- New port: lang/gambas2-base
Gambas is a free development environment based on a Basic interpreter with object extensions, a bit like Visual Basic (but it is NOT a clone !). With Gambas, you can quickly design your program GUI with QT or GTK+, access MySQL, PostgreSQL, Firebird, ODBC and SQLite databases, pilot KDE applications with DCOP, translate your program into any language, create network applications easily, make 3D OpenGL applications, make CGI web applications, and so on. WWW: http://gambas.sf.net/
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/gambas2-base/Makefile60
-rw-r--r--lang/gambas2-base/Makefile.components187
-rw-r--r--lang/gambas2-base/distinfo3
-rw-r--r--lang/gambas2-base/files/patch-main-gbx_gbx_math.c13
-rw-r--r--lang/gambas2-base/files/patch-main-gbx_gbx_math.h12
-rw-r--r--lang/gambas2-base/pkg-descr9
-rw-r--r--lang/gambas2-base/pkg-plist60
8 files changed, 345 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 25c8117ca9d5..2183d4250115 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -79,6 +79,7 @@
SUBDIR += freetxl
SUBDIR += g95
SUBDIR += gambas
+ SUBDIR += gambas2-base
SUBDIR += gambit-c
SUBDIR += gauche
SUBDIR += gawk
diff --git a/lang/gambas2-base/Makefile b/lang/gambas2-base/Makefile
new file mode 100644
index 000000000000..295a60734c99
--- /dev/null
+++ b/lang/gambas2-base/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: gambas2-base
+# Date created: 2009-01-16
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gambas2
+PORTVERSION= 2.12
+CATEGORIES?= lang kde
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR=${PORTNAME:S/2//g}
+PKGNAMESUFFIX?= -base
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ${PORTNAME:S/2//g}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT?= A basic language with object extensions
+
+LIB_DEPENDS= ffi.5:${PORTSDIR}/devel/libffi
+
+USE_AUTOTOOLS= autoconf:262:env automake:19:env
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_LIBS}
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --disable-debug \
+ --disable-optimization
+CONFIGURE_WRKSRC?= ${WRKSRC}/main
+BUILD_WRKSRC?= ${WRKSRC}/main
+INSTALL_WRKSRC?= ${WRKSRC}/main
+
+EXTRACT_AFTER_ARGS= | ${TAR} -xf - "${DISTNAME}/acinclude.m4" "${DISTNAME}/component.am" \
+ "${DISTNAME}/config.sub" "${DISTNAME}/depcomp" "${DISTNAME}/install-sh" \
+ "${DISTNAME}/ltmain.sh" "${DISTNAME}/COPYING" "${DISTNAME}/config.guess" \
+ "${DISTNAME}/ChangeLog" "${DISTNAME}/missing" "${DISTNAME}/main"
+
+.include <bsd.port.pre.mk>
+
+.if ${PKGNAMESUFFIX} == "-base"
+USE_KDELIBS_VER= 3
+.include <${PORTSDIR}/Mk/bsd.kde.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 37,39d ${WRKSRC}/main/share/gb_common.h
+ @cd ${WRKSRC} && \
+ ${FIND} * -type f -name configure -print0 | ${XARGS} -0 ${REINPLACE_CMD} \
+ -e 's|-pipe -Wall -Wno-unused-value -fsigned-char|$$CFLAGS|g' \
+ -e 's|-O0||g' -e 's|-ldl||g'
+ @cd ${WRKSRC} && \
+ ${FIND} -E * -type f -iregex ".*\.(c|h)" -print0 | ${XARGS} -0 ${REINPLACE_CMD} \
+ -e 's|#ifdef __GNU_LIBRARY__|#if defined (__GNU_LIBRARY__) \|\| \
+ defined (__FreeBSD__)|g' -e 's|.so.4|.so|g' -e 's|.so.3|.so|g'
+.else
+.include "${MASTERDIR}/Makefile.components"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/gambas2-base/Makefile.components b/lang/gambas2-base/Makefile.components
new file mode 100644
index 000000000000..c47fb63a78e0
--- /dev/null
+++ b/lang/gambas2-base/Makefile.components
@@ -0,0 +1,187 @@
+PLIST= ${.CURDIR}/pkg-plist
+PATCHDIR= ${.CURDIR}/files
+
+GAMBAS_COMPONENT?= ${PKGNAMESUFFIX:S/-/./g:S/^.//g}
+GAMBAS_COMPDIRE= ${LOCALBASE}/lib/gambas2
+
+CONFIGURE_WRKSRC= ${WRKSRC}/${GAMBAS_COMPONENT}
+BUILD_WRKSRC= ${WRKSRC}/${GAMBAS_COMPONENT}
+INSTALL_WRKSRC= ${WRKSRC}/${GAMBAS_COMPONENT}
+
+CONFIGURE_ARGS= --disable-debug \
+ --disable-optimization
+
+EXTRACT_AFTER_ARGS+= "${DISTNAME}/${GAMBAS_COMPONENT}"
+
+.if ${PKGNAMESUFFIX} == "-gb-sdl-sound"
+BUILD_DEPENDS+= gbi2:${PORTSDIR}/lang/gambas2-base
+
+USE_SDL= sdl mixer
+.endif
+
+.if ${PKGNAMESUFFIX} == "-gb-db-firebird"
+USE_FIREBIRD= yes
+.endif
+
+.if ${PKGNAMESUFFIX} == "-gb-db-mysql"
+USE_MYSQL= yes
+.endif
+
+.if ${PKGNAMESUFFIX} == "-gb-db-postgresql"
+USE_PGSQL= yes
+.endif
+
+.if ${PKGNAMESUFFIX} == "-gb-db-odbc"
+LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
+.endif
+
+.if ${PKGNAMESUFFIX} == "-gb-db-sqlite2"
+USE_SQLITE= 2
+.endif
+
+.if ${PKGNAMESUFFIX} == "-gb-db-sqlite3"
+USE_SQLITE= yes
+.endif
+
+.if ${PKGNAMESUFFIX} == "-gb-pcre"
+BUILD_DEPENDS+= gbi2:${PORTSDIR}/lang/gambas2-base
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+.endif
+
+.if ${PKGNAMESUFFIX} == "-gb-corba"
+BUILD_DEPENDS+= gbi2:${PORTSDIR}/lang/gambas2-base
+LIB_DEPENDS+= ACE.5:${PORTSDIR}/devel/ace \
+ omniORB4.1:${PORTSDIR}/devel/omniORB
+.endif
+
+.if ${PKGNAMESUFFIX} == "-gb-sdl"
+BUILD_DEPENDS+= gbi2:${PORTSDIR}/lang/gambas2-base
+
+USE_SDL= sdl image gfx ttf
+USE_XORG= xft xcursor
+.endif
+
+.if ${PKGNAMESUFFIX} == "-ide"
+BUILD_DEPENDS+= gbi2:${PORTSDIR}/lang/gambas2-base \
+ ${GAMBAS_COMPDIRE}/gb.settings.component:${PORTSDIR}/lang/gambas2-components \
+ ${GAMBAS_COMPDIRE}/gb.qt.component:${PORTSDIR}/x11-toolkits/gambas2-gb-qt \
+ ${GAMBAS_COMPDIRE}/gb.desktop.component:${PORTSDIR}/x11/gambas2-gb-desktop
+.endif
+
+.if ${PKGNAMESUFFIX} == "-gb-net-curl"
+BUILD_DEPENDS+= gbi2:${PORTSDIR}/lang/gambas2-base
+LIB_DEPENDS+= curl.5:${PORTSDIR}/ftp/curl
+.endif
+
+.if ${PKGNAMESUFFIX} == "-gb-opengl"
+BUILD_DEPENDS+= gbi2:${PORTSDIR}/lang/gambas2-base
+
+USE_GL= gl glu
+.endif
+
+.if ${PKGNAMESUFFIX} == "-gb-image"
+BUILD_DEPENDS+= gbi2:${PORTSDIR}/lang/gambas2-base
+.endif
+
+.if ${PKGNAMESUFFIX} == "-gb-gtk-svg"
+BUILD_DEPENDS+= gbi2:${PORTSDIR}/lang/gambas2-base
+
+.include <${PORTSDIR}/Mk/bsd.gnome.mk>
+USE_GNOME= librsvg2
+.endif
+
+.if ${PKGNAMESUFFIX} == "-gb-pdf"
+BUILD_DEPENDS+= gbi2:${PORTSDIR}/lang/gambas2-base
+LIB_DEPENDS+= poppler:${PORTSDIR}/graphics/poppler
+.endif
+
+.if ${PKGNAMESUFFIX} == "-components"
+BUILD_DEPENDS+= gbi2:${PORTSDIR}/lang/gambas2-base \
+ ${GAMBAS_COMPDIRE}/gb.qt.component:${PORTSDIR}/x11-toolkits/gambas2-gb-qt
+.endif
+
+.if ${PKGNAMESUFFIX} == "-gb-net-smtp"
+BUILD_DEPENDS+= gbi2:${PORTSDIR}/lang/gambas2-base
+
+.include <${PORTSDIR}/Mk/bsd.gnome.mk>
+USE_GNOME= glib20
+.endif
+
+.if ${PKGNAMESUFFIX} == "-gb-net"
+BUILD_DEPENDS+= gbi2:${PORTSDIR}/lang/gambas2-base
+.endif
+
+.if ${PKGNAMESUFFIX} == "-gb-crypt"
+BUILD_DEPENDS+= gbi2:${PORTSDIR}/lang/gambas2-base
+.endif
+
+.if ${PKGNAMESUFFIX} == "-gb-xml"
+BUILD_DEPENDS+= gbi2:${PORTSDIR}/lang/gambas2-base \
+ ${GAMBAS_COMPDIRE}/gb.net.component:${PORTSDIR}/net/gambas2-gb-net \
+ ${GAMBAS_COMPDIRE}/gb.net.curl.component:${PORTSDIR}/ftp/gambas2-gb-net-curl
+
+.include <${PORTSDIR}/Mk/bsd.gnome.mk>
+USE_GNOME= libxml2 libxslt
+.endif
+
+.if ${PKGNAMESUFFIX} == "-gb-gtk"
+EXTRACT_AFTER_ARGS+= "${DISTNAME}/gb.qt"
+
+BUILD_DEPENDS+= gbi2:${PORTSDIR}/lang/gambas2-base
+
+.include <${PORTSDIR}/Mk/bsd.gnome.mk>
+USE_GNOME= gtk20
+.endif
+
+.if ${PKGNAMESUFFIX} == "-gb-qt-kde"
+EXTRACT_AFTER_ARGS+= "${DISTNAME}/gb.qt"
+
+BUILD_DEPENDS+= gbi2:${PORTSDIR}/lang/gambas2-base
+
+USE_KDELIBS_VER=3
+.include <${PORTSDIR}/Mk/bsd.kde.mk>
+.endif
+
+.if ${PKGNAMESUFFIX} == "-gb-desktop"
+BUILD_DEPENDS+= gbi2:${PORTSDIR}/lang/gambas2-base \
+ ${GAMBAS_COMPDIRE}/gb.settings.component:${PORTSDIR}/lang/gambas2-components \
+ ${GAMBAS_COMPDIRE}/gb.qt.component:${PORTSDIR}/x11-toolkits/gambas2-gb-qt
+
+USE_XORG= xtst
+.endif
+
+
+.if ${PKGNAMESUFFIX} == "-gb-qt"
+BUILD_DEPENDS+= gbi2:${PORTSDIR}/lang/gambas2-base
+
+USE_QT_VER= 3
+.include <${PORTSDIR}/Mk/bsd.kde.mk>
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 37,39d ${WRKSRC}/main/share/gb_common.h
+ @cd ${WRKSRC} && \
+ ${FIND} * -type f -name configure -print0 | ${XARGS} -0 ${REINPLACE_CMD} \
+ -e 's|-pipe -Wall -Wno-unused-value -fsigned-char|$$CFLAGS|g' \
+ -e 's|-O0||g'
+ @cd ${WRKSRC} && \
+ ${FIND} -E * -type f -iregex ".*\.(c|h)" -print0 | ${XARGS} -0 ${REINPLACE_CMD} \
+ -e 's|#ifdef __GNU_LIBRARY__|#if defined (__GNU_LIBRARY__) \|\| \
+ defined (__FreeBSD__)|g'
+
+pre-install:
+.if exists(${LOCALBASE}/bin/gbi2)
+ @${LOCALBASE}/bin/gbi2 -r ${PREFIX}
+.endif
+
+security-check: gambas2-check-install
+
+gambas2-check-install:
+check-makevars::
+ @${ECHO_CMD} "###################################################################"
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} " The following gambas2 component will be installed in your system: "
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} " * ${PORTNAME}${PKGNAMESUFFIX}"
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "###################################################################"
diff --git a/lang/gambas2-base/distinfo b/lang/gambas2-base/distinfo
new file mode 100644
index 000000000000..720c30b6b990
--- /dev/null
+++ b/lang/gambas2-base/distinfo
@@ -0,0 +1,3 @@
+MD5 (gambas/gambas2-2.12.tar.bz2) = 58118cc26f7c8b56a24a35e51fd6cbca
+SHA256 (gambas/gambas2-2.12.tar.bz2) = 7abdc802896f505097f352a3927cddde479baaae1cccba82674a0454422fc8c2
+SIZE (gambas/gambas2-2.12.tar.bz2) = 12739402
diff --git a/lang/gambas2-base/files/patch-main-gbx_gbx_math.c b/lang/gambas2-base/files/patch-main-gbx_gbx_math.c
new file mode 100644
index 000000000000..d10cfe22b804
--- /dev/null
+++ b/lang/gambas2-base/files/patch-main-gbx_gbx_math.c
@@ -0,0 +1,13 @@
+--- main/gbx/gbx_math.c 2009-05-08 17:34:14.000000000 -0500
++++ main/gbx/gbx_math.c 2009-05-08 17:34:45.000000000 -0500
+@@ -207,10 +207,6 @@
+ return log(x) / M_LN2;
+ }
+
+-#endif
+-
+-#ifdef OS_OPENBSD
+-
+ double exp2(double x)
+ {
+ return pow(2, x);
diff --git a/lang/gambas2-base/files/patch-main-gbx_gbx_math.h b/lang/gambas2-base/files/patch-main-gbx_gbx_math.h
new file mode 100644
index 000000000000..a802b488fdf1
--- /dev/null
+++ b/lang/gambas2-base/files/patch-main-gbx_gbx_math.h
@@ -0,0 +1,12 @@
+--- main/gbx/gbx_math.h 2009-05-08 17:35:50.000000000 -0500
++++ main/gbx/gbx_math.h 2009-05-08 17:36:10.000000000 -0500
+@@ -47,9 +47,6 @@
+ #if defined(OS_FREEBSD) || defined(OS_OPENBSD)
+ double exp10(double x);
+ double log2(double x);
+-#endif
+-
+-#ifdef OS_OPENBSD
+ double exp2(double x);
+ long double log10l(long double x);
+ long double fabsl(long double x);
diff --git a/lang/gambas2-base/pkg-descr b/lang/gambas2-base/pkg-descr
new file mode 100644
index 000000000000..017280e4859f
--- /dev/null
+++ b/lang/gambas2-base/pkg-descr
@@ -0,0 +1,9 @@
+Gambas is a free development environment based on a Basic interpreter with
+object extensions, a bit like Visual Basic (but it is NOT a clone !).
+
+With Gambas, you can quickly design your program GUI with QT or GTK+, access
+MySQL, PostgreSQL, Firebird, ODBC and SQLite databases, pilot KDE applications
+with DCOP, translate your program into any language, create network applications
+easily, make 3D OpenGL applications, make CGI web applications, and so on.
+
+WWW: http://gambas.sf.net/
diff --git a/lang/gambas2-base/pkg-plist b/lang/gambas2-base/pkg-plist
new file mode 100644
index 000000000000..7bec6f50c78b
--- /dev/null
+++ b/lang/gambas2-base/pkg-plist
@@ -0,0 +1,60 @@
+@comment $FreeBSD$
+bin/gbx2
+bin/gbc2
+bin/gba2
+bin/gbi2
+bin/gbr2
+lib/gambas2/gb.so.0
+lib/gambas2/gb.so
+lib/gambas2/gb.la
+lib/gambas2/gb.debug.component
+lib/gambas2/gb.debug.so.0
+lib/gambas2/gb.debug.so
+lib/gambas2/gb.debug.la
+lib/gambas2/gb.eval.component
+lib/gambas2/gb.eval.so.0
+lib/gambas2/gb.eval.so
+lib/gambas2/gb.eval.la
+lib/gambas2/gb.db.component
+lib/gambas2/gb.db.so.0
+lib/gambas2/gb.db.so
+lib/gambas2/gb.db.la
+lib/gambas2/gb.compress.component
+lib/gambas2/gb.compress.so.0
+lib/gambas2/gb.compress.so
+lib/gambas2/gb.compress.la
+lib/gambas2/gb.vb.component
+lib/gambas2/gb.vb.so.0
+lib/gambas2/gb.vb.so
+lib/gambas2/gb.vb.la
+lib/gambas2/gb.option.component
+lib/gambas2/gb.option.so.0
+lib/gambas2/gb.option.so
+lib/gambas2/gb.option.la
+lib/gambas2/gb.draw.so.0
+lib/gambas2/gb.draw.so
+lib/gambas2/gb.draw.la
+lib/gambas2/gb.gui.component
+lib/gambas2/gb.gui.so.0
+lib/gambas2/gb.gui.so
+lib/gambas2/gb.gui.la
+lib/gambas2/gb.component
+%%DATADIR%%/info/gb.debug.info
+%%DATADIR%%/info/gb.debug.list
+%%DATADIR%%/info/gb.eval.info
+%%DATADIR%%/info/gb.eval.list
+%%DATADIR%%/info/gb.db.info
+%%DATADIR%%/info/gb.db.list
+%%DATADIR%%/info/gb.compress.info
+%%DATADIR%%/info/gb.compress.list
+%%DATADIR%%/info/gb.vb.info
+%%DATADIR%%/info/gb.vb.list
+%%DATADIR%%/info/gb.option.info
+%%DATADIR%%/info/gb.option.list
+%%DATADIR%%/info/gb.gui.info
+%%DATADIR%%/info/gb.gui.list
+%%DATADIR%%/info/gb.info
+%%DATADIR%%/info/gb.list
+@dirrmtry lib/gambas2
+@dirrmtry %%DATADIR%%/info
+@dirrmtry %%DATADIR%%