aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2016-04-19 22:20:01 +0800
committergahr <gahr@FreeBSD.org>2016-04-19 22:20:01 +0800
commit55abcc5dbc141b64ce1f2c47358f78bcec07d727 (patch)
tree14fe99943d56267ca815906c549d8a671245db05 /lang
parentfbe85fa27038890342620f0a270900eeb4ff73f0 (diff)
downloadfreebsd-ports-gnome-55abcc5dbc141b64ce1f2c47358f78bcec07d727.tar.gz
freebsd-ports-gnome-55abcc5dbc141b64ce1f2c47358f78bcec07d727.tar.zst
freebsd-ports-gnome-55abcc5dbc141b64ce1f2c47358f78bcec07d727.zip
Add "tea" argument to USES=tcl to facilitate porting of TEA-based extensions.
Quoting https://tcl.tk/doc/tea: "The Tcl Extension Architecture, or TEA, by John Ousterhout and others, is a set of guidelines and techniques for the distribution, configuration, compilation, and installation of Tcl extensions. TEA also provides a set of utilities that operate accordingly. Many Tcl extensions leverage the TEA utilities, which are designed to be easily customizable." To facilitate the porting of TEA-based extensions, I have added the new "tea" argument to USES=tcl. This argument prepares the autoconf environment by setting GNU_CONFIGURE and sets some commonly used CONFIGURE_ARGS. Also, it tries to figure out the correct extension name, sets TCL_PKG accordingly, and adds it to PLIST_SUB. I have modified a few ports to take advantage of this. More will come.
Diffstat (limited to 'lang')
-rw-r--r--lang/tclX/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/lang/tclX/Makefile b/lang/tclX/Makefile
index 6570a5ee7f06..518efcc4fd41 100644
--- a/lang/tclX/Makefile
+++ b/lang/tclX/Makefile
@@ -17,13 +17,10 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
WRKSRC= ${WRKDIR}/${PORTNAME:tl}${PORTVERSION:R}
-USES= alias tcl tar:bzip2
+USES= autoreconf alias tcl:tea tar:bzip2
USE_LDCONFIG= ${PREFIX}/lib/tclx${PORTVERSION:R}
-USE_AUTOTOOLS= autoconf
-CONFIGURE_ARGS= --exec-prefix=${PREFIX} \
- --enable-shared \
- --with-help=Help \
- --with-tcl="${TCL_LIBDIR}"
+CONFIGURE_ARGS+=--enable-shared \
+ --with-help=Help
PLIST_SUB= TCLX_VER=${PORTVERSION:R}
ALL_TARGET= binaries libraries
INSTALL_TARGET= install-binaries install-libraries