aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2014-06-03 16:07:48 +0800
committergahr <gahr@FreeBSD.org>2014-06-03 16:07:48 +0800
commit5d7211e3344f8be8187a319546caf12c117c6806 (patch)
treee81291578eb6bcc6dad77dfbd3a2eaf22088214a /lang
parente66e9270c42c58d95be975d7d00488fc1361724c (diff)
downloadfreebsd-ports-gnome-5d7211e3344f8be8187a319546caf12c117c6806.tar.gz
freebsd-ports-gnome-5d7211e3344f8be8187a319546caf12c117c6806.tar.zst
freebsd-ports-gnome-5d7211e3344f8be8187a319546caf12c117c6806.zip
- Update to 05_20140601
* The compiler has been refactored. Code has been moved from s7c.sd7 to several compiler libraries. The compiler libraries are licensed with the GPL and can be found in seed7/lib/comp. The refactored compiler is the first compiler of the 3.0 series. * The chapter in the manual about the foreign function interface has been improved. * Checks for parse and str have been added to chkflt.sd7 and chkint.sd7. * In chkccomp.c code has been moved from main() to the new functions numericSizes and numericProperties. * Usages of the macro logError have been added to cmd_rtl.c and cmd_unx.c. * The stack size defined in mk_mingc.mak, mk_mingw.mak, mk_msys.mak and mk_nmake.mak has been changed from 4194304 to 8388608. * The function cstri_buf_to_stri has been added to striutl.c. * The generation of float literals in the compiler has been improved to avoid that precision is lost. * Interpreter and compiler have been improved to support the actions BLN_EQ and BLN_NE.
Diffstat (limited to 'lang')
-rw-r--r--lang/seed7/Makefile19
-rw-r--r--lang/seed7/distinfo4
-rw-r--r--lang/seed7/pkg-plist73
3 files changed, 73 insertions, 23 deletions
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
index c02ef5d2ce7f..573b0d5ca499 100644
--- a/lang/seed7/Makefile
+++ b/lang/seed7/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= seed7
-DISTVERSION= 05_20140518
+DISTVERSION= 05_20140601
CATEGORIES= lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}/
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -11,7 +11,11 @@ EXTRACT_SUFX= .tgz
MAINTAINER= gahr@FreeBSD.org
COMMENT= High-level, extensible programming language
-LICENSE= LGPL21
+# The language libraries are licensed under the LGPL21 license. Starting from
+# version 05_20140601, the compiler libraries are also distributed. These are
+# licensed under the GPLv2 and can be found in ${PREFIX}/lib/seed7/lib/comp.
+LICENSE= GPLv2 LGPL21
+LICENSE_COMB= multi
OPTIONS_DEFINE= DOCS EXAMPLES
@@ -38,20 +42,21 @@ PORTDOCS= *
MAKEFILE= mk_freebsd.mk
post-patch:
- ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g;' ${WRKSRC}/${MAKEFILE}
-# ${REINPLACE_CMD} -e '/FLOATTYPE_DOUBLE/s|undef|define|' ${WRKSRC}/config.h
+ ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g;' \
+ -e '/\.\/chkccomp/s|>>||' ${WRKSRC}/${MAKEFILE}
do-build:
- cd ${WRKSRC} && ${MAKE} -f ${MAKEFILE} depend
- cd ${WRKSRC} && ${MAKE} -f ${MAKEFILE} s7 s7c
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} -f ${MAKEFILE} depend
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} -f ${MAKEFILE} s7 s7c
do-install:
# install interpreter and compiler
${INSTALL_PROGRAM} ${WRKSRC}/../bin/s7 ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/../prg/s7c ${STAGEDIR}${PREFIX}/bin
# install seed7 library
- ${INSTALL} -d ${STAGEDIR}${SEED7_LIBRARY}
+ ${INSTALL} -d ${STAGEDIR}${SEED7_LIBRARY}/comp
cd ${WRKSRC}/../lib && ${COPYTREE_SHARE} '*.s7i' ${STAGEDIR}${SEED7_LIBRARY}
+ cd ${WRKSRC}/../lib/comp && ${COPYTREE_SHARE} '*.s7i' ${STAGEDIR}${SEED7_LIBRARY}/comp
# install static libraries
${INSTALL} -d ${STAGEDIR}${S7_LIB_DIR}
.for s7_lib in ${S7_LIBS}
diff --git a/lang/seed7/distinfo b/lang/seed7/distinfo
index 2b29115809f6..6603b8dc82a3 100644
--- a/lang/seed7/distinfo
+++ b/lang/seed7/distinfo
@@ -1,2 +1,2 @@
-SHA256 (seed7_05_20140518.tgz) = e337edb6d89c054b1b72823c384cb2ecb05042b0629691dfaa21d8c7a515b942
-SIZE (seed7_05_20140518.tgz) = 2094157
+SHA256 (seed7_05_20140601.tgz) = ca10dcbe34684d8fc01dd6c463e52a1ba2ee21ca9c3904deb1f3547be903ca3a
+SIZE (seed7_05_20140601.tgz) = 2118208
diff --git a/lang/seed7/pkg-plist b/lang/seed7/pkg-plist
index ec4534f349f8..d523e2310293 100644
--- a/lang/seed7/pkg-plist
+++ b/lang/seed7/pkg-plist
@@ -6,16 +6,8 @@ lib/seed7/bin/s7_data.a
lib/seed7/bin/s7_draw.a
lib/seed7/bin/seed7_05.a
lib/seed7/lib/arc4.s7i
-lib/seed7/lib/asn1.s7i
-lib/seed7/lib/cc_conf.s7i
-lib/seed7/lib/cipher.s7i
-lib/seed7/lib/des.s7i
-lib/seed7/lib/gethttps.s7i
-lib/seed7/lib/hmac.s7i
-lib/seed7/lib/pkcs1.s7i
-lib/seed7/lib/tls.s7i
-lib/seed7/lib/x509cert.s7i
lib/seed7/lib/array.s7i
+lib/seed7/lib/asn1.s7i
lib/seed7/lib/bigfile.s7i
lib/seed7/lib/bigint.s7i
lib/seed7/lib/bigrat.s7i
@@ -28,18 +20,65 @@ lib/seed7/lib/bstring.s7i
lib/seed7/lib/bytedata.s7i
lib/seed7/lib/cards.s7i
lib/seed7/lib/category.s7i
+lib/seed7/lib/cc_conf.s7i
lib/seed7/lib/cgi.s7i
lib/seed7/lib/char.s7i
lib/seed7/lib/charsets.s7i
lib/seed7/lib/chartype.s7i
+lib/seed7/lib/cipher.s7i
lib/seed7/lib/clib_file.s7i
lib/seed7/lib/color.s7i
+lib/seed7/lib/comp/act_act.s7i
+lib/seed7/lib/comp/action.s7i
+lib/seed7/lib/comp/arr_act.s7i
+lib/seed7/lib/comp/big_act.s7i
+lib/seed7/lib/comp/bln_act.s7i
+lib/seed7/lib/comp/bst_act.s7i
+lib/seed7/lib/comp/chr_act.s7i
+lib/seed7/lib/comp/cmd_act.s7i
+lib/seed7/lib/comp/con_act.s7i
+lib/seed7/lib/comp/config.s7i
+lib/seed7/lib/comp/const.s7i
+lib/seed7/lib/comp/copy.s7i
+lib/seed7/lib/comp/create.s7i
+lib/seed7/lib/comp/dcl_act.s7i
+lib/seed7/lib/comp/debug.s7i
+lib/seed7/lib/comp/destr.s7i
+lib/seed7/lib/comp/drw_act.s7i
+lib/seed7/lib/comp/enu_act.s7i
+lib/seed7/lib/comp/error.s7i
+lib/seed7/lib/comp/expr.s7i
+lib/seed7/lib/comp/expr_util.s7i
+lib/seed7/lib/comp/fil_act.s7i
+lib/seed7/lib/comp/flt_act.s7i
+lib/seed7/lib/comp/gkb_act.s7i
+lib/seed7/lib/comp/hsh_act.s7i
+lib/seed7/lib/comp/int_act.s7i
+lib/seed7/lib/comp/itf_act.s7i
+lib/seed7/lib/comp/kbd_act.s7i
+lib/seed7/lib/comp/library.s7i
+lib/seed7/lib/comp/literal.s7i
+lib/seed7/lib/comp/pol_act.s7i
+lib/seed7/lib/comp/prc_act.s7i
+lib/seed7/lib/comp/prg_act.s7i
+lib/seed7/lib/comp/ref_act.s7i
+lib/seed7/lib/comp/rfl_act.s7i
+lib/seed7/lib/comp/sct_act.s7i
+lib/seed7/lib/comp/set_act.s7i
+lib/seed7/lib/comp/soc_act.s7i
+lib/seed7/lib/comp/stat.s7i
+lib/seed7/lib/comp/str_act.s7i
+lib/seed7/lib/comp/tim_act.s7i
+lib/seed7/lib/comp/typ_act.s7i
+lib/seed7/lib/comp/type.s7i
+lib/seed7/lib/comp/ut8_act.s7i
lib/seed7/lib/complex.s7i
lib/seed7/lib/console.s7i
lib/seed7/lib/crc32.s7i
lib/seed7/lib/cronos16.s7i
lib/seed7/lib/cronos27.s7i
lib/seed7/lib/deflate.s7i
+lib/seed7/lib/des.s7i
lib/seed7/lib/dialog.s7i
lib/seed7/lib/dir.s7i
lib/seed7/lib/draw.s7i
@@ -60,12 +99,14 @@ lib/seed7/lib/forloop.s7i
lib/seed7/lib/ftp.s7i
lib/seed7/lib/getf.s7i
lib/seed7/lib/gethttp.s7i
+lib/seed7/lib/gethttps.s7i
lib/seed7/lib/graph.s7i
lib/seed7/lib/graph_file.s7i
lib/seed7/lib/gtkserver.s7i
lib/seed7/lib/gzip.s7i
lib/seed7/lib/hash.s7i
lib/seed7/lib/hashsetof.s7i
+lib/seed7/lib/hmac.s7i
lib/seed7/lib/html.s7i
lib/seed7/lib/html_ent.s7i
lib/seed7/lib/idxarray.s7i
@@ -84,14 +125,16 @@ lib/seed7/lib/makedata.s7i
lib/seed7/lib/math.s7i
lib/seed7/lib/modern27.s7i
lib/seed7/lib/more.s7i
+lib/seed7/lib/msgdigest.s7i
lib/seed7/lib/multiscr.s7i
lib/seed7/lib/null_file.s7i
lib/seed7/lib/osfiles.s7i
-lib/seed7/lib/pic_util.s7i
lib/seed7/lib/pic16.s7i
lib/seed7/lib/pic32.s7i
+lib/seed7/lib/pic_util.s7i
lib/seed7/lib/pixmap_file.s7i
lib/seed7/lib/pixmapfont.s7i
+lib/seed7/lib/pkcs1.s7i
lib/seed7/lib/poll.s7i
lib/seed7/lib/process.s7i
lib/seed7/lib/progs.s7i
@@ -104,14 +147,11 @@ lib/seed7/lib/scanfile.s7i
lib/seed7/lib/scanstri.s7i
lib/seed7/lib/seed7_05.s7i
lib/seed7/lib/set.s7i
-lib/seed7/lib/msgdigest.s7i
lib/seed7/lib/shell.s7i
lib/seed7/lib/sockbase.s7i
lib/seed7/lib/socket.s7i
lib/seed7/lib/sokoban1.s7i
lib/seed7/lib/stars.s7i
-lib/seed7/lib/stdfont8.s7i
-lib/seed7/lib/stdfont9.s7i
lib/seed7/lib/stdfont10.s7i
lib/seed7/lib/stdfont12.s7i
lib/seed7/lib/stdfont14.s7i
@@ -119,6 +159,8 @@ lib/seed7/lib/stdfont16.s7i
lib/seed7/lib/stdfont18.s7i
lib/seed7/lib/stdfont20.s7i
lib/seed7/lib/stdfont24.s7i
+lib/seed7/lib/stdfont8.s7i
+lib/seed7/lib/stdfont9.s7i
lib/seed7/lib/stdio.s7i
lib/seed7/lib/strifile.s7i
lib/seed7/lib/string.s7i
@@ -131,6 +173,7 @@ lib/seed7/lib/tdes.s7i
lib/seed7/lib/tee.s7i
lib/seed7/lib/text.s7i
lib/seed7/lib/time.s7i
+lib/seed7/lib/tls.s7i
lib/seed7/lib/unicode.s7i
lib/seed7/lib/upper.s7i
lib/seed7/lib/utf16.s7i
@@ -140,11 +183,13 @@ lib/seed7/lib/vecfont18.s7i
lib/seed7/lib/vectorfont.s7i
lib/seed7/lib/window.s7i
lib/seed7/lib/wrinum.s7i
+lib/seed7/lib/x509cert.s7i
lib/seed7/lib/xml_ent.s7i
lib/seed7/lib/xmldom.s7i
lib/seed7/lib/zip.s7i
man/man1/s7.1.gz
man/man1/s7c.1.gz
-@dirrm lib/seed7/lib
@dirrm lib/seed7/bin
+@dirrm lib/seed7/lib/comp
+@dirrm lib/seed7/lib
@dirrm lib/seed7