aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2015-07-02 00:58:06 +0800
committergerald <gerald@FreeBSD.org>2015-07-02 00:58:06 +0800
commit5e5e0eed74ec919d77f9343732bbf7faf31f700c (patch)
tree874a88369e737322fdea7b980e294a3b35bd3806 /lang
parent6b60dedd977b5062b985940e36718fc3adca9fe3 (diff)
downloadfreebsd-ports-gnome-5e5e0eed74ec919d77f9343732bbf7faf31f700c.tar.gz
freebsd-ports-gnome-5e5e0eed74ec919d77f9343732bbf7faf31f700c.tar.zst
freebsd-ports-gnome-5e5e0eed74ec919d77f9343732bbf7faf31f700c.zip
Update to the 20150630 snapshot of GCC 5.
files/patch-pie-support is not longer necessary, andreast@ has pushed this backport upstream and it will thus also appear in the GCC 5.2 release.
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc5-devel/Makefile2
-rw-r--r--lang/gcc5-devel/distinfo4
-rw-r--r--lang/gcc5-devel/files/patch-pie-support73
3 files changed, 3 insertions, 76 deletions
diff --git a/lang/gcc5-devel/Makefile b/lang/gcc5-devel/Makefile
index 0a85d004020c..05f8a61acc37 100644
--- a/lang/gcc5-devel/Makefile
+++ b/lang/gcc5-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gcc
-PORTVERSION= 5.1.1.s20150623
+PORTVERSION= 5.1.1.s20150630
CATEGORIES= lang java
MASTER_SITES= GCC/snapshots/${DISTVERSION}
PKGNAMESUFFIX= ${SUFFIX}-devel
diff --git a/lang/gcc5-devel/distinfo b/lang/gcc5-devel/distinfo
index 5753850bc524..e0fe919f5f3d 100644
--- a/lang/gcc5-devel/distinfo
+++ b/lang/gcc5-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gcc-5-20150623.tar.bz2) = d4689d6e637f7e214fa59b1e244b68a8e786449ebcbbefa44f977e3005a30e01
-SIZE (gcc-5-20150623.tar.bz2) = 90747352
+SHA256 (gcc-5-20150630.tar.bz2) = b20a8b7e05caaf7c688440c76e5344bc728262ec68efc39c774073bf5e69a757
+SIZE (gcc-5-20150630.tar.bz2) = 90743492
diff --git a/lang/gcc5-devel/files/patch-pie-support b/lang/gcc5-devel/files/patch-pie-support
deleted file mode 100644
index 7fc70b40e715..000000000000
--- a/lang/gcc5-devel/files/patch-pie-support
+++ /dev/null
@@ -1,73 +0,0 @@
---- gcc/config/freebsd-spec.h.orig 2015-01-05 13:33:28.000000000 +0100
-+++ gcc/config/freebsd-spec.h 2015-05-19 12:13:47.863772000 +0200
-@@ -66,8 +66,9 @@
- "%{!shared: \
- %{pg:gcrt1.o%s} %{!pg:%{p:gcrt1.o%s} \
- %{!p:%{profile:gcrt1.o%s} \
-- %{!profile:crt1.o%s}}}} \
-- crti.o%s %{!shared:crtbegin.o%s} %{shared:crtbeginS.o%s}"
-+ %{!profile: \
-+ %{pie: Scrt1.o%s;:crt1.o%s}}}}} \
-+ crti.o%s %{static:crtbeginT.o%s;shared|pie:crtbeginS.o%s;:crtbegin.o%s}"
-
- /* Provide a ENDFILE_SPEC appropriate for FreeBSD. Here we tack on
- the magical crtend.o file (see crtstuff.c) which provides part of
-@@ -76,7 +77,7 @@
- `crtn.o'. */
-
- #define FBSD_ENDFILE_SPEC \
-- "%{!shared:crtend.o%s} %{shared:crtendS.o%s} crtn.o%s"
-+ "%{shared|pie:crtendS.o%s;:crtend.o%s} crtn.o%s"
-
- /* Provide a LIB_SPEC appropriate for FreeBSD as configured and as
- required by the user-land thread model. Before __FreeBSD_version
---- gcc/config/i386/freebsd.h.orig 2015-01-05 13:33:28.000000000 +0100
-+++ gcc/config/i386/freebsd.h 2015-05-19 12:13:47.865132000 +0200
-@@ -59,28 +59,15 @@
- #define SUBTARGET_EXTRA_SPECS \
- { "fbsd_dynamic_linker", FBSD_DYNAMIC_LINKER }
-
--/* Provide a STARTFILE_SPEC appropriate for FreeBSD. Here we add
-- the magical crtbegin.o file (see crtstuff.c) which provides part
-- of the support for getting C++ file-scope static object constructed
-- before entering `main'. */
--
--#undef STARTFILE_SPEC
--#define STARTFILE_SPEC \
-- "%{!shared: \
-- %{pg:gcrt1.o%s} %{!pg:%{p:gcrt1.o%s} \
-- %{!p:%{profile:gcrt1.o%s} \
-- %{!profile:crt1.o%s}}}} \
-- crti.o%s %{!shared:crtbegin.o%s} %{shared:crtbeginS.o%s}"
--
--/* Provide a ENDFILE_SPEC appropriate for FreeBSD. Here we tack on
-- the magical crtend.o file (see crtstuff.c) which provides part of
-- the support for getting C++ file-scope static object constructed
-- before entering `main', followed by a normal "finalizer" file,
-- `crtn.o'. */
--
--#undef ENDFILE_SPEC
--#define ENDFILE_SPEC \
-- "%{!shared:crtend.o%s} %{shared:crtendS.o%s} crtn.o%s"
-+/* Use the STARTFILE_SPEC from config/freebsd-spec.h. */
-+
-+#undef STARTFILE_SPEC
-+#define STARTFILE_SPEC FBSD_STARTFILE_SPEC
-+
-+/* Use the ENDFILE_SPEC from config/freebsd-spec.h. */
-+
-+#undef ENDFILE_SPEC
-+#define ENDFILE_SPEC FBSD_ENDFILE_SPEC
-
- /* Provide a LINK_SPEC appropriate for FreeBSD. Here we provide support
- for the special GCC options -static and -shared, which allow us to
---- gcc/testsuite/lib/target-supports.exp.orig 2015-03-26 00:35:54.000000000 +0100
-+++ gcc/testsuite/lib/target-supports.exp 2015-05-19 12:13:47.868191000 +0200
-@@ -952,6 +952,7 @@
-
- proc check_effective_target_pie { } {
- if { [istarget *-*-darwin\[912\]*]
-+ || [istarget *-*-freebsd*]
- || [istarget *-*-linux*]
- || [istarget *-*-gnu*] } {
- return 1;