aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2011-09-12 21:46:58 +0800
committergabor <gabor@FreeBSD.org>2011-09-12 21:46:58 +0800
commit62d04d90eca0deab3e6d0c6d2464a4e2e98c2160 (patch)
tree340d61bcebb3fd474659c01f02a4faf7d643ff6b /lang
parent81a4003af96d6d84755108a8c6319d5bb023bb8e (diff)
downloadfreebsd-ports-gnome-62d04d90eca0deab3e6d0c6d2464a4e2e98c2160.tar.gz
freebsd-ports-gnome-62d04d90eca0deab3e6d0c6d2464a4e2e98c2160.tar.zst
freebsd-ports-gnome-62d04d90eca0deab3e6d0c6d2464a4e2e98c2160.zip
- Track dependencies after databases/gdbm update
Diffstat (limited to 'lang')
-rw-r--r--lang/clisp/Makefile4
-rw-r--r--lang/elk/Makefile4
-rw-r--r--lang/fpc/Makefile.units2
-rw-r--r--lang/librep/Makefile3
-rw-r--r--lang/ofc/Makefile4
-rw-r--r--lang/perl5.10/Makefile4
-rw-r--r--lang/perl5.12/Makefile4
-rw-r--r--lang/perl5.14/Makefile4
-rw-r--r--lang/perl5.16/Makefile4
-rw-r--r--lang/perl5.8/Makefile4
-rw-r--r--lang/php4/Makefile.ext2
-rw-r--r--lang/php5/Makefile.ext2
-rw-r--r--lang/php52/Makefile.ext2
-rw-r--r--lang/php53/Makefile.ext2
-rw-r--r--lang/rubinius/Makefile3
-rw-r--r--lang/smalltalk/Makefile3
-rw-r--r--lang/xotcl/Makefile3
17 files changed, 29 insertions, 25 deletions
diff --git a/lang/clisp/Makefile b/lang/clisp/Makefile
index 82a5a4189bc2..a4f7dbaa813d 100644
--- a/lang/clisp/Makefile
+++ b/lang/clisp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= clisp
PORTVERSION= 2.49
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang lisp
MASTER_SITES= GNU/${PORTNAME}/release/${PORTVERSION}
@@ -123,7 +123,7 @@ CONFIGURE_ARGS+=--with-module=fastcgi
.endif
.if defined(WITH_GDBM)
-LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
CONFIGURE_ARGS+=--with-module=gdbm
.endif
diff --git a/lang/elk/Makefile b/lang/elk/Makefile
index 5dc584214b93..0d04da660fb6 100644
--- a/lang/elk/Makefile
+++ b/lang/elk/Makefile
@@ -7,14 +7,14 @@
PORTNAME= elk
PORTVERSION= 3.99.7
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang scheme
MASTER_SITES= http://sam.zoy.org/elk/
MAINTAINER= ports@FreeBSD.org
COMMENT= An embeddable Scheme interpreter
-LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
+LIB_DEPENDS= gdbm.4:${PORTSDIR}/databases/gdbm \
elf.0:${PORTSDIR}/devel/libelf
USE_BZIP2= yes
diff --git a/lang/fpc/Makefile.units b/lang/fpc/Makefile.units
index 8e5ecb2d40b2..24d3656a2e90 100644
--- a/lang/fpc/Makefile.units
+++ b/lang/fpc/Makefile.units
@@ -113,7 +113,7 @@ HAVE_EXAMPLES= true
.if ${PKGNAMESUFFIX} == "-gdbm"
. if defined(WITH_GDBM)
-LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS= gdbm.4:${PORTSDIR}/databases/gdbm
. endif
.endif
diff --git a/lang/librep/Makefile b/lang/librep/Makefile
index 9c65d49d3372..ef0b9c5114ab 100644
--- a/lang/librep/Makefile
+++ b/lang/librep/Makefile
@@ -7,13 +7,14 @@
PORTNAME= librep
PORTVERSION= 0.92.0
+PORTREVISION= 1
CATEGORIES= lang elisp gnome
MASTER_SITES= http://download.tuxfamily.org/librep/
MAINTAINER= ports@FreeBSD.org
COMMENT= An Emacs Lisp like runtime library
-LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
+LIB_DEPENDS= gdbm.4:${PORTSDIR}/databases/gdbm \
ffi.5:${PORTSDIR}/devel/libffi \
gmp.10:${PORTSDIR}/math/gmp
RUN_DEPENDS= gtar:${PORTSDIR}/archivers/gtar
diff --git a/lang/ofc/Makefile b/lang/ofc/Makefile
index 244e48544e74..288587d97831 100644
--- a/lang/ofc/Makefile
+++ b/lang/ofc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ofc
PORTVERSION= 0.8.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= lang
MASTER_SITES= http://ofc.dvoudheusden.net/download/
@@ -31,7 +31,7 @@ OPTIONS= GDBM "Add gdbm support" off \
GMP "Add gmp support" off
.if defined (WITH_GDBM)
-LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
.endif
.if defined (WITH_GMP)
diff --git a/lang/perl5.10/Makefile b/lang/perl5.10/Makefile
index 740d57c08c52..5ec1149df998 100644
--- a/lang/perl5.10/Makefile
+++ b/lang/perl5.10/Makefile
@@ -7,7 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VERSION}
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -104,7 +104,7 @@ PLIST_SUB+= SUIDPERL="@comment "
.if defined(WITH_GDBM)
CONFIGURE_ARGS+= -Di_gdbm
-LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
PLIST_SUB+= GDBM=""
.else
CONFIGURE_ARGS+= -Ui_gdbm
diff --git a/lang/perl5.12/Makefile b/lang/perl5.12/Makefile
index dc9130dbf0bf..abf55d82a456 100644
--- a/lang/perl5.12/Makefile
+++ b/lang/perl5.12/Makefile
@@ -7,7 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -94,7 +94,7 @@ CONFIGURE_ARGS+= -Doptimize="${CFLAGS}"
.if defined(WITH_GDBM)
CONFIGURE_ARGS+= -Di_gdbm
-LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
PLIST_SUB+= GDBM=""
.else
CONFIGURE_ARGS+= -Ui_gdbm
diff --git a/lang/perl5.14/Makefile b/lang/perl5.14/Makefile
index b847383570e0..e92cdfb32d51 100644
--- a/lang/perl5.14/Makefile
+++ b/lang/perl5.14/Makefile
@@ -7,7 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -94,7 +94,7 @@ CONFIGURE_ARGS+= -Doptimize="${CFLAGS}"
.if defined(WITH_GDBM)
CONFIGURE_ARGS+= -Di_gdbm
-LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
PLIST_SUB+= GDBM=""
.else
CONFIGURE_ARGS+= -Ui_gdbm
diff --git a/lang/perl5.16/Makefile b/lang/perl5.16/Makefile
index b847383570e0..e92cdfb32d51 100644
--- a/lang/perl5.16/Makefile
+++ b/lang/perl5.16/Makefile
@@ -7,7 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -94,7 +94,7 @@ CONFIGURE_ARGS+= -Doptimize="${CFLAGS}"
.if defined(WITH_GDBM)
CONFIGURE_ARGS+= -Di_gdbm
-LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
PLIST_SUB+= GDBM=""
.else
CONFIGURE_ARGS+= -Ui_gdbm
diff --git a/lang/perl5.8/Makefile b/lang/perl5.8/Makefile
index 7e734344f0eb..1f6910a195d5 100644
--- a/lang/perl5.8/Makefile
+++ b/lang/perl5.8/Makefile
@@ -7,7 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VERSION}
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -106,7 +106,7 @@ PLIST_SUB+= SUIDPERL="@comment "
.if defined(WITH_GDBM)
CONFIGURE_ARGS+= -Di_gdbm
-LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
PLIST_SUB+= GDBM=""
.else
CONFIGURE_ARGS+= -Ui_gdbm
diff --git a/lang/php4/Makefile.ext b/lang/php4/Makefile.ext
index 51886181626c..d6489c705a2b 100644
--- a/lang/php4/Makefile.ext
+++ b/lang/php4/Makefile.ext
@@ -401,7 +401,7 @@ LIB_DEPENDS+= db-4.4.0:${PORTSDIR}/databases/db44
CONFIGURE_ARGS+=--with-db4=${LOCALBASE}
. endif
. if defined(WITH_GDBM)
-LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
CONFIGURE_ARGS+=--with-gdbm=${LOCALBASE}
. endif
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index a7937042d8b8..3bd8be6799aa 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -454,7 +454,7 @@ USE_BDB= 40+
WITH_BDB_HIGHEST= yes
. endif
. if defined(WITH_GDBM)
-LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
CONFIGURE_ARGS+=--with-gdbm=${LOCALBASE}
. endif
diff --git a/lang/php52/Makefile.ext b/lang/php52/Makefile.ext
index 8fe58be1d3e5..a4f8159b0022 100644
--- a/lang/php52/Makefile.ext
+++ b/lang/php52/Makefile.ext
@@ -526,7 +526,7 @@ USE_BDB= 40+
WITH_BDB_HIGHEST= yes
. endif
. if defined(WITH_GDBM)
-LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
CONFIGURE_ARGS+=--with-gdbm=${LOCALBASE}
. endif
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index a7937042d8b8..3bd8be6799aa 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -454,7 +454,7 @@ USE_BDB= 40+
WITH_BDB_HIGHEST= yes
. endif
. if defined(WITH_GDBM)
-LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
CONFIGURE_ARGS+=--with-gdbm=${LOCALBASE}
. endif
diff --git a/lang/rubinius/Makefile b/lang/rubinius/Makefile
index 96dfb68d39a3..7d1759d56729 100644
--- a/lang/rubinius/Makefile
+++ b/lang/rubinius/Makefile
@@ -7,6 +7,7 @@
PORTNAME= rubinius
PORTVERSION= 1.2.4
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ftp://ftp.SpringDaemons.com/soft/ \
http://asset.rubini.us/prebuilt/:llvm
@@ -48,7 +49,7 @@ BROKEN= Does not compile on sparc64
.endif
.if !defined(WITHOUT_GDBM) || exists(${LOCALBASE}/include/gdbm.h)
-LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS= gdbm.4:${PORTSDIR}/databases/gdbm
PLIST_SUB+= GDBM=""
.else
PLIST_SUB+= GDBM="@comment "
diff --git a/lang/smalltalk/Makefile b/lang/smalltalk/Makefile
index 5580a2f88935..d047dbeb6af4 100644
--- a/lang/smalltalk/Makefile
+++ b/lang/smalltalk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= smalltalk
PORTVERSION= 3.2.4
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,7 +17,7 @@ COMMENT= GNU Smalltalk
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
gawk:${PORTSDIR}/lang/gawk
-LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
+LIB_DEPENDS= gdbm.4:${PORTSDIR}/databases/gdbm \
execinfo.1:${PORTSDIR}/devel/libexecinfo \
cairo.2:${PORTSDIR}/graphics/cairo
diff --git a/lang/xotcl/Makefile b/lang/xotcl/Makefile
index dadfdbdbfb9d..d76f18acb56c 100644
--- a/lang/xotcl/Makefile
+++ b/lang/xotcl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xotcl
PORTVERSION= 1.6.6
+PORTREVISION= 1
CATEGORIES?= lang tcl
MASTER_SITES= SF \
http://media.wu-wien.ac.at/download/
@@ -53,7 +54,7 @@ NO_BUILD= yes
.if defined(WITH_ACTIWEB)
CONFIGURE_ARGS+= --with-actiweb --with-gdbm=${LOCALBASE}/include,${LOCALBASE}/lib
-LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
PLIST_SUB+= ACTIWEB=""
.else
PLIST_SUB+= ACTIWEB="@comment "
?h=gnome-3.24&id=b204eefd9d12857a2e384c59753552fe8286fae5'>Bump PORTREVISIONS for all ports that depend on atk or pango to ease in themarcus2004-11-089-3/+9 * - Use OPTIONSpav2004-11-061-1/+13 * Update to version 1.3.3krion2004-11-023-14/+16 * Add myself to the mapahze2004-10-301-0/+1 * Change email to new FreeBSD.org addressahze2004-10-301-1/+1 * Update to version 6.2krion2004-10-274-15/+107 * SETI - Search for Extra-Terrestrial Intelligencepav2004-10-1813-0/+349 * Unbreak on 4.xvs2004-10-141-2/+2 * - Update to 3.6.1pav2004-10-122-3/+3 * BROKEN: Does not installkris2004-09-191-0/+2 * BROKEN on 5.x: Does not compilekris2004-09-181-0/+4 * Unbreak the build with recent GCC.danfe2004-09-161-0/+10 * Add a hackaround to allow gpsdrive to use serial devices on FreeBSD. Thedes2004-09-072-0/+14 * - Support the "CAVOK" string: "Ceiling and visibility OK"arved2004-09-042-1/+182 * Update to 0.12perky2004-09-033-12/+12 * - Update to 0.26pav2004-08-303-4/+4 * Add gkrellmoon2, a GKrellM 2 plugin showing a moon phaze.pav2004-08-307-0/+73 * Add myself and fjoe@.danfe2004-08-231-0/+1 * Fix build with gcc-3.4krion2004-08-221-0/+15 * Update to version 2.500krion2004-08-222-10/+22 * Add Ljubljana (with me in it) to the map.lesi2004-08-201-0/+1 * Add myself, my mentor :pclsung2004-08-201-1/+1 * Update my location using labs.pagesjaunes.fr as a reference.mat2004-08-171-1/+1 * Fix plist.krion2004-08-141-0/+3 * Add myself to Moscow committers bush.marck2004-08-121-1/+1 * - Add myselfvs2004-07-302-1/+2 * upgrade to 1.1.1ijliao2004-07-282-3/+3 * Move package files from plist to Makefile, remove pkg-plist.osa2004-07-273-2/+4 * Remove pkg-plist.osa2004-07-271-3/+0 * - Add forgotten WITHOUT_PNM knobsem2004-07-241-1/+8 * Fix test for existence of DISTFILES. Be a bit more verbose in the IGNOREtg2004-07-231-2/+9 * - Update to 1.1.0pav2004-07-232-17/+47 * Update to version 3.10.2krion2004-07-205-43/+37 * Update to 6.1.2krion2004-07-184-7/+32 * Do not include the package name in the comment.krion2004-07-182-2/+2 * Apply a big libtool patch to allow porters to use the libtool installed bymarcus2004-07-102-2/+2 * Fix WWW: linekrion2004-07-081-1/+1 * Use the new GConf handling policy, this will be required for GNOME 2.7/2.8 ormezz2004-07-081-4/+2 * Update to version 1.42krion2004-07-032-3/+3 * Add gdesklets-goodweather-psi, GoodWeather desklet with psi theme.pav2004-07-025-0/+63 * Update to version 1.38krion2004-06-282-4/+3 * Upgrade to 3.6.tg2004-06-253-11/+133 * Add alternate mastersite. (The original one seems to have been restoredlinimon2004-06-251-1/+2 * - Fix runtime on nvidia driverpav2004-06-222-0/+24 * Now builds on amd64kris2004-06-211-2/+2 * - Don't use Makefile.kde anymoremarkus2004-06-201-4/+3 * Update to version 6.1.1krion2004-06-164-14/+8 * - Update to version 0.6.0krion2004-06-135-112/+148 * Update to latest version:vs2004-06-095-28/+78 * - Update to 1.0.6pav2004-06-075-56/+63 * Update to 0.11erwin2004-05-312-3/+3 * - Remove dead WWWpav2004-05-302-4/+0 * remove gcc33 dependijliao2004-05-242-1/+10 * - Update MASTER_SITESpav2004-05-244-4/+4 * - Refresh MASTER_SITESpav2004-05-232-7/+5 * Remove the threads related REINPLACE again, the source comes withlofi2004-05-221-2/+1 * Remove inclusion of "${PORTSDIR}/x11/kde3/Makefile.kde", fix PTHREAD_LIBSlofi2004-05-221-4/+3 * Fix download location for polling data.linimon2004-05-172-5/+5 * put adamw, krion, ade, wes and others on the right spot in the file.edwin2004-05-101-5/+5 * Drop maintainership. Maintainer is not using FreeBSD aserwin2004-05-091-1/+1 * Respect CFLAGS and PTHREAD_LIBSmarkus2004-05-061-3/+4 * Update to 3.0.0markus2004-05-053-25/+11 * Remove reference to former maintainermarkus2004-05-041-3/+0