aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorimura <imura@FreeBSD.org>2000-01-15 00:34:17 +0800
committerimura <imura@FreeBSD.org>2000-01-15 00:34:17 +0800
commit71faf31e9709f095e363a7c55082201b82daf7d5 (patch)
tree9d198d1cbd69df536b717fc4c591ee1af0077424 /lang
parent40bca4fb72a18fdbb524cbdba84d6d952a9911a4 (diff)
downloadfreebsd-ports-gnome-71faf31e9709f095e363a7c55082201b82daf7d5.tar.gz
freebsd-ports-gnome-71faf31e9709f095e363a7c55082201b82daf7d5.tar.zst
freebsd-ports-gnome-71faf31e9709f095e363a7c55082201b82daf7d5.zip
- Merge scripts/configure into Makefile
- Add WWW: line of pkg/DESCR PR: 15915 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Diffstat (limited to 'lang')
-rw-r--r--lang/elk/Makefile32
-rw-r--r--lang/elk/pkg-descr2
2 files changed, 21 insertions, 13 deletions
diff --git a/lang/elk/Makefile b/lang/elk/Makefile
index 3e82102c2e9c..b6872b3b3eee 100644
--- a/lang/elk/Makefile
+++ b/lang/elk/Makefile
@@ -1,7 +1,7 @@
-# New ports collection makefile for: elk
-# Version required: 3.0pl3
-# Date created: 08 March 1995
-# Whom: Thomas Gellekum <tg@FreeBSD.org>
+# New ports collection makefile for: elk
+# Version required: 3.0pl3
+# Date created: 08 March 1995
+# Whom: Thomas Gellekum <tg@FreeBSD.org>
#
# $FreeBSD$
#
@@ -17,20 +17,26 @@ USE_XLIB= yes
ALL_TARGET= default
MAN1= elk.1
-#
-# we install the scheme binary as ${PREFIX}/bin/elk
-# to avoid a clash with mit-scheme.
-#
+post-patch:
+ @${CP} ${WRKSRC}/config/untested/386pc-freebsd2.1-cc \
+ ${WRKSRC}/config/system
+ @${CP} ${WRKSRC}/config/sites/386pc-freebsd2.1 \
+ ${WRKSRC}/config/site
pre-install:
@${MKDIR} ${PREFIX}/share/elk
+#
+# we install the scheme binary as ${PREFIX}/bin/elk
+# to avoid a clash with mit-scheme.
+#
post-install:
- @(cd ${PREFIX}/share/elk; \
- ${CP} bin/scheme ${PREFIX}/bin/elk; \
- ${MKDIR} ${PREFIX}/include/elk; \
- ${CP} -R include/* ${PREFIX}/include/elk; \
- ${RM} -rf bin include)
+ ${INSTALL_PROGRAM} ${PREFIX}/share/elk/bin/scheme ${PREFIX}/bin/elk
+ @${MKDIR} ${PREFIX}/include/elk
+ ${CP} -R ${PREFIX}/share/elk/include/* ${PREFIX}/include/elk
+.for dir in bin include
+ @${RM} -rf ${PREFIX}/share/elk/${dir}
+.endfor
@${INSTALL_MAN} ${WRKSRC}/doc/man/elk.1 ${PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/lang/elk/pkg-descr b/lang/elk/pkg-descr
index 50e4f9a7916d..0f95b7228ab0 100644
--- a/lang/elk/pkg-descr
+++ b/lang/elk/pkg-descr
@@ -8,3 +8,5 @@ mutually incompatible Lisp-like extension languages. Instead of
inventing and implementing yet another extension language, application
programmers can integrate Elk into their application to make it
extensible and highly customizable.
+
+WWW: http://www-rn.informatik.uni-bremen.de/software/elk/