aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-08-13 17:06:32 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-08-13 17:06:32 +0800
commit79f9ca0bb8421dd06793c9604b986657ad479bd0 (patch)
treedd3796b93ee6019d9a7e0c1d3909e697ee9de023 /lang
parent53f0bf6777b606f95bf13808659e3cdfa8a85806 (diff)
downloadfreebsd-ports-gnome-79f9ca0bb8421dd06793c9604b986657ad479bd0.tar.gz
freebsd-ports-gnome-79f9ca0bb8421dd06793c9604b986657ad479bd0.tar.zst
freebsd-ports-gnome-79f9ca0bb8421dd06793c9604b986657ad479bd0.zip
- Add CPE information
Diffstat (limited to 'lang')
-rw-r--r--lang/v8/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/lang/v8/Makefile b/lang/v8/Makefile
index 20800c30f418..174bb437e2d6 100644
--- a/lang/v8/Makefile
+++ b/lang/v8/Makefile
@@ -20,13 +20,15 @@ MAKE_ARGS= library=shared
MAKE_ENV= CC.host=${CC} CXX.host=${CXX} LINK.host=${CXX} LINK.target=${CXX}
USE_LDCONFIG= yes
USE_PYTHON= 2
-USES= compiler execinfo gmake tar:xz
+USES= compiler cpe execinfo gmake tar:xz
+
+CPE_VENDOR= google
.include <bsd.port.pre.mk>
.if ${COMPILER_TYPE} == clang
-MAKE_ENV+= LINK=clang++
CFLAGS+= -Wno-unused-private-field
+MAKE_ENV+= LINK=clang++
.if ${COMPILER_VERSION} >= 33
CFLAGS+= -Wno-nested-anon-types -Wno-unused-function
.if ${COMPILER_VERSION} >= 34