aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorcs <cs@FreeBSD.org>2014-06-06 05:55:01 +0800
committercs <cs@FreeBSD.org>2014-06-06 05:55:01 +0800
commit8e51ad60d5c55fc064f7cb10d200694f316af381 (patch)
tree89b77e76f3657ba71f7900e9822dcb074f8d98e4 /lang
parentec452a0c11c5b4ae27af20ef66c3f993b5b8d943 (diff)
downloadfreebsd-ports-gnome-8e51ad60d5c55fc064f7cb10d200694f316af381.tar.gz
freebsd-ports-gnome-8e51ad60d5c55fc064f7cb10d200694f316af381.tar.zst
freebsd-ports-gnome-8e51ad60d5c55fc064f7cb10d200694f316af381.zip
- Support staging
- Strip binaries - Pet portlint PR: 190504 Submitted by: vmagerya@gmail.com (maintainer)
Diffstat (limited to 'lang')
-rw-r--r--lang/petite-chez/Makefile10
-rw-r--r--lang/petite-chez/pkg-plist7
2 files changed, 10 insertions, 7 deletions
diff --git a/lang/petite-chez/Makefile b/lang/petite-chez/Makefile
index b0d6c159b951..87a7914067aa 100644
--- a/lang/petite-chez/Makefile
+++ b/lang/petite-chez/Makefile
@@ -19,7 +19,7 @@ ONLY_FOR_ARCHS= i386 amd64
NO_PACKAGE= User must accept license terms before installation
.if defined(PACKAGE_BUILDING)
-IGNORE= User must accept license terms before installation
+IGNORE= user must accept license terms before installation
.endif
OPTIONS_DEFINE= THREADS
@@ -29,18 +29,16 @@ HAS_CONFIGURE= yes
USES= iconv
CONFIGURE_ARGS= --installprefix=${PREFIX} \
--installman=${MANPREFIX}/man \
+ --temproot=${STAGEDIR} \
--force-relink \
--nogzip-man-pages \
-m=${CHEZ_MACHTYPE}
ALL_TARGET= build
-MAN1= petite.1
-
PLIST_SUB= CHEZ_VERSION="${PORTVERSION}" \
CHEZ_MACHTYPE="${CHEZ_MACHTYPE}"
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
@@ -75,4 +73,8 @@ post-configure:
-e 's|-L/usr/local/lib|-L/usr/lib -L${LOCALBASE}/lib|' \
${WRKSRC}/Mf-${CHEZ_MACHTYPE}
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/petite
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/scheme-script
+
.include <bsd.port.post.mk>
diff --git a/lang/petite-chez/pkg-plist b/lang/petite-chez/pkg-plist
index ff291a9ac2ba..f3ba13dc2d9f 100644
--- a/lang/petite-chez/pkg-plist
+++ b/lang/petite-chez/pkg-plist
@@ -27,6 +27,7 @@ lib/csv%%CHEZ_VERSION%%/lib/scons.ss
lib/csv%%CHEZ_VERSION%%/lib/setof.ss
lib/csv%%CHEZ_VERSION%%/lib/socket.ss
lib/csv%%CHEZ_VERSION%%/lib/unify.ss
-@dirrm lib/csv%%CHEZ_VERSION%%/lib
-@dirrm lib/csv%%CHEZ_VERSION%%/%%CHEZ_MACHTYPE%%
-@dirrm lib/csv%%CHEZ_VERSION%%
+man/man1/petite.1.gz
+@dirrmtry lib/csv%%CHEZ_VERSION%%/%%CHEZ_MACHTYPE%%
+@dirrmtry lib/csv%%CHEZ_VERSION%%/lib
+@dirrmtry lib/csv%%CHEZ_VERSION%%