aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-06-03 06:16:29 +0800
committerthierry <thierry@FreeBSD.org>2004-06-03 06:16:29 +0800
commit9253d454eec462853c79a857eb306711823a3816 (patch)
treeefb64d20adf6f3d9050983334f19df8b548e4d6d /lang
parentb3f47c81b64d897c0a8f563f3caeec77aad0d92a (diff)
downloadfreebsd-ports-gnome-9253d454eec462853c79a857eb306711823a3816.tar.gz
freebsd-ports-gnome-9253d454eec462853c79a857eb306711823a3816.tar.zst
freebsd-ports-gnome-9253d454eec462853c79a857eb306711823a3816.zip
Unbreak on -STABLE:
- dont use gcc 3.3 to link with qt; - disable sqlite on FreeBSD-4.x (at this time).
Diffstat (limited to 'lang')
-rw-r--r--lang/gambas/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/lang/gambas/Makefile b/lang/gambas/Makefile
index bc2bb8a4b5c1..68d52ff05854 100644
--- a/lang/gambas/Makefile
+++ b/lang/gambas/Makefile
@@ -23,7 +23,6 @@ USE_LIBTOOL_VER= 13
LIBTOOLFILES= configure libltdl/configure
LIBTOOLFLAGS= # none
USE_GMAKE= yes
-USE_GCC= 3.3
CONFIGURE_ARGS= --with-conv-includes=${LOCALBASE}/include \
--with-conv-libraries=${LOCALBASE}/lib \
--with-moc=${X11BASE}/bin
@@ -49,10 +48,6 @@ PLIST_SUB+= SDL="@comment "
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= "Does not run on FreeBSD-4.x at this time"
-.endif
-
.for lib in ${LIBS2FIX}
NEW${lib:U}!= ${LDCONFIG} -r | ${GREP} ${lib} | ${GREP} -v 'compat/pkg' \
| ${AWK} -F 'lib\/' '{print $$2}'
@@ -72,18 +67,17 @@ CONFIGURE_ARGS+= --without-postgresql-includes \
PLIST_SUB+= PGSQL="@comment "
.endif
-.if exists(${LOCALBASE}/include/sqlite.h)
+.if exists(${LOCALBASE}/include/sqlite.h) && ${OSVERSION} > 500000
WITH_SQLITE= yes
.endif
-.if defined(WITH_SQLITE)
+.if defined(WITH_SQLITE) && ${OSVERSION} > 500000
LIB_DEPENDS+= sqlite.2:${PORTSDIR}/databases/sqlite
CONFIGURE_ARGS+= --with-sqlite-includes=${LOCALBASE}/include \
--with-sqlite-libraries=${LOCALBASE}/lib
BUILD_DEPENDS+= ${LOCALBASE}/lib/libpub.a:${PORTSDIR}/devel/publib
PLIST_SUB+= SQLITE=""
.else
-CONFIGURE_ARGS+= --without-sqlite-includes \
- --without-sqlite-libraries
+CONFIGURE_ARGS+= --disable-sqlite
PLIST_SUB+= SQLITE="@comment "
.endif