aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2014-06-10 16:28:44 +0800
committerpi <pi@FreeBSD.org>2014-06-10 16:28:44 +0800
commit9cbad15bc1ce6e77ff4b907734f2b4397f424cd8 (patch)
tree7d253c8d02c7615bfe9e0a977b0e40f8611b9333 /lang
parentd75325f5ae838c633b64ff5a7345a8b88db16ae5 (diff)
downloadfreebsd-ports-gnome-9cbad15bc1ce6e77ff4b907734f2b4397f424cd8.tar.gz
freebsd-ports-gnome-9cbad15bc1ce6e77ff4b907734f2b4397f424cd8.tar.zst
freebsd-ports-gnome-9cbad15bc1ce6e77ff4b907734f2b4397f424cd8.zip
lang/perl5.20: fix warning in Math/BigInt.pm
See also https://rt.cpan.org/Public/Bug/Display.html?id=80182 PR: ports/185541 Approved-by: tobez (maintainer timeout), jadawin (mentor)
Diffstat (limited to 'lang')
-rw-r--r--lang/perl5.20/Makefile2
-rw-r--r--lang/perl5.20/files/patch-BigInt.pm11
2 files changed, 12 insertions, 1 deletions
diff --git a/lang/perl5.20/Makefile b/lang/perl5.20/Makefile
index c4d7b25a19be..8ff5b5a284a8 100644
--- a/lang/perl5.20/Makefile
+++ b/lang/perl5.20/Makefile
@@ -3,7 +3,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN \
${MASTER_SITE_LOCAL:S/$/:local/} \
diff --git a/lang/perl5.20/files/patch-BigInt.pm b/lang/perl5.20/files/patch-BigInt.pm
new file mode 100644
index 000000000000..8c56e2859ff4
--- /dev/null
+++ b/lang/perl5.20/files/patch-BigInt.pm
@@ -0,0 +1,11 @@
+--- dist/Math-BigInt/lib/Math/BigInt.pm-orig 2014-06-09 16:22:23.000000000 +0200
++++ dist/Math-BigInt/lib/Math/BigInt.pm 2014-06-09 16:22:54.000000000 +0200
+@@ -62,7 +62,7 @@
+ '>>=' => sub { $_[0]->brsft($_[1]); },
+
+ # not supported by Perl yet
+-'..' => \&_pointpoint,
++# '..' => \&_pointpoint,
+
+ '<=>' => sub { my $rc = $_[2] ?
+ ref($_[0])->bcmp($_[1],$_[0]) :