aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2007-02-19 03:58:54 +0800
committerale <ale@FreeBSD.org>2007-02-19 03:58:54 +0800
commita7ae9e0bd7668085c4870f80f3a225f2696454fc (patch)
tree79bb62fdd790773e8afcecf78e9c46025af79512 /lang
parent5752c4682ba551c5fa91cd6a083ddf20bf3f0253 (diff)
downloadfreebsd-ports-gnome-a7ae9e0bd7668085c4870f80f3a225f2696454fc.tar.gz
freebsd-ports-gnome-a7ae9e0bd7668085c4870f80f3a225f2696454fc.tar.zst
freebsd-ports-gnome-a7ae9e0bd7668085c4870f80f3a225f2696454fc.zip
Add an hack to avoid segmentation fault caused by session module loaded
after pspell module.
Diffstat (limited to 'lang')
-rw-r--r--lang/php5/Makefile.ext4
-rw-r--r--lang/php53/Makefile.ext4
2 files changed, 8 insertions, 0 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index c346bfcc65f7..c66efc3edc34 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -322,6 +322,10 @@ CONFIGURE_ARGS+=--enable-posix
LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+=--with-pspell=${LOCALBASE}
+
+# Ugly hack to load session before psell to avoid crashes
+USE_PHP= session
+USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "readline"
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index c346bfcc65f7..c66efc3edc34 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -322,6 +322,10 @@ CONFIGURE_ARGS+=--enable-posix
LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+=--with-pspell=${LOCALBASE}
+
+# Ugly hack to load session before psell to avoid crashes
+USE_PHP= session
+USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "readline"