aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2009-01-30 03:04:46 +0800
committerglarkin <glarkin@FreeBSD.org>2009-01-30 03:04:46 +0800
commitb3cb194d0c00c7e9dce37b69368a04622f923248 (patch)
tree6665f4b63798942193332530e40b823af3bb5d94 /lang
parente5095049949d94bbd6667bdd894b84fbf2aa4fce (diff)
downloadfreebsd-ports-gnome-b3cb194d0c00c7e9dce37b69368a04622f923248.tar.gz
freebsd-ports-gnome-b3cb194d0c00c7e9dce37b69368a04622f923248.tar.zst
freebsd-ports-gnome-b3cb194d0c00c7e9dce37b69368a04622f923248.zip
- Unbreak by removing reference to DynaLoader.a in Perl 5.8.9+
- Regenerate patch files with "make makepatch" - Take maintainership
Diffstat (limited to 'lang')
-rw-r--r--lang/eperl/Makefile20
-rw-r--r--lang/eperl/files/extra-patch-configure13
-rw-r--r--lang/eperl/files/patch-configure (renamed from lang/eperl/files/patch-ab)7
-rw-r--r--lang/eperl/files/patch-eperl_perl5.c (renamed from lang/eperl/files/patch-ac)4
-rw-r--r--lang/eperl/files/patch-eperl_perl5.h14
-rw-r--r--lang/eperl/files/patch-eperl_proto.h13
-rw-r--r--lang/eperl/files/patch-eperl_sys.c (renamed from lang/eperl/files/patch-aa)4
-rw-r--r--lang/eperl/pkg-plist52
8 files changed, 71 insertions, 56 deletions
diff --git a/lang/eperl/Makefile b/lang/eperl/Makefile
index 7ebc219c242d..3bc98670ba76 100644
--- a/lang/eperl/Makefile
+++ b/lang/eperl/Makefile
@@ -7,16 +7,14 @@
PORTNAME= eperl
PORTVERSION= 2.2.14
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang www perl5
MASTER_SITES= ${MASTER_SITE_OSSP}
MASTER_SITE_SUBDIR= tool/${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= glarkin@FreeBSD.org
COMMENT= Embedded Perl 5 Language
-BROKEN= does not compile
-
# User-controlled variables list
# INSTALL_ALSO_AS_SSSL
# install ePerl also as a Server-Side
@@ -38,6 +36,10 @@ MAN1= eperl.1
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} >= 500809
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-configure
+.endif
+
.if ${OSVERSION} >= 800058
BROKEN= does not build
.endif
@@ -53,16 +55,12 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/eperl ${PREFIX}/bin/eperl
${INSTALL_MAN} ${WRKSRC}/eperl.1 ${PREFIX}/man/man1/eperl.1
-.if !defined(NOPORTDOCS)
- @if [ ! -d ${EXAMPLESDIR} ]; then \
- ${MKDIR} ${EXAMPLESDIR}; \
- fi
+.if !defined(NOPORTEXAMPLES)
+ ${INSTALL} -d ${EXAMPLESDIR}
${CP} ${WRKSRC}/eg/* ${EXAMPLESDIR}/
.endif
.if defined(INSTALL_ALSO_AS_SSSL)
- @if [ ! -d ${PREFIX}/www/cgi-bin ]; then \
- ${MKDIR} ${PREFIX}/www/cgi-bin; \
- fi
+ ${INSTALL} -d ${PREFIX}/www/cgi-bin; \
${INSTALL_PROGRAM} ${WRKSRC}/eperl ${PREFIX}/www/cgi-bin/nph-eperl
@if [ ".`${GREP} x-httpd-eperl ${PREFIX}/etc/apache/srm.conf`" = . ]; then \
${ECHO_CMD} "AddType application/x-httpd-eperl .phtml .eperl .epl" \
diff --git a/lang/eperl/files/extra-patch-configure b/lang/eperl/files/extra-patch-configure
new file mode 100644
index 000000000000..6a08828a10a4
--- /dev/null
+++ b/lang/eperl/files/extra-patch-configure
@@ -0,0 +1,13 @@
+--- configure.orig 2009-01-29 13:51:15.000000000 -0500
++++ configure 2009-01-29 13:51:35.000000000 -0500
+@@ -710,7 +710,9 @@
+ #define HAVE_PERL_DYNALOADER 1
+ EOF
+
+- perl_dla=$perl_archlib/auto/DynaLoader/DynaLoader.a
++ # In Perl 5.8.9, DynaLoader functions are moved to libperl.so,
++ # so we don't need an extra library linked here.
++ perl_dla=
+ ;;
+ * )
+ rc=no
diff --git a/lang/eperl/files/patch-ab b/lang/eperl/files/patch-configure
index cda2fca32bcf..6b45af07a483 100644
--- a/lang/eperl/files/patch-ab
+++ b/lang/eperl/files/patch-configure
@@ -1,8 +1,5 @@
-
-$FreeBSD$
-
---- configure.orig Sun Aug 2 16:48:40 1998
-+++ configure Wed Jan 2 14:14:55 2002
+--- ./configure.orig 1998-08-02 09:48:40.000000000 -0400
++++ ./configure 2009-01-29 13:27:30.000000000 -0500
@@ -571,7 +571,7 @@
if test "${with_perl+set}" = set; then
withval="$with_perl"
diff --git a/lang/eperl/files/patch-ac b/lang/eperl/files/patch-eperl_perl5.c
index 23e6a5450db7..e944cce88a9a 100644
--- a/lang/eperl/files/patch-ac
+++ b/lang/eperl/files/patch-eperl_perl5.c
@@ -1,5 +1,5 @@
---- eperl_perl5.c.orig Fri Sep 8 00:29:14 2000
-+++ eperl_perl5.c Fri Sep 8 00:29:27 2000
+--- ./eperl_perl5.c.orig 1998-08-02 10:33:55.000000000 -0400
++++ ./eperl_perl5.c 2009-01-29 13:27:30.000000000 -0500
@@ -33,6 +33,8 @@
** eperl_perl5.c -- ePerl Perl5 related stuff
*/
diff --git a/lang/eperl/files/patch-eperl_perl5.h b/lang/eperl/files/patch-eperl_perl5.h
index da2f9083d0c9..a6083b17a354 100644
--- a/lang/eperl/files/patch-eperl_perl5.h
+++ b/lang/eperl/files/patch-eperl_perl5.h
@@ -1,10 +1,8 @@
-$FreeBSD$
-
---- eperl_perl5.h.orig Fri Jul 10 07:52:13 1998
-+++ eperl_perl5.h Wed Mar 1 12:12:32 2006
+--- ./eperl_perl5.h.orig 1998-07-10 03:52:13.000000000 -0400
++++ ./eperl_perl5.h 2009-01-29 13:27:30.000000000 -0500
@@ -43,10 +43,10 @@
-
-
+
+
/* try to adjust for PerlIO handling */
-#ifdef USE_PERLIO
-#undef fwrite
@@ -14,6 +12,6 @@ $FreeBSD$
+/* #undef fwrite */
+/* #define fwrite(buf,size,count,f) PerlIO_write(f,buf,size*count) */
+/* #endif */
-
-
+
+
/* define the I/O type string for verbosity */
diff --git a/lang/eperl/files/patch-eperl_proto.h b/lang/eperl/files/patch-eperl_proto.h
index 4b9b19e994d4..bc352637bfaf 100644
--- a/lang/eperl/files/patch-eperl_proto.h
+++ b/lang/eperl/files/patch-eperl_proto.h
@@ -1,5 +1,5 @@
---- eperl_proto.h.orig Fri Dec 15 01:27:39 2006
-+++ eperl_proto.h Fri Dec 15 01:27:51 2006
+--- ./eperl_proto.h.orig 1998-07-10 03:52:24.000000000 -0400
++++ ./eperl_proto.h 2009-01-29 13:27:30.000000000 -0500
@@ -35,6 +35,8 @@
#ifndef EPERL_PROTO_H
#define EPERL_PROTO_H 1
@@ -9,3 +9,12 @@
/*_BEGIN_PROTO_*/
/* eperl_main.c */
+@@ -79,7 +81,7 @@
+ extern char *ePerl_Efwrite(char *cpBuf, int nBuf, int cNum, char *cpOut);
+ extern char *ePerl_Cfwrite(char *cpBuf, int nBuf, int cNum, char *cpOut);
+ extern char *strnchr(char *buf, char chr, int n);
+-extern char *strnstr(char *buf, char *str, int n);
++extern char *ePerl_strnstr(char *buf, char *str, int n);
+ extern char *strncasestr(char *buf, char *str, int n);
+ extern char *strndup(char *buf, int n);
+ extern char *ePerl_Bristled2Plain(char *cpBuf);
diff --git a/lang/eperl/files/patch-aa b/lang/eperl/files/patch-eperl_sys.c
index 3d5bdaf12d5f..0827368ea134 100644
--- a/lang/eperl/files/patch-aa
+++ b/lang/eperl/files/patch-eperl_sys.c
@@ -1,5 +1,5 @@
---- eperl_sys.c.original Mon Jul 27 17:41:34 1998
-+++ eperl_sys.c Mon May 1 15:07:34 2000
+--- ./eperl_sys.c.orig 1998-07-27 04:41:34.000000000 -0400
++++ ./eperl_sys.c 2009-01-29 13:27:29.000000000 -0500
@@ -239,8 +239,8 @@
char timestr[128];
diff --git a/lang/eperl/pkg-plist b/lang/eperl/pkg-plist
index 25be2ae105ee..051277f9a108 100644
--- a/lang/eperl/pkg-plist
+++ b/lang/eperl/pkg-plist
@@ -3,29 +3,29 @@ bin/eperl
%%SSSL%%@exec echo "AddType application/x-httpd-eperl .phtml .eperl .epl" >>%D/etc/apache/srm.conf
%%SSSL%%@exec echo "Action application/x-httpd-eperl /cgi-bin/nph-eperl" >>%D/etc/apache/srm.conf
%%SSSL%%@unexec grep -v "application/x-httpd-eperl" %D/etc/apache/srm.conf >%D/etc/apache/srm.conf.bak; mv %D/etc/apache/srm.conf.bak %D/etc/apache/srm.conf
-%%PORTDOCS%%%%EXAMPLESDIR%%/00README
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.cgipm.phtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.cgipm.iphtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.env.phtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.env.iphtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.errout.phtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.errout.iphtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.errsyn.phtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.errsyn.iphtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.func.phtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.func.iphtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.html.phtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.html.iphtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.image.phtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.image.iphtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.lwp.phtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.lwp.iphtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.net.phtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.net.iphtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.pp.phtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.pp.iphtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.table.phtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.table.iphtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.text.phtml
-%%PORTDOCS%%%%EXAMPLESDIR%%/demo.text.iphtml
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/00README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.cgipm.phtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.cgipm.iphtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.env.phtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.env.iphtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.errout.phtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.errout.iphtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.errsyn.phtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.errsyn.iphtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.func.phtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.func.iphtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.html.phtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.html.iphtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.image.phtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.image.iphtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.lwp.phtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.lwp.iphtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.net.phtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.net.iphtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.pp.phtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.pp.iphtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.table.phtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.table.iphtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.text.phtml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.text.iphtml
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%