aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-05-13 12:03:21 +0800
committerdinoex <dinoex@FreeBSD.org>2003-05-13 12:03:21 +0800
commitb9270873846ba42cacdf48071eeccb90f76b99b4 (patch)
treee1cae88f48df3ca1ae82044ca6101aa2c763db70 /lang
parent870a4f26f137daa80a0a131c6fd83e38467b31f9 (diff)
downloadfreebsd-ports-gnome-b9270873846ba42cacdf48071eeccb90f76b99b4.tar.gz
freebsd-ports-gnome-b9270873846ba42cacdf48071eeccb90f76b99b4.tar.zst
freebsd-ports-gnome-b9270873846ba42cacdf48071eeccb90f76b99b4.zip
- use configures --includedir
- cleanup makefile
Diffstat (limited to 'lang')
-rw-r--r--lang/tcl83/Makefile7
-rw-r--r--lang/tcl83/files/patch-aa2
2 files changed, 4 insertions, 5 deletions
diff --git a/lang/tcl83/Makefile b/lang/tcl83/Makefile
index 0b9388b46dd5..0bd62be7c3f3 100644
--- a/lang/tcl83/Makefile
+++ b/lang/tcl83/Makefile
@@ -21,7 +21,7 @@ PATCH_DIST_ARGS= -d ${WRKDIR}/${DISTNAME} -E ${PATCH_DIST_STRIP}
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}/unix
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-shared
+CONFIGURE_ARGS= --enable-shared --includedir=${LOCALBASE}/include/tcl${TCL_VER}
CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
MAKE_ENV= SHORT_TCL_VER=83
PKGINSTALL= ${PKGDIR}/pkg-install.tclsh
@@ -29,7 +29,6 @@ PKGDEINSTALL= ${PKGDIR}/pkg-deinstall.tclsh
TCL_VER= 8.3
NOPRECIOUSMAKEVARS= yes # Otherwise 'make readmes' is broken
USE_REINPLACE= YES
-
PLIST_SUB= TCL_VER=${TCL_VER} SHORT_TCL_VER=83
MAN1= tclsh.1
@@ -422,12 +421,12 @@ MLINKS= Access.3 Tcl_Access.3 \
safe.n Safe\Base.n \
tcltest.n Tcltest.n
+.include <bsd.port.pre.mk>
+
post-configure:
${REINPLACE_CMD} -e 's=${WRKDIRPREFIX}${PORTSDIR}=$${WRKDIRPREFIX}${PORTSDIR}=' \
${WRKSRC}/tclConfig.sh
-.include <bsd.port.pre.mk>
-
post-install:
.if exists(${PKGINSTALL})
${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL}
diff --git a/lang/tcl83/files/patch-aa b/lang/tcl83/files/patch-aa
index 671ab4f73df7..b3dde591957d 100644
--- a/lang/tcl83/files/patch-aa
+++ b/lang/tcl83/files/patch-aa
@@ -5,7 +5,7 @@
# Directory in which to install the include file tcl.h:
-INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(includedir)
-+INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(includedir)/tcl$(VERSION)
++INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(includedir)
+GENERIC_INCLUDE_INSTALL_DIR = $(INCLUDE_INSTALL_DIR)/generic
+UNIX_INCLUDE_INSTALL_DIR = $(INCLUDE_INSTALL_DIR)/unix