aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorjdp <jdp@FreeBSD.org>1996-09-28 02:17:42 +0800
committerjdp <jdp@FreeBSD.org>1996-09-28 02:17:42 +0800
commitba0d5c02e6912c450db31e3b3df55b3345459a81 (patch)
tree0e7fa87fc22cb46ac99e2c611a8c80777f5d073e /lang
parent3cb0c5839dd1d7845cdefde1352f85781c850649 (diff)
downloadfreebsd-ports-gnome-ba0d5c02e6912c450db31e3b3df55b3345459a81.tar.gz
freebsd-ports-gnome-ba0d5c02e6912c450db31e3b3df55b3345459a81.tar.zst
freebsd-ports-gnome-ba0d5c02e6912c450db31e3b3df55b3345459a81.zip
In the post-extract target, chmod the gcc shell scripts to make
sure that they are executable. On at least one user's system, the copies taken from /usr/src/contrib did not have their execute bits set. Suggested by: max@wide.ad.jp
Diffstat (limited to 'lang')
-rw-r--r--lang/modula-3/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/modula-3/Makefile b/lang/modula-3/Makefile
index 1c3a355f2a99..e9a37e845dd0 100644
--- a/lang/modula-3/Makefile
+++ b/lang/modula-3/Makefile
@@ -3,7 +3,7 @@
# Date created: 18 Mar 1996
# Whom: John Polstra <jdp@polstra.com>
#
-# $Id: Makefile,v 1.4 1996/09/12 00:39:41 jdp Exp $
+# $Id: Makefile,v 1.5 1996/09/27 02:26:41 jdp Exp $
#
DISTNAME= modula-3-3.6
@@ -64,7 +64,6 @@ temp_prefix= ${WRKDIR}/installed
late_builds= m3configvars
post-extract:
- @${DO_NADA}
.if !empty(have_boot)
@echo "Copying bootstrap modula-3 compiler from ${have_boot}"
@/bin/sh ${SCRIPTDIR}/copy_files ${FILESDIR}/T.boot installed \
@@ -75,6 +74,8 @@ post-extract:
@/bin/sh ${SCRIPTDIR}/copy_files ${FILESDIR}/T.gcc m3cc \
${have_gcc} ${WRKDIR}
.endif
+ @cd ${WRKDIR}/m3cc/gcc; \
+ chmod +x config.sub configure move-if-change
do-build:
@test -d ${temp_prefix}/bin || mkdir -p ${temp_prefix}/bin