aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2014-11-08 13:22:30 +0800
committerache <ache@FreeBSD.org>2014-11-08 13:22:30 +0800
commitbd104bde34cb966b5cd95574073b4694da475346 (patch)
treed94d8467acf93f21238a7e3018e054246ec42130 /lang
parentd84b9d2f46f742d863d30d5ed7210e468d2278cc (diff)
downloadfreebsd-ports-gnome-bd104bde34cb966b5cd95574073b4694da475346.tar.gz
freebsd-ports-gnome-bd104bde34cb966b5cd95574073b4694da475346.tar.zst
freebsd-ports-gnome-bd104bde34cb966b5cd95574073b4694da475346.zip
Handle the case when dtrace build is disabled (WITHOUT_CDDL=yes)
Approved by: swills
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby20/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/lang/ruby20/Makefile b/lang/ruby20/Makefile
index f0067f64a700..2402b70bc4ac 100644
--- a/lang/ruby20/Makefile
+++ b/lang/ruby20/Makefile
@@ -86,7 +86,9 @@ CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.if ${OPSYS} == "FreeBSD"
-.if (${ARCH} == "i386" && ${OSVERSION} > 1010000) || (${ARCH} == "amd64" && ${OSVERSION} > 903000)
+.if exists(/usr/sbin/dtrace) && \
+ ((${ARCH} == "i386" && ${OSVERSION} > 1010000) || \
+ (${ARCH} == "amd64" && ${OSVERSION} > 903000))
CONFIGURE_ARGS+= --enable-dtrace
.else
CONFIGURE_ARGS+= --disable-dtrace