aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2012-06-14 14:02:52 +0800
committerdemon <demon@FreeBSD.org>2012-06-14 14:02:52 +0800
commitea78382bbfb9a5d59d1a5340f7fd5ea18bc0422d (patch)
treebbd44983d3b0848005289d58aa42d379ae14e7da /lang
parentb9fc224b353a2b89468aff837d15a83db76f7885 (diff)
downloadfreebsd-ports-gnome-ea78382bbfb9a5d59d1a5340f7fd5ea18bc0422d.tar.gz
freebsd-ports-gnome-ea78382bbfb9a5d59d1a5340f7fd5ea18bc0422d.tar.zst
freebsd-ports-gnome-ea78382bbfb9a5d59d1a5340f7fd5ea18bc0422d.zip
Fix permissions for Tools and Demo folders.
PR: 152224 Submitted by: John Hein <jhein@symmetricom.com> Silence from: python@
Diffstat (limited to 'lang')
-rw-r--r--lang/python27/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 75ebf61a2d18..2b9458b5b6f6 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -146,6 +146,12 @@ CONFIGURE_ARGS+= --disable-ipv6
CONFIGURE_ARGS+= --with-fpectl
.endif
+post-extract:
+# The distribution tarball for python 2.7 has permission bits for 'others'
+# set to 0. Later during install, we copy Tools and Demo to the installed
+# prefix, so set them right here.
+ ${CHMOD} -R og=u-w ${PYTHON_WRKSRC}/Tools ${PYTHON_WRKSRC}/Demo
+
pre-patch:
${CP} -r ${PATCH_WRKSRC}/Lib/plat-freebsd8 \
${PATCH_WRKSRC}/Lib/plat-freebsd9
@@ -267,12 +273,12 @@ post-install:
.if !defined(NOPORTDATA)
@${MKDIR} ${DATADIR}
@cd ${PYTHON_WRKSRC}; ${TAR} -cf - Tools | \
- (cd ${DATADIR}; ${TAR} -xf -)
+ (cd ${DATADIR}; ${TAR} --no-same-owner -xf -)
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@cd ${PYTHON_WRKSRC}/Demo; ${TAR} -cf - * | \
- (cd ${EXAMPLESDIR}; ${TAR} -xf -)
+ (cd ${EXAMPLESDIR}; ${TAR} --no-same-owner -xf -)
.endif
@${CAT} ${PKGMESSAGE}