aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-04-26 00:17:31 +0800
committermat <mat@FreeBSD.org>2016-04-26 00:17:31 +0800
commitedc4b1a149e328e94d71fd41a78496b9387bd43e (patch)
tree3ae246ccbda59847628903cdf71a3645fe2d5a86 /lang
parentdffbc9bf81bcdcd58f45ad1d4512e6f15c851854 (diff)
downloadfreebsd-ports-gnome-edc4b1a149e328e94d71fd41a78496b9387bd43e.tar.gz
freebsd-ports-gnome-edc4b1a149e328e94d71fd41a78496b9387bd43e.tar.zst
freebsd-ports-gnome-edc4b1a149e328e94d71fd41a78496b9387bd43e.zip
Move MySQL support from bsd.databases.mk to Uses/mysql.mk.
Also, USE_MYSQL can't happen after bsd.port.pre.mk because it is a USES. PR: 208971 Submitted by: mat Exp-run by: antoine With hat: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D5951
Diffstat (limited to 'lang')
-rw-r--r--lang/harbour/Makefile2
-rw-r--r--lang/php55/Makefile.ext68
-rw-r--r--lang/php56/Makefile.ext68
-rw-r--r--lang/php70/Makefile.ext38
4 files changed, 88 insertions, 88 deletions
diff --git a/lang/harbour/Makefile b/lang/harbour/Makefile
index 8ecb7e4749ef..c94d607c6e14 100644
--- a/lang/harbour/Makefile
+++ b/lang/harbour/Makefile
@@ -90,6 +90,7 @@ MAKE_ENV= HB_ARCHITECTURE=${HB_ARCH} \
PGSQL_USES= pgsql
FIREBIRD_USES= firebird
+MYSQL_USES= mysql
.include <bsd.port.pre.mk>
@@ -115,7 +116,6 @@ PLIST_SUB+= SQLITE="@comment "
.endif
.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
MAKE_ENV+= HB_WITH_MYSQL=nolocal
.else
MAKE_ENV+= HB_WITH_MYSQL=no
diff --git a/lang/php55/Makefile.ext b/lang/php55/Makefile.ext
index 69a16f499b15..5845e3d41f1a 100644
--- a/lang/php55/Makefile.ext
+++ b/lang/php55/Makefile.ext
@@ -499,6 +499,40 @@ CONFIGURE_ARGS+=--disable-flatfile
. endif
.endif
+.if ${PHP_MODNAME} == "mysql"
+. if ${PORT_OPTIONS:MMYSQLND}
+CONFIGURE_ARGS+=--with-mysql=mysqlnd
+. else
+CONFIGURE_ARGS+=--with-mysql=${LOCALBASE} \
+ --with-zlib-dir=/usr
+
+USES+= mysql
+. endif
+.endif
+
+.if ${PHP_MODNAME} == "mysqli"
+. if ${PORT_OPTIONS:MMYSQLND}
+CONFIGURE_ARGS+=--with-mysqli=mysqlnd
+. else
+CONFIGURE_ARGS+=--with-mysqli=${LOCALBASE}/bin/mysql_config
+
+USES+= mysql
+. endif
+.endif
+
+.if ${PHP_MODNAME} == "pdo_mysql"
+. if ${PORT_OPTIONS:MMYSQLND}
+CONFIGURE_ARGS+=--with-pdo-mysql=mysqlnd
+
+USE_PHP+= mysql
+. else
+CONFIGURE_ARGS+=--with-pdo-mysql=${LOCALBASE} \
+ --with-zlib-dir=/usr
+
+USES+= mysql
+. endif
+.endif
+
.include <bsd.port.pre.mk>
.if ${PHP_MODNAME} == "gd"
@@ -542,27 +576,6 @@ CONFIGURE_ARGS+=--disable-mbregex
. endif
.endif
-.if ${PHP_MODNAME} == "mysql"
-. if ${PORT_OPTIONS:MMYSQLND}
-CONFIGURE_ARGS+=--with-mysql=mysqlnd
-. else
-CONFIGURE_ARGS+=--with-mysql=${LOCALBASE} \
- --with-zlib-dir=/usr
-
-USE_MYSQL= yes
-. endif
-.endif
-
-.if ${PHP_MODNAME} == "mysqli"
-. if ${PORT_OPTIONS:MMYSQLND}
-CONFIGURE_ARGS+=--with-mysqli=mysqlnd
-. else
-CONFIGURE_ARGS+=--with-mysqli=${LOCALBASE}/bin/mysql_config
-
-USE_MYSQL= yes
-. endif
-.endif
-
.if ${PHP_MODNAME} == "openssl" || ${PHP_MODNAME} == "sqlite3"
post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
@@ -576,19 +589,6 @@ LIB_DEPENDS+= libct.so:databases/freetds
. endif
.endif
-.if ${PHP_MODNAME} == "pdo_mysql"
-. if ${PORT_OPTIONS:MMYSQLND}
-CONFIGURE_ARGS+=--with-pdo-mysql=mysqlnd
-
-USE_PHP+= mysql
-. else
-CONFIGURE_ARGS+=--with-pdo-mysql=${LOCALBASE} \
- --with-zlib-dir=/usr
-
-USE_MYSQL= yes
-. endif
-.endif
-
.if ${PHP_MODNAME} == "xml"
post-extract:
@${MKDIR} ${WRKSRC}/ext/xml
diff --git a/lang/php56/Makefile.ext b/lang/php56/Makefile.ext
index 8ed5295444be..fec5aff98418 100644
--- a/lang/php56/Makefile.ext
+++ b/lang/php56/Makefile.ext
@@ -502,6 +502,40 @@ CONFIGURE_ARGS+=--disable-flatfile
. endif
.endif
+.if ${PHP_MODNAME} == "mysql"
+. if ${PORT_OPTIONS:MMYSQLND}
+CONFIGURE_ARGS+=--with-mysql=mysqlnd
+. else
+CONFIGURE_ARGS+=--with-mysql=${LOCALBASE} \
+ --with-zlib-dir=/usr
+
+USES+= mysql
+. endif
+.endif
+
+.if ${PHP_MODNAME} == "mysqli"
+. if ${PORT_OPTIONS:MMYSQLND}
+CONFIGURE_ARGS+=--with-mysqli=mysqlnd
+. else
+CONFIGURE_ARGS+=--with-mysqli=${LOCALBASE}/bin/mysql_config
+
+USES+= mysql
+. endif
+.endif
+
+.if ${PHP_MODNAME} == "pdo_mysql"
+. if ${PORT_OPTIONS:MMYSQLND}
+CONFIGURE_ARGS+=--with-pdo-mysql=mysqlnd
+
+USE_PHP+= mysql
+. else
+CONFIGURE_ARGS+=--with-pdo-mysql=${LOCALBASE} \
+ --with-zlib-dir=/usr
+
+USES+= mysql
+. endif
+.endif
+
.include <bsd.port.pre.mk>
.if ${PHP_MODNAME} == "gd"
@@ -545,27 +579,6 @@ CONFIGURE_ARGS+=--disable-mbregex
. endif
.endif
-.if ${PHP_MODNAME} == "mysql"
-. if ${PORT_OPTIONS:MMYSQLND}
-CONFIGURE_ARGS+=--with-mysql=mysqlnd
-. else
-CONFIGURE_ARGS+=--with-mysql=${LOCALBASE} \
- --with-zlib-dir=/usr
-
-USE_MYSQL= yes
-. endif
-.endif
-
-.if ${PHP_MODNAME} == "mysqli"
-. if ${PORT_OPTIONS:MMYSQLND}
-CONFIGURE_ARGS+=--with-mysqli=mysqlnd
-. else
-CONFIGURE_ARGS+=--with-mysqli=${LOCALBASE}/bin/mysql_config
-
-USE_MYSQL= yes
-. endif
-.endif
-
.if ${PHP_MODNAME} == "openssl" || ${PHP_MODNAME} == "sqlite3"
post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
@@ -579,19 +592,6 @@ LIB_DEPENDS+= libct.so:databases/freetds
. endif
.endif
-.if ${PHP_MODNAME} == "pdo_mysql"
-. if ${PORT_OPTIONS:MMYSQLND}
-CONFIGURE_ARGS+=--with-pdo-mysql=mysqlnd
-
-USE_PHP+= mysql
-. else
-CONFIGURE_ARGS+=--with-pdo-mysql=${LOCALBASE} \
- --with-zlib-dir=/usr
-
-USE_MYSQL= yes
-. endif
-.endif
-
.if ${PHP_MODNAME} == "xml"
post-extract:
@${MKDIR} ${WRKSRC}/ext/xml
diff --git a/lang/php70/Makefile.ext b/lang/php70/Makefile.ext
index 88c8d16e5b7e..043949cc8cb8 100644
--- a/lang/php70/Makefile.ext
+++ b/lang/php70/Makefile.ext
@@ -494,6 +494,25 @@ CONFIGURE_ARGS+=--disable-flatfile
. endif
.endif
+.if ${PHP_MODNAME} == "mysqli"
+. if ${PORT_OPTIONS:MMYSQLND}
+CONFIGURE_ARGS+=--with-mysqli=mysqlnd
+. else
+CONFIGURE_ARGS+=--with-mysqli=${LOCALBASE}/bin/mysql_config
+USES+= mysql
+. endif
+.endif
+
+.if ${PHP_MODNAME} == "pdo_mysql"
+. if ${PORT_OPTIONS:MMYSQLND}
+CONFIGURE_ARGS+=--with-pdo-mysql=mysqlnd
+. else
+CONFIGURE_ARGS+=--with-pdo-mysql=${LOCALBASE} \
+ --with-zlib-dir=/usr
+USES+= mysql
+. endif
+.endif
+
.include <bsd.port.pre.mk>
.if ${PHP_MODNAME} == "gd"
@@ -537,25 +556,6 @@ CONFIGURE_ARGS+=--disable-mbregex
. endif
.endif
-.if ${PHP_MODNAME} == "mysqli"
-. if ${PORT_OPTIONS:MMYSQLND}
-CONFIGURE_ARGS+=--with-mysqli=mysqlnd
-. else
-CONFIGURE_ARGS+=--with-mysqli=${LOCALBASE}/bin/mysql_config
-USE_MYSQL= yes
-. endif
-.endif
-
-.if ${PHP_MODNAME} == "pdo_mysql"
-. if ${PORT_OPTIONS:MMYSQLND}
-CONFIGURE_ARGS+=--with-pdo-mysql=mysqlnd
-. else
-CONFIGURE_ARGS+=--with-pdo-mysql=${LOCALBASE} \
- --with-zlib-dir=/usr
-USE_MYSQL= yes
-. endif
-.endif
-
.if ${PHP_MODNAME} == "openssl" || ${PHP_MODNAME} == "sqlite3"
post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4