aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-02-18 07:04:57 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-02-18 07:04:57 +0800
commitf145f6aae5420d70d5f78245dba34161817e68fa (patch)
tree8dd8935e9fc19b464216f70c0281c9c1845eaf25 /lang
parentd8151f6abc29a75e1be2a823200ccf7913328d2a (diff)
downloadfreebsd-ports-gnome-f145f6aae5420d70d5f78245dba34161817e68fa.tar.gz
freebsd-ports-gnome-f145f6aae5420d70d5f78245dba34161817e68fa.tar.zst
freebsd-ports-gnome-f145f6aae5420d70d5f78245dba34161817e68fa.zip
- Mark broken on 8.x - gdc fails to link anything
May be tested on simple hello world: --- import std.stdio; int main() { std.stdio.writefln("Hello World!"); std.stdio.readln; return 0; } --- gdc test.d -o test --- /usr/local/lib/gcc/i386-portbld-freebsd8.0/../../libgphobos.a(math.o)(.text+0xa45): In function `_D3std4math6tgammaFeZe': ../.././../gcc-4.1-20080428/libphobos/std/math.d:1136: undefined reference to `tgammal' ...
Diffstat (limited to 'lang')
-rw-r--r--lang/gdc/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/lang/gdc/Makefile b/lang/gdc/Makefile
index 15fd2b16befe..e6578574cabc 100644
--- a/lang/gdc/Makefile
+++ b/lang/gdc/Makefile
@@ -49,6 +49,10 @@ GDC_INC= ${PREFIX}/include/d/${GCC_VERSION}
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 800000
+BROKEN= fails to link any executables on 8.x
+.endif
+
.ifndef TARGET_GCC
.if ${OSVERSION} >= 700000 || ${ARCH} == "amd64"
TARGET_GCC= 4.1