aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2018-08-07 20:41:26 +0800
committergahr <gahr@FreeBSD.org>2018-08-07 20:41:26 +0800
commit19be0fa6dd8e006d5a3ba84c369997f1a54ec07a (patch)
tree26261994fa7c0a2248731f6c1a1461e2a36c93a7 /lang
parent3722a928fbcc2bb16af0b96c502b765594bf1441 (diff)
downloadfreebsd-ports-gnome-19be0fa6dd8e006d5a3ba84c369997f1a54ec07a.tar.gz
freebsd-ports-gnome-19be0fa6dd8e006d5a3ba84c369997f1a54ec07a.tar.zst
freebsd-ports-gnome-19be0fa6dd8e006d5a3ba84c369997f1a54ec07a.zip
lang/io-devel: new port, development snapshot of lang/io
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/io-devel/Makefile31
-rw-r--r--lang/io-devel/distinfo5
-rw-r--r--lang/io-devel/pkg-descr5
-rw-r--r--lang/io-devel/pkg-message7
-rw-r--r--lang/io-devel/pkg-plist112
-rw-r--r--lang/io/Makefile2
7 files changed, 163 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 137fb00c0363..5b651a203d36 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -147,6 +147,7 @@
SUBDIR += icon
SUBDIR += intercal
SUBDIR += io
+ SUBDIR += io-devel
SUBDIR += itcl
SUBDIR += itcl4
SUBDIR += jakarta-commons-jelly
diff --git a/lang/io-devel/Makefile b/lang/io-devel/Makefile
new file mode 100644
index 000000000000..24ac96d4cc98
--- /dev/null
+++ b/lang/io-devel/Makefile
@@ -0,0 +1,31 @@
+# Created by: gahr
+# $FreeBSD$
+
+PORTNAME= io
+PORTVERSION= 20180807
+CATEGORIES= lang
+PKGNAMESUFFIX= -devel
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= Small prototype-based programming language (devel version)
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+CONFLICTS= io-[0-9]*
+
+USES= cmake:outsource,noninja compiler:c11
+
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= IoLanguage
+GH_TAGNAME= 9bfac31d
+
+GH_TUPLE+= kgabis:parson:4f3eaa6:parson/deps/parson
+
+MAKE_JOBS_UNSAFE= yes
+
+CMAKE_ARGS= -DWITHOUT_EERIE:BOOL=ON
+
+.include <bsd.port.mk>
diff --git a/lang/io-devel/distinfo b/lang/io-devel/distinfo
new file mode 100644
index 000000000000..75aec436390b
--- /dev/null
+++ b/lang/io-devel/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1533644788
+SHA256 (IoLanguage-io-20180807-9bfac31d_GH0.tar.gz) = e2da7f22ec9bb1b45a2546f53f52b450a57d6b58ed4799db4354beab95e94a09
+SIZE (IoLanguage-io-20180807-9bfac31d_GH0.tar.gz) = 1120166
+SHA256 (kgabis-parson-4f3eaa6_GH0.tar.gz) = e23f2714bc30f105166005fa664269053923ec0b51caa7cbe13f4299b2f7d22d
+SIZE (kgabis-parson-4f3eaa6_GH0.tar.gz) = 23094
diff --git a/lang/io-devel/pkg-descr b/lang/io-devel/pkg-descr
new file mode 100644
index 000000000000..cab216db2560
--- /dev/null
+++ b/lang/io-devel/pkg-descr
@@ -0,0 +1,5 @@
+Io is a dynamic prototype-based programming language in the same realm as
+Smalltalk and Self. It revolves around the idea of message passing from object
+to object.
+
+WWW: http://iolanguage.org/
diff --git a/lang/io-devel/pkg-message b/lang/io-devel/pkg-message
new file mode 100644
index 000000000000..249b868fcfde
--- /dev/null
+++ b/lang/io-devel/pkg-message
@@ -0,0 +1,7 @@
+** A note about Addons **
+
+Addons are no longer part of Io core. Most are now hosted on their dedicated
+repositories under https://github.com/IoLanguage.
+
+Addons are managed using the Eerie package manager, which can be installed
+following the instructions at https://github.com/IoLanguage/eerie.
diff --git a/lang/io-devel/pkg-plist b/lang/io-devel/pkg-plist
new file mode 100644
index 000000000000..c11d3c80d38b
--- /dev/null
+++ b/lang/io-devel/pkg-plist
@@ -0,0 +1,112 @@
+bin/io
+bin/io_static
+include/io/386-ucontext.h
+include/io/BStream.h
+include/io/BStreamTag.h
+include/io/Base.h
+include/io/CHash.h
+include/io/CHash_inline.h
+include/io/Collector.h
+include/io/CollectorMarker.h
+include/io/CollectorMarker_inline.h
+include/io/Collector_inline.h
+include/io/Common.h
+include/io/Common_inline.h
+include/io/Coro.h
+include/io/Date.h
+include/io/Duration.h
+include/io/DynLib.h
+include/io/Hash_fnv.h
+include/io/Hash_murmur.h
+include/io/Hash_superfast.h
+include/io/IoBlock.h
+include/io/IoCFunction.h
+include/io/IoCall.h
+include/io/IoCollector.h
+include/io/IoCompiler.h
+include/io/IoConfig.h
+include/io/IoContext.h
+include/io/IoCoroutine.h
+include/io/IoDate.h
+include/io/IoDebugger.h
+include/io/IoDirectory.h
+include/io/IoDuration.h
+include/io/IoDynLib.h
+include/io/IoError.h
+include/io/IoFile.h
+include/io/IoFile_stat.h
+include/io/IoInstallPrefix.h
+include/io/IoLexer.h
+include/io/IoList.h
+include/io/IoMap.h
+include/io/IoMessage.h
+include/io/IoMessage_inline.h
+include/io/IoMessage_opShuffle.h
+include/io/IoMessage_parser.h
+include/io/IoNumber.h
+include/io/IoObject.h
+include/io/IoObject_flow.h
+include/io/IoObject_inline.h
+include/io/IoObject_struct.h
+include/io/IoProfiler.h
+include/io/IoSandbox.h
+include/io/IoSeq.h
+include/io/IoSeq_immutable.h
+include/io/IoSeq_inline.h
+include/io/IoSeq_mutable.h
+include/io/IoSeq_vector.h
+include/io/IoState.h
+include/io/IoState_callbacks.h
+include/io/IoState_coros.h
+include/io/IoState_debug.h
+include/io/IoState_eval.h
+include/io/IoState_exceptions.h
+include/io/IoState_inline.h
+include/io/IoState_symbols.h
+include/io/IoSystem.h
+include/io/IoTag.h
+include/io/IoTag_inline.h
+include/io/IoToken.h
+include/io/IoVM.h
+include/io/IoVMApi.h
+include/io/IoVersion.h
+include/io/IoWeakLink.h
+include/io/List.h
+include/io/List_inline.h
+include/io/MainArgs.h
+include/io/PHash.h
+include/io/PHash_inline.h
+include/io/PHash_struct.h
+include/io/PointerHash.h
+include/io/PointerHash_inline.h
+include/io/PointerHash_struct.h
+include/io/PortableGettimeofday.h
+include/io/PortableSorting.h
+include/io/PortableStdint.h
+include/io/PortableStrlcpy.h
+include/io/PortableStrptime.h
+include/io/PortableTruncate.h
+include/io/PortableUsleep.h
+include/io/RandomGen.h
+include/io/Stack.h
+include/io/Stack_inline.h
+include/io/UArray.h
+include/io/UArray_character.h
+include/io/UArray_format.h
+include/io/UArray_math.h
+include/io/UArray_path.h
+include/io/UArray_stream.h
+include/io/UArray_string.h
+include/io/UArray_utf.h
+include/io/amd64-ucontext.h
+include/io/cdecode.h
+include/io/cencode.h
+include/io/power-ucontext.h
+include/io/taskimpl.h
+include/io/utf8.h
+include/io/utf8internal.h
+include/io/utf_convert.h
+lib/libbasekit.so
+lib/libcoroutine.so
+lib/libgarbagecollector.so
+lib/libiovmall.so
diff --git a/lang/io/Makefile b/lang/io/Makefile
index 695baf9e6c65..b19e7aa864b6 100644
--- a/lang/io/Makefile
+++ b/lang/io/Makefile
@@ -11,6 +11,8 @@ COMMENT= Small prototype-based programming language
LICENSE= BSD3CLAUSE
+CONFLICTS= io-devel-[0-9]*
+
BROKEN_armv6= fails to compile: ucontext.h: expected parameter declarator
BROKEN_armv7= fails to compile: Coro.c:392:2: no member named 'arm_r0' in 'mcontext_t'
BROKEN_powerpc64= fails to build: unrecognized command line option -msse2