aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2012-09-12 04:16:20 +0800
committerolgeni <olgeni@FreeBSD.org>2012-09-12 04:16:20 +0800
commit8bb604a5eacfea8a1c00c6907f74128f81cb96fe (patch)
tree67f7469650c46a882570b695f5762d959588a84d /lang
parent21ad7494c83c5692b07b7cf427648a9761e881c0 (diff)
downloadfreebsd-ports-gnome-8bb604a5eacfea8a1c00c6907f74128f81cb96fe.tar.gz
freebsd-ports-gnome-8bb604a5eacfea8a1c00c6907f74128f81cb96fe.tar.zst
freebsd-ports-gnome-8bb604a5eacfea8a1c00c6907f74128f81cb96fe.zip
Add configuration check: DTRACE support on amd64 requires GCC46 to
be enabled. Building with gcc version 4.2.1 20070831 causes an infinite loop while compiling erl_nif.c. Discovered by: Kenji Rikitake
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 8d4cab2f592c..6c6d9f2acb3f 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -70,6 +70,10 @@ ERL_RELEASE= R${PORTVERSION:S/.//g:U}
# probes fixed does not match the number of defined probes (54 != 132,
# respectively)" you probably misconfigured DTrace in some way.
+.if ${ARCH} == "amd64" && ${PORT_OPTIONS:MDTRACE} && ! ${PORT_OPTIONS:MGCC46}
+IGNORE= DTRACE support on amd64 requires GCC46 option
+.endif
+
.if ${PORT_OPTIONS:MGCC46}
USE_GCC?= 4.6+
.endif