aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2013-11-24 22:03:44 +0800
committerkoobs <koobs@FreeBSD.org>2013-11-24 22:03:44 +0800
commitf336f58fc9206a089564c665de3f88c01e1eb8ae (patch)
tree7ff7665ecd0f28205372bf2617a86596d0c8c2ab /lang
parent084fbcebbe6f39d64e9e504d14e7259a8f9bb98e (diff)
downloadfreebsd-ports-gnome-f336f58fc9206a089564c665de3f88c01e1eb8ae.tar.gz
freebsd-ports-gnome-f336f58fc9206a089564c665de3f88c01e1eb8ae.tar.zst
freebsd-ports-gnome-f336f58fc9206a089564c665de3f88c01e1eb8ae.zip
lang/python26: Fix CFLAGS in python-config where cc = clang
- Temporarily override OPT:Olimit using CONFIGURE_ENV (ports/182952) [1] - Replace patch: extra-patch-configure-pth with CONFIGURE_ENV instead - QA: Clean up and group related USE_*, WRKSRC and CONFIGURE entries - QA: Whitespace alignment - QA: Clarify DEPRECATED message [1] Python removed OPT:Olimit in 3.2+, requested backport or alternative upstream patch: http://bugs.python.org/issue877121 PR: ports/182952 Submitted by: pawel Reviewed by: antoine
Diffstat (limited to 'lang')
-rw-r--r--lang/python26/Makefile19
-rw-r--r--lang/python26/files/extra-patch-configure-pth12
2 files changed, 11 insertions, 20 deletions
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 243723e12c6e..963191f3d7d7 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -3,6 +3,7 @@
PORTNAME= python26
PORTVERSION= 2.6.9
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -11,26 +12,28 @@ DISTFILES= ${PYTHON_DISTFILE}
MAINTAINER= python@FreeBSD.org
COMMENT= Interpreted object-oriented programming language
-DEPRECATED= This port reached its EoL upstream, please migrate to lang/python27
+DEPRECATED= Python 2.6 is now end-of-life, please migrate to lang/python27
EXPIRATION_DATE=2014-01-01
DIST_SUBDIR= python
-WRKSRC= ${PYTHON_WRKSRC}/portbld.static
-PATCH_WRKSRC= ${PYTHON_WRKSRC}
GNU_CONFIGURE= yes
CONFIGURE_SCRIPT= ../configure # must be relative
-CONFIGURE_ENV= SVNVERSION="echo freebsd"
+CONFIGURE_ENV= SVNVERSION="echo freebsd" ac_cv_opt_olimit_ok=no
MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
-USE_LDCONFIG= yes
INSTALL_TARGET= altinstall
MAN1= ${PYTHON_VERSION}.1
+USE_LDCONFIG= yes
USE_PYTHON= yes
USE_XZ= yes
-PYTHON_VERSION= python2.6
+
+PYTHON_VERSION= python2.6
PYTHON_NO_DEPENDS= yes
+WRKSRC= ${PYTHON_WRKSRC}/portbld.static
SHARED_WRKSRC= ${PYTHON_WRKSRC}/portbld.shared
+PATCH_WRKSRC= ${PYTHON_WRKSRC}
+
PLIST= ${WRKDIR}/PLIST
PLIST_TEMPLATE?=${PKGDIR}/pkg-plist
PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//} \
@@ -53,7 +56,7 @@ BINLINKS_SUB_PYTHON_VER= ${BINLINKS_SUB_TMPL:S/%%VERSION%%/${PYTHON_VER}/g}
OPTIONS_DEFINE= THREADS SEM PTH PYMALLOC IPV6 FPECTL EXAMPLES NLS
OPTIONS_DEFAULT= THREADS UCS4 PYMALLOC IPV6
-OPTIONS_SINGLE= UCS
+OPTIONS_SINGLE= UCS
OPTIONS_SINGLE_UCS= UCS2 UCS4
NLS_DESC= Enable Gettext support for the locale module
@@ -92,7 +95,7 @@ SUB_LIST= SEM=${SEM_MSG}
PLIST_SUB+= THREADS=""
.if ${PORT_OPTIONS:MPTH}
CONFIGURE_ARGS+= --with-pth
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-configure-pth
+CONFIGURE_ENV+= ac_cv_pthread=no
LIB_DEPENDS+= pth:${PORTSDIR}/devel/pth
_PTH_CPPFLAGS= "-I${LOCALBASE}/include/pth"
_PTH_LDFLAGS= "-L${LOCALBASE}/lib/pth"
diff --git a/lang/python26/files/extra-patch-configure-pth b/lang/python26/files/extra-patch-configure-pth
deleted file mode 100644
index 707ff0d378f6..000000000000
--- a/lang/python26/files/extra-patch-configure-pth
+++ /dev/null
@@ -1,12 +0,0 @@
---- configure.orig 2010-09-13 09:44:44.000000000 +0800
-+++ configure 2010-09-13 09:47:25.000000000 +0800
-@@ -5693,6 +5693,9 @@
- CC="$ac_save_cc"
- fi
-
-+# XXX Explicitly disable system pthread libraries.
-+ac_cv_pthread=no
-+
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_pthread" >&5
- $as_echo "$ac_cv_pthread" >&6; }
- fi