aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-09-22 13:30:31 +0800
committerlinimon <linimon@FreeBSD.org>2018-09-22 13:30:31 +0800
commit12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5 (patch)
treeee1202c5a5464562474562e70212261185323b7d /lang
parent82b2604cbc93a294ed39ce8da691d406c1342992 (diff)
downloadfreebsd-ports-gnome-12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5.tar.gz
freebsd-ports-gnome-12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5.tar.zst
freebsd-ports-gnome-12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5.zip
Fix build on gcc-based archs by updating USES.
Tested on powerpc64 and amd64 (for no regression). While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'lang')
-rw-r--r--lang/sdcc/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/lang/sdcc/Makefile b/lang/sdcc/Makefile
index b6849da26914..d2db619a5c28 100644
--- a/lang/sdcc/Makefile
+++ b/lang/sdcc/Makefile
@@ -2,8 +2,8 @@
PORTNAME= sdcc
PORTVERSION= 3.7.0
-PORTREVISION= 1
DISTVERSIONPREFIX= src-
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= SF
@@ -12,11 +12,13 @@ COMMENT= Small Device C Compiler
LICENSE= GPLv3
+BROKEN_aarch64= Fails to configure: BFD does not support target aarch64-portbld-freebsd11.0
+
BUILD_DEPENDS= ${LOCALBASE}/include/boost/graph/adjacency_list.hpp:devel/boost-libs
CONFLICTS_INSTALL= sdcc-[0-9]* sdcc-devel-[0-9]*
GNU_CONFIGURE= yes
-USES= bison gmake readline:port python:2.7,run shebangfix tar:bzip2
+USES= bison compiler:c++11-lang gmake readline:port python:2.7,run shebangfix tar:bzip2
SHEBANG_FILES= support/scripts/as2gbmap.py
OPTIONS_DEFINE= DEVLIB DOCS UCSIM
@@ -51,8 +53,6 @@ Z80_CONFIGURE_OFF= --disable-gbz80-port --disable-r2k-port \
--disable-r3ka-port --disable-tlcs90-port \
--disable-z180-port --disable-z80-port
-BROKEN_aarch64= Fails to configure: BFD does not support target aarch64-portbld-freebsd11.0
-
.include <bsd.port.options.mk>
.if ${ARCH} == "amd64"