aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-03-30 21:14:12 +0800
committersobomax <sobomax@FreeBSD.org>2002-03-30 21:14:12 +0800
commit1aa5f4a1a56ea2817cee928991b97c514feadb5c (patch)
treeae84d24fe8382435e4a64bdc2e3171ef600aba41 /lang
parent2cf3d27d3a466c15a1d7ed23383e33b1ee72b3bf (diff)
downloadfreebsd-ports-gnome-1aa5f4a1a56ea2817cee928991b97c514feadb5c.tar.gz
freebsd-ports-gnome-1aa5f4a1a56ea2817cee928991b97c514feadb5c.tar.zst
freebsd-ports-gnome-1aa5f4a1a56ea2817cee928991b97c514feadb5c.zip
Make it impossible to install the software without reading the license first.
Diffstat (limited to 'lang')
-rw-r--r--lang/cli/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/lang/cli/Makefile b/lang/cli/Makefile
index 790f0a6f9d1d..a7b1734d3d2c 100644
--- a/lang/cli/Makefile
+++ b/lang/cli/Makefile
@@ -44,6 +44,15 @@ do-build:
@${CHMOD} 700 ${WRKSRC} # <- we need this because build system creates world-writeable dirs
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${SH} env.sh ./buildall)
+.if !defined(I_AGREE_TO_A_LICENSE_TERMS)
+pre-install:
+ @${ECHO_MSG} "Please make sure that you have read and understood license terms contained in"
+ @${ECHO_MSG} "the ${WRKSRC}/license.txt file and if you"
+ @${ECHO_MSG} "agree with them then add -DI_AGREE_TO_A_LICENSE_TERMS to command line to"
+ @${ECHO_MSG} "install the software (i.e. 'make -DI_AGREE_TO_A_LICENSE_TERMS install')."
+ @${FALSE}
+.endif
+
do-install:
@${MKDIR} ${PREFIX}/cli-${PORTVERSION}
@${INSTALL_DATA} ${WRKSRC}/license.txt ${PREFIX}/cli-${PORTVERSION}