aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2012-08-17 21:16:43 +0800
committerolgeni <olgeni@FreeBSD.org>2012-08-17 21:16:43 +0800
commit2c3a5991e59757556e296c25216f14cdb1e924cc (patch)
treeabbb6fd6495a28f8c846ff7612267254b9c0a4b7 /lang
parent67fd0204e1ceb247172e34281c2c75fdfb3d6f5d (diff)
downloadfreebsd-ports-gnome-2c3a5991e59757556e296c25216f14cdb1e924cc.tar.gz
freebsd-ports-gnome-2c3a5991e59757556e296c25216f14cdb1e924cc.tar.zst
freebsd-ports-gnome-2c3a5991e59757556e296c25216f14cdb1e924cc.zip
Add experimental DTrace support.
Obtained from: Kenji Rikitake's Erlang port on github https://github.com/jj1bdx/erlang-freebsd-port
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang/Makefile17
1 files changed, 16 insertions, 1 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index aede724adb7f..ccee9b07be97 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -44,7 +44,7 @@ SUB_LIST= TOOLS_VSN=${TOOLS_VSN}
MAKE_JOBS_UNSAFE=yes
-OPTIONS_DEFINE= DOCS GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREADS WX
+OPTIONS_DEFINE= DOCS GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREADS WX DTRACE
OPTIONS_SINGLE= ODBC
OPTIONS_SINGLE_ODBC= IODBC UNIXODBC
@@ -54,11 +54,26 @@ SCTP_DESC= Enable SCTP support
SMP_DESC= Enable SMP support
WX_DESC= Enable WX application
GS_DESC= Enable GS application (deprecated)
+DTRACE_DESC= Enable DTrace support (experimental)
OPTIONS_DEFAULT=SMP OPENSSL THREADS SCTP KQUEUE
.include <bsd.port.options.mk>
+# See http://wiki.freebsd.org/DTrace to learn how to enable DTrace
+# on your system. You will need to configure STRIP, WITH_CTF and
+# CFLAGS in your make.conf before building.
+
+# If you run Erlang and get a message resembling "WARNING: number of
+# probes fixed does not match the number of defined probes (54 != 132,
+# respectively)" you probably misconfigured DTrace in some way.
+
+.if ${PORT_OPTIONS:MDTRACE}
+CONFIGURE_ARGS+=--with-dynamic-trace=dtrace
+.else
+CONFIGURE_ARGS+=--without-dynamic-trace
+.endif
+
.if ${PORT_OPTIONS:MOPENSSL}
USE_OPENSSL= yes
CONFIGURE_ARGS+=--with-ssl=${OPENSSLBASE}