aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2004-01-26 20:58:14 +0800
committerale <ale@FreeBSD.org>2004-01-26 20:58:14 +0800
commit32c025b8b8e9a3b2c9872ddc7e0150ab60d95d81 (patch)
treebed710635ead797cad5df2bf9d1c49b376a09f82 /lang
parent4600de13684e82268c08790bb35062297485e5f0 (diff)
downloadfreebsd-ports-gnome-32c025b8b8e9a3b2c9872ddc7e0150ab60d95d81.tar.gz
freebsd-ports-gnome-32c025b8b8e9a3b2c9872ddc7e0150ab60d95d81.tar.zst
freebsd-ports-gnome-32c025b8b8e9a3b2c9872ddc7e0150ab60d95d81.zip
- Add support for PTHREAD_{LIBS/CFLAGS} [1]
- Add support for FastCGI [2] - Fix PEAR installation in a particular scenario [3] PR: ports/61790 [2] Submitted by: clement [1], Xavier Beaudouin <kiwi@oav.net> [2], Balazs Nagy <js@iksz.hu> [3] Approved by: nork (mentor/implicitly)
Diffstat (limited to 'lang')
-rw-r--r--lang/php4/Makefile15
-rw-r--r--lang/php4/files/patch-pear::Makefile.frag4
-rw-r--r--lang/php5/Makefile12
-rw-r--r--lang/php5/files/patch-pear::Makefile.frag4
-rw-r--r--lang/php53/Makefile12
-rw-r--r--lang/php53/files/patch-pear::Makefile.frag4
6 files changed, 33 insertions, 18 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index 5c66d0944dcb..2a3f9579de14 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -67,6 +67,9 @@ GNU_CONFIGURE= yes
USE_BISON= yes
USE_REINPLACE= yes
+CONFIGURE_ENV= ac_cv_pthreads_lib=${PTHREAD_LIBS} \
+ ac_cv_pthreads_cflags=${PTHREAD_CFLAGS}
+
CONFIGURE_ARGS= --enable-versioning \
--enable-memory-limit \
--with-layout=GNU \
@@ -103,7 +106,14 @@ CONFLICTS= php4-4* php4-cli-4* php4-cgi-4*
CONFLICTS+= php5-5* php5-cli-5* mod_php5-5* php5-cgi-5*
.if defined(WITHOUT_APACHE)
+.if defined(WITHOUT_CLI)
+.if defined(WITH_FASTCGI)
+CONFIGURE_ARGS+=--enable-fastcgi
+.else
CONFIGURE_ARGS+=--enable-discard-path
+.endif
+SAPI_FILE= bin/php
+.endif
PLIST_SUB+= APACHE="@comment "
.else
PLIST_SUB+= APACHE=""
@@ -121,9 +131,6 @@ PLIST_SUB+= PEAR="@comment "
MAN1= php.1
PLIST_SUB+= CLI=""
.endif
-.if defined(WITHOUT_APACHE) && defined(WITHOUT_CLI)
-SAPI_FILE= "bin/php"
-.endif
ALL_OPTIONS= BCMATH BZIP2 CALENDAR CDB CRACK CTYPE CURL DB4 DBASE DBX DIO \
DOMXML DOMXSLT EXIF FILEPRO FRIBIDI FTP GD GDBM GETTEXT \
@@ -692,7 +699,7 @@ test: all
.endif
post-install:
-.if !defined(WITHOUT_CLI)
+.if !defined(WITHOUT_CLI) && !defined(WITHOUT_PEAR)
@${INSTALL_SCRIPT} ${WRKSRC}/pear/scripts/pear ${PREFIX}/bin
.endif
@${INSTALL_DATA} ${WRKSRC}/php.ini-dist ${PREFIX}/etc
diff --git a/lang/php4/files/patch-pear::Makefile.frag b/lang/php4/files/patch-pear::Makefile.frag
index 6653c7852f69..060066c367b6 100644
--- a/lang/php4/files/patch-pear::Makefile.frag
+++ b/lang/php4/files/patch-pear::Makefile.frag
@@ -17,6 +17,6 @@
+ $(INSTALL_ROOT)$(peardir)/bootstrap
+ @cp $(srcdir)/Archive/*.php $(INSTALL_ROOT)$(peardir)/bootstrap/Archive
+ @cp $(srcdir)/Console/*.php $(INSTALL_ROOT)$(peardir)/bootstrap/Console
-+ @cp -R $(srcdir)/OS $(INSTALL_ROOT)$(peardir)/bootstrap/OS
-+ @cp -R $(srcdir)/PEAR $(INSTALL_ROOT)$(peardir)/bootstrap/PEAR
++ @cp -R $(srcdir)/OS $(INSTALL_ROOT)$(peardir)/bootstrap
++ @cp -R $(srcdir)/PEAR $(INSTALL_ROOT)$(peardir)/bootstrap
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index b2f71a4bf5f1..43afe764eb32 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -67,6 +67,9 @@ GNU_CONFIGURE= yes
USE_BISON= yes
USE_REINPLACE= yes
+CONFIGURE_ENV= ac_cv_pthreads_lib=${PTHREAD_LIBS} \
+ ac_cv_pthreads_cflags=${PTHREAD_CFLAGS}
+
CONFIGURE_ARGS= --enable-versioning \
--enable-memory-limit \
--with-layout=GNU \
@@ -103,7 +106,12 @@ CONFLICTS+= php4-4* php4-cli-4* mod_php4-4* php4-cgi-4*
.if defined(WITHOUT_APACHE)
.if defined(WITHOUT_CLI)
+.if defined(WITH_FASTCGI)
+CONFIGURE_ARGS+=--enable-fastcgi
+.else
CONFIGURE_ARGS+=--enable-discard-path
+.endif
+SAPI_FILE= bin/php
.else
CONFIGURE_ARGS+=--disable-cgi
.endif
@@ -124,9 +132,6 @@ PLIST_SUB+= PEAR="@comment "
MAN1= php.1
PLIST_SUB+= CLI=""
.endif
-.if defined(WITHOUT_APACHE) && defined(WITHOUT_CLI)
-SAPI_FILE= "bin/php"
-.endif
ALL_OPTIONS= BCMATH BZIP2 CALENDAR CDB CRACK CTYPE CURL DB4 DBASE DBX DIO \
DOM EXIF FILEPRO FTP GD GDBM GETTEXT GMP ICONV IMAP INTERBASE \
@@ -534,7 +539,6 @@ CONFIGURE_ARGS+=--with-zlib
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_APACHE)
-APXS?= ${LOCALBASE}/sbin/apxs
.if exists(${LOCALBASE}/include/apache2/apr.h)
WITH_APACHE2= yes
APACHE_MPM!= ${APXS} -q MPM_NAME
diff --git a/lang/php5/files/patch-pear::Makefile.frag b/lang/php5/files/patch-pear::Makefile.frag
index 6653c7852f69..060066c367b6 100644
--- a/lang/php5/files/patch-pear::Makefile.frag
+++ b/lang/php5/files/patch-pear::Makefile.frag
@@ -17,6 +17,6 @@
+ $(INSTALL_ROOT)$(peardir)/bootstrap
+ @cp $(srcdir)/Archive/*.php $(INSTALL_ROOT)$(peardir)/bootstrap/Archive
+ @cp $(srcdir)/Console/*.php $(INSTALL_ROOT)$(peardir)/bootstrap/Console
-+ @cp -R $(srcdir)/OS $(INSTALL_ROOT)$(peardir)/bootstrap/OS
-+ @cp -R $(srcdir)/PEAR $(INSTALL_ROOT)$(peardir)/bootstrap/PEAR
++ @cp -R $(srcdir)/OS $(INSTALL_ROOT)$(peardir)/bootstrap
++ @cp -R $(srcdir)/PEAR $(INSTALL_ROOT)$(peardir)/bootstrap
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index b2f71a4bf5f1..43afe764eb32 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -67,6 +67,9 @@ GNU_CONFIGURE= yes
USE_BISON= yes
USE_REINPLACE= yes
+CONFIGURE_ENV= ac_cv_pthreads_lib=${PTHREAD_LIBS} \
+ ac_cv_pthreads_cflags=${PTHREAD_CFLAGS}
+
CONFIGURE_ARGS= --enable-versioning \
--enable-memory-limit \
--with-layout=GNU \
@@ -103,7 +106,12 @@ CONFLICTS+= php4-4* php4-cli-4* mod_php4-4* php4-cgi-4*
.if defined(WITHOUT_APACHE)
.if defined(WITHOUT_CLI)
+.if defined(WITH_FASTCGI)
+CONFIGURE_ARGS+=--enable-fastcgi
+.else
CONFIGURE_ARGS+=--enable-discard-path
+.endif
+SAPI_FILE= bin/php
.else
CONFIGURE_ARGS+=--disable-cgi
.endif
@@ -124,9 +132,6 @@ PLIST_SUB+= PEAR="@comment "
MAN1= php.1
PLIST_SUB+= CLI=""
.endif
-.if defined(WITHOUT_APACHE) && defined(WITHOUT_CLI)
-SAPI_FILE= "bin/php"
-.endif
ALL_OPTIONS= BCMATH BZIP2 CALENDAR CDB CRACK CTYPE CURL DB4 DBASE DBX DIO \
DOM EXIF FILEPRO FTP GD GDBM GETTEXT GMP ICONV IMAP INTERBASE \
@@ -534,7 +539,6 @@ CONFIGURE_ARGS+=--with-zlib
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_APACHE)
-APXS?= ${LOCALBASE}/sbin/apxs
.if exists(${LOCALBASE}/include/apache2/apr.h)
WITH_APACHE2= yes
APACHE_MPM!= ${APXS} -q MPM_NAME
diff --git a/lang/php53/files/patch-pear::Makefile.frag b/lang/php53/files/patch-pear::Makefile.frag
index 6653c7852f69..060066c367b6 100644
--- a/lang/php53/files/patch-pear::Makefile.frag
+++ b/lang/php53/files/patch-pear::Makefile.frag
@@ -17,6 +17,6 @@
+ $(INSTALL_ROOT)$(peardir)/bootstrap
+ @cp $(srcdir)/Archive/*.php $(INSTALL_ROOT)$(peardir)/bootstrap/Archive
+ @cp $(srcdir)/Console/*.php $(INSTALL_ROOT)$(peardir)/bootstrap/Console
-+ @cp -R $(srcdir)/OS $(INSTALL_ROOT)$(peardir)/bootstrap/OS
-+ @cp -R $(srcdir)/PEAR $(INSTALL_ROOT)$(peardir)/bootstrap/PEAR
++ @cp -R $(srcdir)/OS $(INSTALL_ROOT)$(peardir)/bootstrap
++ @cp -R $(srcdir)/PEAR $(INSTALL_ROOT)$(peardir)/bootstrap