aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2005-01-01 02:24:10 +0800
committernetchild <netchild@FreeBSD.org>2005-01-01 02:24:10 +0800
commit41aa99b87f1fc1de75ee54ee38b4782ee393704b (patch)
tree377e4c9c9dd556f0b4785f3df7b930015778713f /lang
parent0a7250c8120524f20b14e530af6f7eddf2e77d1e (diff)
downloadfreebsd-ports-gnome-41aa99b87f1fc1de75ee54ee38b4782ee393704b.tar.gz
freebsd-ports-gnome-41aa99b87f1fc1de75ee54ee38b4782ee393704b.tar.zst
freebsd-ports-gnome-41aa99b87f1fc1de75ee54ee38b4782ee393704b.zip
Say hello to the linux mega patch, it consolidates our linux bits a
little bit and allows to proceed to a more recent linux_base from a stable (read as: the major bugs should be ironed out or identified and most linux ports build just fine) source. It also allows to ship 4.11 with a working linuxolator (the EOLed linux_base is marked forbidden because of a security hole). This is a major update, please read UPDATING (and CHANGES if you develop linux ports). Changes: - change the default linux_base from v7 to v8 - add a newer freetype to linux_base-8 for nicer fonts display [1] - don't let cpio use hardlinks in the linux_base-8 port to quiet some warnings in some cases [2] - fix a cut&past error in the linux_base-8 pkg-install script [3] - convert the binary knob "USE_LINUX" to a version specifier, e.g. USE_LINUX=<value> specifies a dependency upon emulators/linux_base-<value>, exceptions are a value of "7" (which does what you want and adds a dependency to linux_base) and any value without a corresponding port in PORTSDIR/emulators/linux_base-<value> (which adds a dependency to the default linux_base) - don't implicitly add USE_LINUX with the USE_LINUX_PREFIX knob, this allows us to use the USE_LINUX_PREFIX knob for linux_base and paves the way for splitting up future linux base ports into individual pieces - remove RESTRICTED from some GPL licensed ports, even when we only distribute binaries, we get them from official linux sites, so anyone can grab them there if he needs to - add a dependency upon the linux X11 bits where necessary (based upon guesswork) - don't use USE_X_PREFIX in some linux ports since it adds a dependency to the FreeBSD X11 libs, as a workaround use PREFIX?= (the clean solution would be to remove the implicit USE_XLIB from USE_X_PREFIX) - bump the portrevision of the linux ports ("better safe than sorry" algorithm) - pass maintainership of the important linux infrastructure to a mailinglist, hijack freebsd-emulation@ for this purpose (if somebody doesn't like this: tell us your bikeshed color at freebsd-emulation@, my color would be "linuxolator@" in case someone cares...) - add a pkg-install script for linux-fontconfig, but don't use it; everything should work without it (the FreeBSD fc-cache program should do all the work), but in case we need it we just need to decomment the pkg-install part in the Makefile - fix some dependencies - fix some bugs - add some static plists - unbreak the ports with dependecies to more than one linux_base This also fixes some ports which are marked BROKEN because of dependencies to v7 and v8 of linux_base at the same time. Known bugs: - the linux-mesa and linux-devtools ports install libGL*.so symlinks - some "minor" plist bugs (e.g. ld.so.{conf,cache} are modified by the linux X11 port, so linx_Base-8 moans at deinstall time) Future work (interested souls should coordinate with freebsd-emulation@): - add some kind of USE_LINUX_X11 knob to streamline the X11 dependencies, or modify the behavior of USE_XLIB in the USE_LINUX case AFAIK trevor has some patches. - make USE_XLIB and USE_X_PREFIX orthogonal to be able to get rid of the PREFIX?= workaround in some linux ports Should be discussed/coordinated on/with x11@. - move the RPM bits from x11-toolkits/linux-gtk/Makefile to PORTSDIR/Mk/ - update to a more recent linux base PR: 69997, 70539 (and maybe others) Discussed with/on: java@, x11@, trevor, portmgr Tested by: mezz, portmgr, pointyhat RPM hunted down by: Joseph Gelinas <scirocco@tasam.com> [1] Requested by: portmgr [2] Submitted by: kris [3] Approved by: portmgr
Diffstat (limited to 'lang')
-rw-r--r--lang/icc/Makefile4
-rw-r--r--lang/icc7/Makefile1
-rw-r--r--lang/ifc/Makefile3
-rw-r--r--lang/ifc7/Makefile1
-rw-r--r--lang/linux-j/Makefile2
-rw-r--r--lang/visualworks/Makefile3
6 files changed, 8 insertions, 6 deletions
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index 58c4f47fe054..fb6dc7294d3e 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -18,7 +18,6 @@ PATCHLEVEL= ${PORTVERSION:C/(.+p)(.+)$/pe\2/}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
.if ${PORTVERSION} != ${PATCHLEVEL}
DISTFILES+= ${DISTNAME}_${PATCHLEVEL}${EXTRACT_SUFX}
-#PATCH_DEPENDS= ${LINUXBASE}/etc/redhat-release:${PORTSDIR}/emulators/linux_base
PATCH_DEPENDS= ${LINUXBASE}/lib/libc-2.3.2.so:${PORTSDIR}/emulators/linux_base-8
.endif
@@ -31,8 +30,7 @@ NO_CDROM= ${RESTRICTED}
ONLY_FOR_ARCHS= i386
CONFLICTS= linux_devtools*
-#USE_LINUX= yes
-RUN_DEPENDS= ${LINUXBASE}/lib/libc-2.3.2.so:${PORTSDIR}/emulators/linux_base-8
+USE_LINUX= yes
USE_REINPLACE= yes
NO_FILTER_SHLIBS= yes
diff --git a/lang/icc7/Makefile b/lang/icc7/Makefile
index a06f1592caf9..a5f15cf4cc69 100644
--- a/lang/icc7/Makefile
+++ b/lang/icc7/Makefile
@@ -7,6 +7,7 @@
PORTNAME= icc7
PORTVERSION= 7.1.042
+PORTREVISION= 1
CATEGORIES= lang linux devel
MASTER_SITES=
DISTNAME= l_cc_pc_${PORTVERSION}
diff --git a/lang/ifc/Makefile b/lang/ifc/Makefile
index bdae559e183d..3e8f0d0ad9c0 100644
--- a/lang/ifc/Makefile
+++ b/lang/ifc/Makefile
@@ -31,8 +31,7 @@ NO_CDROM= ${RESTRICTED}
ONLY_FOR_ARCHS= i386
CONFLICTS= linux_devtools*
-#USE_LINUX= yes
-RUN_DEPENDS= ${LINUXBASE}/lib/libc-2.3.2.so:${PORTSDIR}/emulators/linux_base-8
+USE_LINUX= yes
USE_REINPLACE= yes
NO_FILTER_SHLIBS= yes
diff --git a/lang/ifc7/Makefile b/lang/ifc7/Makefile
index 6dd181b78c17..e03a2547d1c4 100644
--- a/lang/ifc7/Makefile
+++ b/lang/ifc7/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ifc7
PORTVERSION= 7.1.040
+PORTREVISION= 1
CATEGORIES= lang linux devel
MASTER_SITES=
DISTNAME= l_fc_pc_${PORTVERSION}
diff --git a/lang/linux-j/Makefile b/lang/linux-j/Makefile
index 575f8f1e37c7..79f93c81163e 100644
--- a/lang/linux-j/Makefile
+++ b/lang/linux-j/Makefile
@@ -7,7 +7,7 @@
PORTNAME= linux-j
PORTVERSION= 502a
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang linux
MASTER_SITES= http://www.jsoftware.com/download/
DISTNAME= j${PORTVERSION}_linux
diff --git a/lang/visualworks/Makefile b/lang/visualworks/Makefile
index d4f882e794c3..06e04d2ac412 100644
--- a/lang/visualworks/Makefile
+++ b/lang/visualworks/Makefile
@@ -7,6 +7,7 @@
PORTNAME= visualworks
PORTVERSION= 7.2
+PORTREVISION= 1
CATEGORIES= lang linux
MASTER_SITES= http://www.cincomsmalltalk.com/bsdports/vwnc7.2/
DISTFILES= AdvancedTools.tar.gz \
@@ -34,6 +35,8 @@ DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
MAINTAINER= chris@chrisburkert.de
COMMENT= A high performance Smalltalk environment
+RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
+
USE_LINUX= yes
ONLY_FOR_ARCHS= i386