aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-12-24 03:10:47 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-12-24 03:10:47 +0800
commit583b1e47aed56feb2007ac9f593fbb86581dc818 (patch)
treea2e6a705ed76d26bdd22e66a9054fb36aa53859d /lang
parentbf04ae6661a029998a8d810c895af2bddb7e3a06 (diff)
downloadfreebsd-ports-gnome-583b1e47aed56feb2007ac9f593fbb86581dc818.tar.gz
freebsd-ports-gnome-583b1e47aed56feb2007ac9f593fbb86581dc818.tar.zst
freebsd-ports-gnome-583b1e47aed56feb2007ac9f593fbb86581dc818.zip
- Update to 2.1.8
- Add LICENSE_FILE - Use USES=autoreconf instead of USE_AUTOTOOLS=autoconf - Use USES=libedit - Silence patch and build messages Changes: https://www.ruby-lang.org/en/news/2015/12/16/ruby-2-1-8-released/ http://svn.ruby-lang.org/repos/ruby/tags/v2_1_8/ChangeLog Security: 3b50881d-1860-4721-aab1-503290e23f6c Differential Revision: https://reviews.freebsd.org/D4668 PR: 205487 Exp-run by: antoine MFH: 2015Q4
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby21/Makefile24
-rw-r--r--lang/ruby21/distinfo4
-rw-r--r--lang/ruby21/files/patch-ext_openssl_extconf.rb6
-rw-r--r--lang/ruby21/files/patch-ext_readline_extconf.rb8
4 files changed, 17 insertions, 25 deletions
diff --git a/lang/ruby21/Makefile b/lang/ruby21/Makefile
index 2af35a8b9692..f5c894356871 100644
--- a/lang/ruby21/Makefile
+++ b/lang/ruby21/Makefile
@@ -15,6 +15,8 @@ COMMENT?= Object-oriented interpreted scripting language
LICENSE= BSD2CLAUSE RUBY
LICENSE_COMB= dual
+LICENSE_FILE_BSD2CLAUSE=${WRKSRC}/BSDL
+LICENSE_FILE_RUBY= ${WRKSRC}/COPYING
# Using LIB_DEPENDS finds the libffi from gcc which causes problems
BUILD_DEPENDS= libffi>=0:${PORTSDIR}/devel/libffi
@@ -34,20 +36,19 @@ GNU_CONFIGURE= yes
# Keep this, else ruby will fail to load libraries dependent of libpthread.
LIBS+= -lpthread -L${LOCALBASE}/lib
MAKE_ENV= LC_ALL=C
-USE_AUTOTOOLS= autoconf
USE_LDCONFIG= yes
USE_OPENSSL= yes
-USES= cpe execinfo tar:xz
+USES= autoreconf cpe execinfo tar:xz
WRKSRC= ${RUBY_WRKSRC}
-NOT_FOR_ARCHS= ia64
-NOT_FOR_ARCHS_REASON_ia64= does not build
-
RUBY_VER= 2.1
USE_RUBY= yes
RUBY_NO_BUILD_DEPENDS= yes
RUBY_NO_RUN_DEPENDS= yes
+NOT_FOR_ARCHS= ia64
+NOT_FOR_ARCHS_REASON_ia64= does not build
+
OPTIONS_DEFINE= CAPIDOCS DEBUG DOCS EXAMPLES GMP RDOC
OPTIONS_DEFAULT= RDOC LIBEDIT
OPTIONS_SINGLE= EDIT
@@ -64,9 +65,8 @@ CAPIDOCS_BUILD_DEPENDS= doxygen>0:${PORTSDIR}/devel/doxygen \
CAPIDOCS_CONFIGURE_ENABLE= install-capi
GMP_CONFIGURE_WITH= gmp
GMP_LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
-LIBEDIT_BUILD_DEPENDS= libedit>=0:${PORTSDIR}/devel/libedit
LIBEDIT_CONFIGURE_ON= --enable-libedit --with-libedit-dir=${LOCALBASE}
-LIBEDIT_RUN_DEPENDS= libedit>=0:${PORTSDIR}/devel/libedit
+LIBEDIT_USES= libedit
RDOC_CONFIGURE_ENABLE= install-rdoc
READLINE_BUILD_DEPENDS= readline>=0:${PORTSDIR}/devel/readline
READLINE_CONFIGURE_ON= --disable-libedit --with-readline-dir=${LOCALBASE}
@@ -142,20 +142,20 @@ post-patch:
# Remove modules we don't want
#
.for d in win32ole
- ${RM} -rf ${BUILD_WRKSRC}/ext/${d}
+ @${RM} -rf ${BUILD_WRKSRC}/ext/${d}
.endfor
# We get rake from ports.
.for d in bin/rake doc/rake lib/rake test/rake man/rake.1 lib/rake.rb
- ${RM} -rf ${BUILD_WRKSRC}/${d}
+ @${RM} -rf ${BUILD_WRKSRC}/${d}
.endfor
# We get the gem executable from ports.
- ${RM} ${BUILD_WRKSRC}/bin/gem
+ @${RM} ${BUILD_WRKSRC}/bin/gem
#
# Prepare modules we are wanting to build via external ports
#
.for d in gdbm tk
- ${MV} ${BUILD_WRKSRC}/ext/${d} ${WRKDIR}/
+ @${MV} ${BUILD_WRKSRC}/ext/${d} ${WRKDIR}/
.endfor
post-build:
@@ -170,7 +170,7 @@ post-build:
@${RB_SET_CONF_VAR} "INSTALL_DATA" "ENV['RB_USER_INSTALL'] ? '${INSTALL} ${COPY} -m ${SHAREMODE}' : '${INSTALL_DATA}'"
post-build-CAPIDOCS-on:
- ${FIND} ${WRKSRC}/doc -type d -empty -delete
+ @${FIND} ${WRKSRC}/doc -type d -empty -delete
pre-install:
${MKDIR} ${STAGEDIR}${RUBY_SITEARCHLIBDIR}
diff --git a/lang/ruby21/distinfo b/lang/ruby21/distinfo
index 39e405d0b747..8b62cb6a9cc6 100644
--- a/lang/ruby21/distinfo
+++ b/lang/ruby21/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ruby/ruby-2.1.7.tar.xz) = 225c067d9820fe52fcffbfb91d5b5243708a0b666b9929bea466e9379eb40ad7
-SIZE (ruby/ruby-2.1.7.tar.xz) = 9371208
+SHA256 (ruby/ruby-2.1.8.tar.xz) = 94eeae3b3e3ac93cfd205e1aaef4c5325227b7656cbb2fc1ee217618145dd19d
+SIZE (ruby/ruby-2.1.8.tar.xz) = 9382672
diff --git a/lang/ruby21/files/patch-ext_openssl_extconf.rb b/lang/ruby21/files/patch-ext_openssl_extconf.rb
index 2577c1c1ec13..0d837b15d4da 100644
--- a/lang/ruby21/files/patch-ext_openssl_extconf.rb
+++ b/lang/ruby21/files/patch-ext_openssl_extconf.rb
@@ -10,6 +10,6 @@
+have_func("SSLv23_method")
+have_func("SSLv23_server_method")
+have_func("SSLv23_client_method")
- have_func("TLSv1_1_method")
- have_func("TLSv1_1_server_method")
- have_func("TLSv1_1_client_method")
+ have_func("SSLv3_method")
+ have_func("SSLv3_server_method")
+ have_func("SSLv3_client_method")
diff --git a/lang/ruby21/files/patch-ext_readline_extconf.rb b/lang/ruby21/files/patch-ext_readline_extconf.rb
index 1eed0c2b49ba..daa6055cea28 100644
--- a/lang/ruby21/files/patch-ext_readline_extconf.rb
+++ b/lang/ruby21/files/patch-ext_readline_extconf.rb
@@ -1,13 +1,5 @@
--- ext/readline/extconf.rb.orig 2014-05-01 11:59:37.000000000 +0000
+++ ext/readline/extconf.rb 2015-10-23 04:05:44.000000000 +0000
-@@ -37,6 +37,7 @@
- case enable_libedit
- when true
- # --enable-libedit
-+ dir_config("libedit")
- unless (readline.have_header("editline/readline.h") ||
- readline.have_header("readline/readline.h")) &&
- have_library("edit", "readline")
@@ -62,7 +63,7 @@ else
end