aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authoremaste <emaste@FreeBSD.org>2018-09-27 00:12:12 +0800
committeremaste <emaste@FreeBSD.org>2018-09-27 00:12:12 +0800
commit60279d141a108042caecd4ee9dbbf9e89b2c6d99 (patch)
tree04964e84769ceaf209ed3f5f1261b819bfb55c22 /lang
parent3898de35c8dcd17235a542e48d3f63b4a06b9385 (diff)
downloadfreebsd-ports-gnome-60279d141a108042caecd4ee9dbbf9e89b2c6d99.tar.gz
freebsd-ports-gnome-60279d141a108042caecd4ee9dbbf9e89b2c6d99.tar.zst
freebsd-ports-gnome-60279d141a108042caecd4ee9dbbf9e89b2c6d99.zip
Add -znotext to LDFLAGS on i386, for lld
These ports link some non-PIC code, which fails with lld as it defaults to disallowing relocations against read-only segments. For i386 we can just add -znotext unconditionally: for GNU BFD ld it just affirms BFD's existing default. PR: 214864 Approved by: portmgr (lld blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'lang')
-rw-r--r--lang/clover/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/clover/Makefile b/lang/clover/Makefile
index f8adadacccbc..bdb119381e5e 100644
--- a/lang/clover/Makefile
+++ b/lang/clover/Makefile
@@ -22,6 +22,7 @@ CONFIGURE_ARGS+= --enable-opencl --enable-opencl-icd --disable-dri \
--disable-egl --disable-gbm --disable-gles2 --disable-glx \
--disable-va --disable-vdpau --disable-xvmc \
--with-gallium-drivers=r600,radeonsi # only supported GPUs
+LDFLAGS_i386= -Wl,-znotext
#MESA_BUILD_WRKSRC= src/util src/compiler src/mesa src/gallium
MESA_INSTALL_WRKSRC= src/gallium/targets/opencl src/gallium/targets/pipe-loader