aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authoraraujo <araujo@FreeBSD.org>2017-03-25 02:30:47 +0800
committeraraujo <araujo@FreeBSD.org>2017-03-25 02:30:47 +0800
commit74df2d8f8c858de1fcbdfe51cf4c8cf33bbe9d79 (patch)
tree3774ea3519f5b5aa0f6d78df137597f3c127a847 /lang
parentc586891f65a3c7889de972a94f53bf609373a79a (diff)
downloadfreebsd-ports-gnome-74df2d8f8c858de1fcbdfe51cf4c8cf33bbe9d79.tar.gz
freebsd-ports-gnome-74df2d8f8c858de1fcbdfe51cf4c8cf33bbe9d79.tar.zst
freebsd-ports-gnome-74df2d8f8c858de1fcbdfe51cf4c8cf33bbe9d79.zip
Make cython and cython3 co-exist.
Reported by: jbeich@ Differential Revision: https://reviews.freebsd.org/D5845 (based on)
Diffstat (limited to 'lang')
-rw-r--r--lang/cython/Makefile2
-rw-r--r--lang/cython3/Makefile4
2 files changed, 5 insertions, 1 deletions
diff --git a/lang/cython/Makefile b/lang/cython/Makefile
index 0ee5f675d2f3..c5cec1927350 100644
--- a/lang/cython/Makefile
+++ b/lang/cython/Makefile
@@ -15,7 +15,7 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
USES?= python
-USE_PYTHON= autoplist distutils
+USE_PYTHON+= autoplist distutils
post-install:
${FIND} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/Cython \
diff --git a/lang/cython3/Makefile b/lang/cython3/Makefile
index be5425fb76c8..426919c58514 100644
--- a/lang/cython3/Makefile
+++ b/lang/cython3/Makefile
@@ -1,6 +1,10 @@
MASTERDIR= ${.CURDIR}/../cython
PKGNAMESUFFIX= 3
+PKGNAMESUFFIX= 3
+
USES= python:3.3+
+USE_PYTHON= concurrent
+UNIQUE_SUFFIX= ${PKGNAMESUFFIX}
.include "${MASTERDIR}/Makefile"