aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authordumbbell <dumbbell@FreeBSD.org>2017-07-29 00:29:08 +0800
committerdumbbell <dumbbell@FreeBSD.org>2017-07-29 00:29:08 +0800
commit781c0bd9e115e3d193f197d785e38b5e3e091f0f (patch)
treed8ab006e09b7ca331613f3a124239a5fa9a72e2e /lang
parentf0cbe3dd6aa8376a261dc63218f43f5a3295b448 (diff)
downloadfreebsd-ports-gnome-781c0bd9e115e3d193f197d785e38b5e3e091f0f.tar.gz
freebsd-ports-gnome-781c0bd9e115e3d193f197d785e38b5e3e091f0f.tar.zst
freebsd-ports-gnome-781c0bd9e115e3d193f197d785e38b5e3e091f0f.zip
lang/rust: Fix ${PORT_LLVM_BUILD_DEPENDS}
The BUILD_DEPENDS argument for the PORT_LLVM option was not updated: it was using the ${LLVM_PREFIX} variable which was removed. Now, it uses ${LOCALBASE} and ${LLVM_VER} as a suffix to the executable verified. Submitted by: Rainer Hurling <rhurlin@gwdg.de> Reported by: Rainer Hurling <rhurlin@gwdg.de>
Diffstat (limited to 'lang')
-rw-r--r--lang/rust/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 95ef996d71a9..8a41b9211627 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -80,7 +80,7 @@ LLNEXTGEN_BUILD_DEPENDS= LLnextgen:devel/llnextgen
# Rust may pass more regression tests with bundled LLVM
PORT_LLVM_DESC= Build against devel/llvm${LLVM_VER} instead of bundled version
-PORT_LLVM_BUILD_DEPENDS= ${LLVM_PREFIX}/bin/FileCheck:devel/llvm${LLVM_VER}
+PORT_LLVM_BUILD_DEPENDS= ${LOCALBASE}/bin/FileCheck${LLVM_VER}:devel/llvm${LLVM_VER}
LLVM_VER?= 40
LLVM_CONFIG= ${LOCALBASE}/bin/llvm-config${LLVM_VER}