aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2015-03-23 05:39:24 +0800
committergerald <gerald@FreeBSD.org>2015-03-23 05:39:24 +0800
commit7af8309546c7d782826fe2a9e6b9bcafa08be217 (patch)
treef5fb62aab01254009085b71d92d36d33adf35937 /lang
parentc48cda7d8f6666ee68105861842c9df3c671c8ef (diff)
downloadfreebsd-ports-gnome-7af8309546c7d782826fe2a9e6b9bcafa08be217.tar.gz
freebsd-ports-gnome-7af8309546c7d782826fe2a9e6b9bcafa08be217.tar.zst
freebsd-ports-gnome-7af8309546c7d782826fe2a9e6b9bcafa08be217.zip
Add CPE information. [1]
Use PKGNAMESUFFIX so that PORTNAME falls back to plain gcc and we can avoid setting DISTNAME and CPE_PRODUCT. [2] PR: 198256 [1] Submitted by: shun.fbsd.pr@dropcut.net [1] Suggested by: mat [2]
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc47/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index 07d8daa19807..4eb391fa2fae 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -1,14 +1,14 @@
# Created by: Gerald Pfeifer <gerald@FreeBSD.org>
# $FreeBSD$
-PORTNAME= gcc47
+PORTNAME= gcc
PORTVERSION= 4.7.4
PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= releases/gcc-${DISTVERSION}
-DISTNAME= gcc-${DISTVERSION}
+PKGNAMESUFFIX= ${SUFFIX}
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.7
@@ -27,6 +27,7 @@ BUILD_DEPENDS+= runtest:${PORTSDIR}/misc/dejagnu
.endif
CONFLICTS= gcc-4.7.*
+CPE_VENDOR= gnu
# DISTVERSION relates to downloads, GCC_VERSION and SUFFIX to names
# of executables and directories once installed.
@@ -34,7 +35,7 @@ DISTVERSION= ${PORTVERSION}
GCC_VERSION= ${PORTVERSION:C/(.+)\.[0-9]{8}/\1/}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 sparc64
-USES= gmake iconv libtool makeinfo perl5 tar:bzip2
+USES= cpe gmake iconv libtool makeinfo perl5 tar:bzip2
USE_BINUTILS= yes
USE_PERL5= build
SSP_UNSAFE= yes