aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2004-03-11 23:55:38 +0800
committerperky <perky@FreeBSD.org>2004-03-11 23:55:38 +0800
commit8035782ac4c7cc332048068e9c17e5899dacb6a2 (patch)
treea0e79fea10d858d4c5d28597c4c545ab7b6bf4a1 /lang
parentd386a3bdd54cfeb06fa1a1f31f8a8b5793566d9b (diff)
downloadfreebsd-ports-gnome-8035782ac4c7cc332048068e9c17e5899dacb6a2.tar.gz
freebsd-ports-gnome-8035782ac4c7cc332048068e9c17e5899dacb6a2.tar.zst
freebsd-ports-gnome-8035782ac4c7cc332048068e9c17e5899dacb6a2.zip
- Fix installation problem where PREFIX != LOCALBASE.
- Add checksum for Python-2.4.a0.20040311
Diffstat (limited to 'lang')
-rw-r--r--lang/python/Makefile3
-rw-r--r--lang/python/distinfo3
-rw-r--r--lang/python23/Makefile3
-rw-r--r--lang/python23/distinfo3
-rw-r--r--lang/python24/Makefile3
-rw-r--r--lang/python24/distinfo3
6 files changed, 12 insertions, 6 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 9a9bf3b29902..f607714bd0ab 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -161,7 +161,8 @@ post-install:
${PREFIX}/lib
cd ${PREFIX}/lib; ${LN} -sf lib${PYTHON_VERSION}.so.1 \
lib${PYTHON_VERSION}.so
- ${LN} -sf ${PREFIX}/lib/lib${PYTHON_VERSION}.so ${PYTHON_LIBDIR}/config
+ ${LN} -sf ${PREFIX}/lib/lib${PYTHON_VERSION}.so \
+ ${PYTHONPREFIX_LIBDIR}/config
${INSTALL_PROGRAM} \
${SHARED_WRKSRC}/${PYTHON_VERSION:S/thon/thon-shared/} \
${PREFIX}/bin
diff --git a/lang/python/distinfo b/lang/python/distinfo
index 5e2a54f44346..459b99fd3e56 100644
--- a/lang/python/distinfo
+++ b/lang/python/distinfo
@@ -15,5 +15,6 @@ MD5 (python/Python-2.3.1.tgz) = a3dcbe1c7f173c8e3c7cce28495016ae
MD5 (python/Python-2.3.2.tgz) = f54d7a529d444994b4b33429bbb45479
MD5 (python/Python-2.3.3.tgz) = 4d16732b1cfccc0ed250956d41463c61
SIZE (python/Python-2.3.3.tgz) = 8491380
-MD5 (python/Python-2.4.a0.20031022.tgz) = 79581105c218886dd9dc382a84c64043
MD5 (python/Python-2.4.a0.20040106.tgz) = cde5962028bcfdb473455c57bbb24c18
+MD5 (python/Python-2.4.a0.20040311.tgz) = 5619b787ce62a1ebac3c973179d36670
+SIZE (python/Python-2.4.a0.20040311.tgz) = 8512702
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index 9a9bf3b29902..f607714bd0ab 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -161,7 +161,8 @@ post-install:
${PREFIX}/lib
cd ${PREFIX}/lib; ${LN} -sf lib${PYTHON_VERSION}.so.1 \
lib${PYTHON_VERSION}.so
- ${LN} -sf ${PREFIX}/lib/lib${PYTHON_VERSION}.so ${PYTHON_LIBDIR}/config
+ ${LN} -sf ${PREFIX}/lib/lib${PYTHON_VERSION}.so \
+ ${PYTHONPREFIX_LIBDIR}/config
${INSTALL_PROGRAM} \
${SHARED_WRKSRC}/${PYTHON_VERSION:S/thon/thon-shared/} \
${PREFIX}/bin
diff --git a/lang/python23/distinfo b/lang/python23/distinfo
index 5e2a54f44346..459b99fd3e56 100644
--- a/lang/python23/distinfo
+++ b/lang/python23/distinfo
@@ -15,5 +15,6 @@ MD5 (python/Python-2.3.1.tgz) = a3dcbe1c7f173c8e3c7cce28495016ae
MD5 (python/Python-2.3.2.tgz) = f54d7a529d444994b4b33429bbb45479
MD5 (python/Python-2.3.3.tgz) = 4d16732b1cfccc0ed250956d41463c61
SIZE (python/Python-2.3.3.tgz) = 8491380
-MD5 (python/Python-2.4.a0.20031022.tgz) = 79581105c218886dd9dc382a84c64043
MD5 (python/Python-2.4.a0.20040106.tgz) = cde5962028bcfdb473455c57bbb24c18
+MD5 (python/Python-2.4.a0.20040311.tgz) = 5619b787ce62a1ebac3c973179d36670
+SIZE (python/Python-2.4.a0.20040311.tgz) = 8512702
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index 9a9bf3b29902..f607714bd0ab 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -161,7 +161,8 @@ post-install:
${PREFIX}/lib
cd ${PREFIX}/lib; ${LN} -sf lib${PYTHON_VERSION}.so.1 \
lib${PYTHON_VERSION}.so
- ${LN} -sf ${PREFIX}/lib/lib${PYTHON_VERSION}.so ${PYTHON_LIBDIR}/config
+ ${LN} -sf ${PREFIX}/lib/lib${PYTHON_VERSION}.so \
+ ${PYTHONPREFIX_LIBDIR}/config
${INSTALL_PROGRAM} \
${SHARED_WRKSRC}/${PYTHON_VERSION:S/thon/thon-shared/} \
${PREFIX}/bin
diff --git a/lang/python24/distinfo b/lang/python24/distinfo
index 5e2a54f44346..459b99fd3e56 100644
--- a/lang/python24/distinfo
+++ b/lang/python24/distinfo
@@ -15,5 +15,6 @@ MD5 (python/Python-2.3.1.tgz) = a3dcbe1c7f173c8e3c7cce28495016ae
MD5 (python/Python-2.3.2.tgz) = f54d7a529d444994b4b33429bbb45479
MD5 (python/Python-2.3.3.tgz) = 4d16732b1cfccc0ed250956d41463c61
SIZE (python/Python-2.3.3.tgz) = 8491380
-MD5 (python/Python-2.4.a0.20031022.tgz) = 79581105c218886dd9dc382a84c64043
MD5 (python/Python-2.4.a0.20040106.tgz) = cde5962028bcfdb473455c57bbb24c18
+MD5 (python/Python-2.4.a0.20040311.tgz) = 5619b787ce62a1ebac3c973179d36670
+SIZE (python/Python-2.4.a0.20040311.tgz) = 8512702