aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2005-06-16 14:04:46 +0800
committerale <ale@FreeBSD.org>2005-06-16 14:04:46 +0800
commit8d34ac9586665a7d5d856cc4a7826b0f3f9d2be6 (patch)
treeea63ea5091703e84a1fb5c88f592d5583cd72143 /lang
parentdfb4c179bad9caa218006ba68405b9a95698dd0a (diff)
downloadfreebsd-ports-gnome-8d34ac9586665a7d5d856cc4a7826b0f3f9d2be6.tar.gz
freebsd-ports-gnome-8d34ac9586665a7d5d856cc4a7826b0f3f9d2be6.tar.zst
freebsd-ports-gnome-8d34ac9586665a7d5d856cc4a7826b0f3f9d2be6.zip
Move oracle library creation to pre-configure instead of post-patch,
since oracle is only a build dependency. Spotted by: pointyhat via kris
Diffstat (limited to 'lang')
-rw-r--r--lang/php4/Makefile.ext2
-rw-r--r--lang/php5/Makefile.ext2
-rw-r--r--lang/php53/Makefile.ext2
3 files changed, 3 insertions, 3 deletions
diff --git a/lang/php4/Makefile.ext b/lang/php4/Makefile.ext
index c2aaf698dcf5..d222d04bf5e8 100644
--- a/lang/php4/Makefile.ext
+++ b/lang/php4/Makefile.ext
@@ -449,7 +449,7 @@ post-extract:
.endif
.if ${PHP_MODNAME} == "oracle"
-post-patch:
+pre-configure:
@cd ${WRKSRC}; \
for lib in c3v6 client common core3 epc generic ncr nlsrtl3 sqlnet wrap; do \
/usr/bin/ar x ${LOCALBASE}/oracle7/lib/lib$${lib}.a; \
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index fb580dc518e8..36b3d601884a 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -462,7 +462,7 @@ post-extract:
.endif
.if ${PHP_MODNAME} == "oracle"
-post-patch:
+pre-configure:
@cd ${WRKSRC}; \
for lib in c3v6 client common core3 epc generic ncr nlsrtl3 sqlnet wrap; do \
/usr/bin/ar x ${LOCALBASE}/oracle7/lib/lib$${lib}.a; \
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index fb580dc518e8..36b3d601884a 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -462,7 +462,7 @@ post-extract:
.endif
.if ${PHP_MODNAME} == "oracle"
-post-patch:
+pre-configure:
@cd ${WRKSRC}; \
for lib in c3v6 client common core3 epc generic ncr nlsrtl3 sqlnet wrap; do \
/usr/bin/ar x ${LOCALBASE}/oracle7/lib/lib$${lib}.a; \