aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2004-01-20 22:59:46 +0800
committermaho <maho@FreeBSD.org>2004-01-20 22:59:46 +0800
commit9076247d833328c455382d0e7f3292f09e7cd21e (patch)
tree30e4de6e9f81898026e1755b94b0c1028584e231 /lang
parent2bfb1c92813e335a282e83d20b503cf977dcbc5b (diff)
downloadfreebsd-ports-gnome-9076247d833328c455382d0e7f3292f09e7cd21e.tar.gz
freebsd-ports-gnome-9076247d833328c455382d0e7f3292f09e7cd21e.tar.zst
freebsd-ports-gnome-9076247d833328c455382d0e7f3292f09e7cd21e.zip
Remocxa_finalize.c isn't needed anymore as the entire DSO support is in
cxa_atexit.c now (it has the same line count as the icc one). Reviewed by: netchild
Diffstat (limited to 'lang')
-rw-r--r--lang/ifc8/Makefile3
-rw-r--r--lang/ifc8/files/cxa_finalize.c38
2 files changed, 1 insertions, 40 deletions
diff --git a/lang/ifc8/Makefile b/lang/ifc8/Makefile
index 705e31db51e0..7090768920c9 100644
--- a/lang/ifc8/Makefile
+++ b/lang/ifc8/Makefile
@@ -151,8 +151,7 @@ do-build:
${FILESDIR}/sysconf.c \
${FILESDIR}/errno_location.c ${FILESDIR}/mcount.S
.if ( ${OSVERSION} < 502101 )
- @cd ${WRKSRC} && ${CC} ${CFLAGS} -c ${FILESDIR}/cxa_atexit.c \
- ${FILESDIR}/cxa_finalize.c
+ @cd ${WRKSRC} && ${CC} ${CFLAGS} -c ${FILESDIR}/cxa_atexit.c
.endif
.if ( ${OSVERSION} < 470101 ) || \
( ${OSVERSION} >= 500000 && ${OSVERSION} < 500042 )
diff --git a/lang/ifc8/files/cxa_finalize.c b/lang/ifc8/files/cxa_finalize.c
deleted file mode 100644
index 434038f42509..000000000000
--- a/lang/ifc8/files/cxa_finalize.c
+++ /dev/null
@@ -1,38 +0,0 @@
-/*
- * Copyright (c) 2002 Marius Strobl
- * All rights reserved.
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions
- * are met:
- * 1. Redistributions of source code must retain the above copyright
- * notice, this list of conditions and the following disclaimer.
- * 2. Redistributions in binary form must reproduce the above copyright
- * notice, this list of conditions and the following disclaimer in the
- * documentation and/or other materials provided with the distribution.
- *
- * THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
- * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
- * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
- * ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
- * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
- * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
- * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
- * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
- * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
- * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
- * SUCH DAMAGE.
- *
- * $FreeBSD: /tmp/pcvs/ports/lang/ifc8/files/Attic/cxa_finalize.c,v 1.1 2004-01-19 14:52:12 maho Exp $
- */
-
-void
-__cxa_finalize(void *handle)
-{
-
- /*
- * As we dared to register the functions via atexit() this job will
- * be done by exit().
- */
- return;
-}