aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2015-05-23 22:52:35 +0800
committerjohans <johans@FreeBSD.org>2015-05-23 22:52:35 +0800
commitd41d0ed01d70903c84506c334f4826d14a1c8f36 (patch)
tree816d4036772c9e1602ac7fa740cbe4a8dc29db78 /lang
parent44b660e5bac70047f4fc8485a599e7a0b69d0548 (diff)
downloadfreebsd-ports-gnome-d41d0ed01d70903c84506c334f4826d14a1c8f36.tar.gz
freebsd-ports-gnome-d41d0ed01d70903c84506c334f4826d14a1c8f36.tar.zst
freebsd-ports-gnome-d41d0ed01d70903c84506c334f4826d14a1c8f36.zip
- Force linking with readline from ports
Note that gawk works fine with readline from base, but it would break dependency tracking if we get this wrong PR: 200408 Submitted by: sunpoet
Diffstat (limited to 'lang')
-rw-r--r--lang/gawk/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/lang/gawk/Makefile b/lang/gawk/Makefile
index feb5527aaf79..f301a7e88c55 100644
--- a/lang/gawk/Makefile
+++ b/lang/gawk/Makefile
@@ -3,14 +3,14 @@
PORTNAME= gawk
PORTVERSION= 4.1.3
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= GNU
MAINTAINER= johans@FreeBSD.org
COMMENT= GNU version of Awk
-LIB_DEPENDS= libsigsegv.so:${PORTSDIR}/devel/libsigsegv \
- libreadline.so:${PORTSDIR}/devel/readline
+LIB_DEPENDS= libsigsegv.so:${PORTSDIR}/devel/libsigsegv
OPTIONS_DEFINE= NLS MPFR
OPTIONS_SUB= yes
@@ -23,10 +23,9 @@ MPFR_CONFIGURE_OFF= --without-gmp --without-mpfr
INFO= gawk gawkinet
GNU_CONFIGURE= yes
-USES= iconv libtool makeinfo tar:xz
+USES= iconv libtool makeinfo readline:port tar:xz
CONFIGURE_ARGS= ${ICONV_CONFIGURE_ARG} \
--with-libintl-prefix=${LOCALBASE} \
- --with-readline=${LOCALBASE} \
AWK=${AWK}
INSTALL_TARGET= install-strip