aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-02-10 02:53:12 +0800
committerlinimon <linimon@FreeBSD.org>2017-02-10 02:53:12 +0800
commitd986308550a19d058cd7490871a870e705d8365c (patch)
treebe5801b4b385a04c75cc1baf3b06a46cc4f893e5 /lang
parentb9168d5cd97c323a0847a91c6972bca6948a21a0 (diff)
downloadfreebsd-ports-gnome-d986308550a19d058cd7490871a870e705d8365c.tar.gz
freebsd-ports-gnome-d986308550a19d058cd7490871a870e705d8365c.tar.zst
freebsd-ports-gnome-d986308550a19d058cd7490871a870e705d8365c.zip
Add -fPIC to various ports to enable them to build on armv6.
Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'lang')
-rw-r--r--lang/squirrel/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/lang/squirrel/Makefile b/lang/squirrel/Makefile
index 9aea441fa114..80505b3da780 100644
--- a/lang/squirrel/Makefile
+++ b/lang/squirrel/Makefile
@@ -16,11 +16,14 @@ USES= dos2unix
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/SQUIRREL2
+CFLAGS_aarch64= -fPIC
+CFLAGS_amd64= -fPIC
+CFLAGS_sparc64= -fPIC
+
.include <bsd.port.pre.mk>
-.if ${ARCH} == amd64 || ${ARCH} == sparc64 || ${ARCH} == ia64
+.if ${ARCH} == aarch64 || ${ARCH} == amd64 || ${ARCH} == sparc64
ALL_TARGET= sq64
-CFLAGS+= -fPIC
.else
ALL_TARGET= sq32
.endif