aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2012-10-24 05:14:20 +0800
committerrene <rene@FreeBSD.org>2012-10-24 05:14:20 +0800
commitd9a4cde3a38ea7084acc8e10c47e1cfce8bf344b (patch)
tree590a2f35cea96c894c8c3d7701bce3a3027e54e9 /lang
parent9b8897c5b64b30597da0529a751823d42d9db73b (diff)
downloadfreebsd-ports-gnome-d9a4cde3a38ea7084acc8e10c47e1cfce8bf344b.tar.gz
freebsd-ports-gnome-d9a4cde3a38ea7084acc8e10c47e1cfce8bf344b.tar.zst
freebsd-ports-gnome-d9a4cde3a38ea7084acc8e10c47e1cfce8bf344b.zip
Use optionsNG syntax for NOPORTDOCS
Feature safe: yes
Diffstat (limited to 'lang')
-rw-r--r--lang/bas2tap/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/lang/bas2tap/Makefile b/lang/bas2tap/Makefile
index f18d639fa91b..87f34393f55d 100644
--- a/lang/bas2tap/Makefile
+++ b/lang/bas2tap/Makefile
@@ -18,12 +18,14 @@ NO_WRKSUBDIR= yes
PORTDOCS= ${PORTNAME}.doc
PLIST_FILES= bin/${PORTNAME}
+.include <bsd.port.options.mk>
+
do-build:
${CC} ${WRKSRC}/${PORTNAME}.c -o ${WRKSRC}/${PORTNAME} -lm ${CFLAGS}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.ifndef NOPORTDOCS
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}