aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-09-19 01:49:31 +0800
committerkris <kris@FreeBSD.org>2004-09-19 01:49:31 +0800
commite6af723b427131278badc3dc020fee3cfef66d18 (patch)
treedc1bf7a770ac357f185dc978d61310d4d01b4bc4 /lang
parent8d05912892b859574e72655b0987937be881b688 (diff)
downloadfreebsd-ports-gnome-e6af723b427131278badc3dc020fee3cfef66d18.tar.gz
freebsd-ports-gnome-e6af723b427131278badc3dc020fee3cfef66d18.tar.zst
freebsd-ports-gnome-e6af723b427131278badc3dc020fee3cfef66d18.zip
BROKEN on 5.x: Does not compile
Approved by: portmgr (self)
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang/Makefile4
-rw-r--r--lang/erlang14/Makefile4
-rw-r--r--lang/ghc/Makefile4
-rw-r--r--lang/ghc5/Makefile4
-rw-r--r--lang/gprolog/Makefile8
5 files changed, 23 insertions, 1 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index d1247bfbab36..b0e4adbf1787 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -46,6 +46,10 @@ CONFIGURE_ARGS+= --enable-threads --enable-hipe
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if !exists(${JAVABINDIR}/java)
WITHOUT_JAVA= yes
.endif
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index d1247bfbab36..b0e4adbf1787 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -46,6 +46,10 @@ CONFIGURE_ARGS+= --enable-threads --enable-hipe
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if !exists(${JAVABINDIR}/java)
WITHOUT_JAVA= yes
.endif
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 462cd1859d27..bf3154cb2ba5 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -19,6 +19,10 @@ BOOT_DIST5= ghc-${PORTVERSION}-i386-unknown-freebsd5-boot${EXTRACT_SUFX}:boot
USE_BZIP2= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
DISTFILES= ${SRC_DIST}
.if ${OSVERSION} < 500000
diff --git a/lang/ghc5/Makefile b/lang/ghc5/Makefile
index b8352f7ed5f1..4dfccaa8b908 100644
--- a/lang/ghc5/Makefile
+++ b/lang/ghc5/Makefile
@@ -20,6 +20,10 @@ BOOT_DIST5= ghc-${PORTVERSION}-i386-unknown-freebsd5-boot${EXTRACT_SUFX}:boot
USE_BZIP2= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
DISTFILES= ${SRC_DIST}
.if ${OSVERSION} < 500000
diff --git a/lang/gprolog/Makefile b/lang/gprolog/Makefile
index d981bafe994b..d7220ff58945 100644
--- a/lang/gprolog/Makefile
+++ b/lang/gprolog/Makefile
@@ -27,8 +27,14 @@ CONFIGURE_ARGS= --with-c-flags="${CFLAGS}"
PLIST_SUB+= GPROLOG_VER=${PORTVERSION}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|<malloc\.h>|<stdlib.h>|g' ${WRKSRC}/EnginePl/machine.c
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>