aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2017-12-15 11:02:06 +0800
committerswills <swills@FreeBSD.org>2017-12-15 11:02:06 +0800
commitf982b6d91c0e75696adc5270e100d8e473294cbf (patch)
treef21826f57e5a44012c22ff1ad1f15fdbbfa7712d /lang
parent712003e025287b1afd8011f86532b0c3090b03db (diff)
downloadfreebsd-ports-gnome-f982b6d91c0e75696adc5270e100d8e473294cbf.tar.gz
freebsd-ports-gnome-f982b6d91c0e75696adc5270e100d8e473294cbf.tar.zst
freebsd-ports-gnome-f982b6d91c0e75696adc5270e100d8e473294cbf.zip
lang/ruby22, 23, 24: update ARCHs
Add armv7, drop armv6hf and ia64. While here, drop unneeded quotes. PR: 223986 Submitted by: linimon
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby22/Makefile8
-rw-r--r--lang/ruby23/Makefile8
-rw-r--r--lang/ruby24/Makefile11
3 files changed, 12 insertions, 15 deletions
diff --git a/lang/ruby22/Makefile b/lang/ruby22/Makefile
index 1f78d5de75ae..84335123fe86 100644
--- a/lang/ruby22/Makefile
+++ b/lang/ruby22/Makefile
@@ -86,7 +86,7 @@ _SUF1= _${PORTREVISION}
.endif
.if ${OPSYS} == "FreeBSD"
-.if exists(/usr/sbin/dtrace) && (${OSVERSION} > 1100032) && (${ARCH} == "amd64" || ${ARCH} == "i386")
+.if exists(/usr/sbin/dtrace) && (${OSVERSION} > 1100032) && (${ARCH} == amd64 || ${ARCH} == i386)
CONFIGURE_ARGS+= --enable-dtrace
.else
CONFIGURE_ARGS+= --disable-dtrace
@@ -94,15 +94,15 @@ CONFIGURE_ARGS+= --disable-dtrace
.endif
# keep in sync with all platforms where libunwind is available
-.if (${ARCH} == "amd64" || ${ARCH} == "i386")
+.if (${ARCH} == amd64 || ${ARCH} == i386)
LIB_DEPENDS+= libunwind.so:devel/libunwind
.endif
-.if ${ARCH} == "powerpc64"
+.if ${ARCH} == powerpc64
USE_GCC= yes
.endif
-.if ${ARCH} == "armv6" || ${ARCH} == "armv6hf"
+.if ${ARCH} == armv6 || ${ARCH} == armv7
CONFIGURE_ARGS+= --with-setjmp-type=_setjmp
CONFIGURE_ENV+= ac_cv_func__setjmp=yes
.endif
diff --git a/lang/ruby23/Makefile b/lang/ruby23/Makefile
index 1231be0fcb98..6753540b407a 100644
--- a/lang/ruby23/Makefile
+++ b/lang/ruby23/Makefile
@@ -90,7 +90,7 @@ _SUF2= ,${PORTEPOCH}
.endif
.if ${OPSYS} == "FreeBSD"
-.if exists(/usr/sbin/dtrace) && (${OSVERSION} > 1100032) && (${ARCH} == "amd64" || ${ARCH} == "i386")
+.if exists(/usr/sbin/dtrace) && (${OSVERSION} > 1100032) && (${ARCH} == amd64 || ${ARCH} == i386)
CONFIGURE_ARGS+=--enable-dtrace
.else
CONFIGURE_ARGS+=--disable-dtrace
@@ -98,15 +98,15 @@ CONFIGURE_ARGS+=--disable-dtrace
.endif
# keep in sync with all platforms where libunwind is available
-.if (${ARCH} == "amd64" || ${ARCH} == "i386")
+.if (${ARCH} == amd64 || ${ARCH} == i386)
LIB_DEPENDS+= libunwind.so:devel/libunwind
.endif
-.if ${ARCH} == "powerpc64"
+.if ${ARCH} == powerpc64
USE_GCC= yes
.endif
-.if ${ARCH} == "armv6" || ${ARCH} == "armv6hf"
+.if ${ARCH} == armv6 || ${ARCH} == armv7
CONFIGURE_ARGS+=--with-setjmp-type=_setjmp
CONFIGURE_ENV+= ac_cv_func__setjmp=yes
.endif
diff --git a/lang/ruby24/Makefile b/lang/ruby24/Makefile
index e849772d28b6..b11b588b7362 100644
--- a/lang/ruby24/Makefile
+++ b/lang/ruby24/Makefile
@@ -45,9 +45,6 @@ USE_RUBY= yes
RUBY_NO_BUILD_DEPENDS= yes
RUBY_NO_RUN_DEPENDS= yes
-NOT_FOR_ARCHS= ia64
-NOT_FOR_ARCHS_REASON_ia64= does not build
-
OPTIONS_DEFINE= CAPIDOCS DEBUG DOCS EXAMPLES GMP RDOC
OPTIONS_DEFAULT= RDOC LIBEDIT
OPTIONS_SINGLE= EDIT
@@ -87,7 +84,7 @@ _SUF2= ,${PORTEPOCH}
.endif
.if ${OPSYS} == "FreeBSD"
-.if exists(/usr/sbin/dtrace) && (${OSVERSION} > 1100032) && (${ARCH} == "amd64" || ${ARCH} == "i386")
+.if exists(/usr/sbin/dtrace) && (${OSVERSION} > 1100032) && (${ARCH} == amd64 || ${ARCH} == i386)
CONFIGURE_ARGS+=--enable-dtrace
.else
CONFIGURE_ARGS+=--disable-dtrace
@@ -95,15 +92,15 @@ CONFIGURE_ARGS+=--disable-dtrace
.endif
# keep in sync with all platforms where libunwind is available
-.if (${ARCH} == "amd64" || ${ARCH} == "i386")
+.if (${ARCH} == amd64 || ${ARCH} == i386)
LIB_DEPENDS+= libunwind.so:devel/libunwind
.endif
-.if (${ARCH} == "powerpc64" || ${ARCH} == "powerpc")
+.if (${ARCH} == powerpc || ${ARCH} == powerpc64)
USE_GCC= yes
.endif
-.if ${ARCH} == "armv6" || ${ARCH} == "armv6hf"
+.if ${ARCH} == armv6 || ${ARCH} == armv7
CONFIGURE_ARGS+=--with-setjmp-type=_setjmp
CONFIGURE_ENV+= ac_cv_func__setjmp=yes
.endif