aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorsbruno <sbruno@FreeBSD.org>2014-02-28 11:04:19 +0800
committersbruno <sbruno@FreeBSD.org>2014-02-28 11:04:19 +0800
commit1e6560b6f1508d06c0a6a6908d6bcec18dc24713 (patch)
tree9e59ef9047d7763caf2d85dbb59eee4f582d6343 /lang
parent61128e48762a0d8f9f52d0b78e16bcf4411e2348 (diff)
downloadfreebsd-ports-gnome-1e6560b6f1508d06c0a6a6908d6bcec18dc24713.tar.gz
freebsd-ports-gnome-1e6560b6f1508d06c0a6a6908d6bcec18dc24713.tar.zst
freebsd-ports-gnome-1e6560b6f1508d06c0a6a6908d6bcec18dc24713.zip
Unbreak python module builds across the tree as a result of clang 3.4 import
now disallowing the use of -R. Submitted by: antoine Reviewed by: gjb
Diffstat (limited to 'lang')
-rw-r--r--lang/python27/Makefile2
-rw-r--r--lang/python27/files/patch-Lib__distutils__unixccompiler.py11
2 files changed, 12 insertions, 1 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 3f404f68b09e..3301c99589bb 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -3,7 +3,7 @@
PORTNAME= python27
PORTVERSION= 2.7.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python27/files/patch-Lib__distutils__unixccompiler.py b/lang/python27/files/patch-Lib__distutils__unixccompiler.py
new file mode 100644
index 000000000000..a7e71a0be3cb
--- /dev/null
+++ b/lang/python27/files/patch-Lib__distutils__unixccompiler.py
@@ -0,0 +1,11 @@
+--- ./Lib/distutils/unixccompiler.py.orig 2013-11-10 07:36:40.000000000 +0000
++++ ./Lib/distutils/unixccompiler.py 2014-02-19 15:41:48.000000000 +0000
+@@ -228,6 +228,8 @@
+ if sys.platform[:6] == "darwin":
+ # MacOSX's linker doesn't understand the -R flag at all
+ return "-L" + dir
++ elif sys.platform[:7] == "freebsd":
++ return "-Wl,-rpath=" + dir
+ elif sys.platform[:5] == "hp-ux":
+ if self._is_gcc(compiler):
+ return ["-Wl,+s", "-L" + dir]