aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2006-10-09 23:40:08 +0800
committerperky <perky@FreeBSD.org>2006-10-09 23:40:08 +0800
commit20a737c6e7f8b428d347a7fcc6bb2f8927d8f064 (patch)
treea163ee1ac011ec5b2661751604732d055661701f /lang
parent23d75a3f9728554a43d68e48df5139f406567e63 (diff)
downloadfreebsd-ports-gnome-20a737c6e7f8b428d347a7fcc6bb2f8927d8f064.tar.gz
freebsd-ports-gnome-20a737c6e7f8b428d347a7fcc6bb2f8927d8f064.tar.zst
freebsd-ports-gnome-20a737c6e7f8b428d347a7fcc6bb2f8927d8f064.zip
Simple portupgrade doesn't upgrade python correctly, so add a check
and an instruction.
Diffstat (limited to 'lang')
-rw-r--r--lang/python25/Makefile7
-rw-r--r--lang/python26/Makefile7
-rw-r--r--lang/python27/Makefile7
-rw-r--r--lang/python30/Makefile7
-rw-r--r--lang/python31/Makefile7
-rw-r--r--lang/python32/Makefile7
6 files changed, 42 insertions, 0 deletions
diff --git a/lang/python25/Makefile b/lang/python25/Makefile
index 8831de95431e..706e204e5f2d 100644
--- a/lang/python25/Makefile
+++ b/lang/python25/Makefile
@@ -179,6 +179,13 @@ pre-su-install:
.endfor
pre-install:
+ @if [ -f ${PREFIX}/bin/python ]; then \
+ ${ECHO_CMD} "=============================="; \
+ ${ECHO_CMD} "If you're upgrading it using portupgrade, try portupgrade -o lang/python25 python-2.4.x"; \
+ ${ECHO_CMD} "=============================="; \
+ ${FALSE}; \
+ fi
+
${EGREP} -v ${PLIST_EXCLUDE} ${PLIST_TEMPLATE} | \
${AWK} '{ print $$0; } \
/LIBDIR.*\.py$$/ && !/\/bad/ { print $$0 "o"; print $$0 "c"; }' > ${PLIST}
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 8831de95431e..706e204e5f2d 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -179,6 +179,13 @@ pre-su-install:
.endfor
pre-install:
+ @if [ -f ${PREFIX}/bin/python ]; then \
+ ${ECHO_CMD} "=============================="; \
+ ${ECHO_CMD} "If you're upgrading it using portupgrade, try portupgrade -o lang/python25 python-2.4.x"; \
+ ${ECHO_CMD} "=============================="; \
+ ${FALSE}; \
+ fi
+
${EGREP} -v ${PLIST_EXCLUDE} ${PLIST_TEMPLATE} | \
${AWK} '{ print $$0; } \
/LIBDIR.*\.py$$/ && !/\/bad/ { print $$0 "o"; print $$0 "c"; }' > ${PLIST}
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 8831de95431e..706e204e5f2d 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -179,6 +179,13 @@ pre-su-install:
.endfor
pre-install:
+ @if [ -f ${PREFIX}/bin/python ]; then \
+ ${ECHO_CMD} "=============================="; \
+ ${ECHO_CMD} "If you're upgrading it using portupgrade, try portupgrade -o lang/python25 python-2.4.x"; \
+ ${ECHO_CMD} "=============================="; \
+ ${FALSE}; \
+ fi
+
${EGREP} -v ${PLIST_EXCLUDE} ${PLIST_TEMPLATE} | \
${AWK} '{ print $$0; } \
/LIBDIR.*\.py$$/ && !/\/bad/ { print $$0 "o"; print $$0 "c"; }' > ${PLIST}
diff --git a/lang/python30/Makefile b/lang/python30/Makefile
index 8831de95431e..706e204e5f2d 100644
--- a/lang/python30/Makefile
+++ b/lang/python30/Makefile
@@ -179,6 +179,13 @@ pre-su-install:
.endfor
pre-install:
+ @if [ -f ${PREFIX}/bin/python ]; then \
+ ${ECHO_CMD} "=============================="; \
+ ${ECHO_CMD} "If you're upgrading it using portupgrade, try portupgrade -o lang/python25 python-2.4.x"; \
+ ${ECHO_CMD} "=============================="; \
+ ${FALSE}; \
+ fi
+
${EGREP} -v ${PLIST_EXCLUDE} ${PLIST_TEMPLATE} | \
${AWK} '{ print $$0; } \
/LIBDIR.*\.py$$/ && !/\/bad/ { print $$0 "o"; print $$0 "c"; }' > ${PLIST}
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index 8831de95431e..706e204e5f2d 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -179,6 +179,13 @@ pre-su-install:
.endfor
pre-install:
+ @if [ -f ${PREFIX}/bin/python ]; then \
+ ${ECHO_CMD} "=============================="; \
+ ${ECHO_CMD} "If you're upgrading it using portupgrade, try portupgrade -o lang/python25 python-2.4.x"; \
+ ${ECHO_CMD} "=============================="; \
+ ${FALSE}; \
+ fi
+
${EGREP} -v ${PLIST_EXCLUDE} ${PLIST_TEMPLATE} | \
${AWK} '{ print $$0; } \
/LIBDIR.*\.py$$/ && !/\/bad/ { print $$0 "o"; print $$0 "c"; }' > ${PLIST}
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 8831de95431e..706e204e5f2d 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -179,6 +179,13 @@ pre-su-install:
.endfor
pre-install:
+ @if [ -f ${PREFIX}/bin/python ]; then \
+ ${ECHO_CMD} "=============================="; \
+ ${ECHO_CMD} "If you're upgrading it using portupgrade, try portupgrade -o lang/python25 python-2.4.x"; \
+ ${ECHO_CMD} "=============================="; \
+ ${FALSE}; \
+ fi
+
${EGREP} -v ${PLIST_EXCLUDE} ${PLIST_TEMPLATE} | \
${AWK} '{ print $$0; } \
/LIBDIR.*\.py$$/ && !/\/bad/ { print $$0 "o"; print $$0 "c"; }' > ${PLIST}