aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-01-09 18:00:14 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-01-09 18:00:14 +0800
commit21edffcead6b136bd3efd9cf7b032787bbed0aa3 (patch)
treed6f467c1c330494653482fc0b43ab4c02018f770 /lang
parent2941d6ade0334e178c2c45b5d3a6aad484b58e6d (diff)
downloadfreebsd-ports-gnome-21edffcead6b136bd3efd9cf7b032787bbed0aa3.tar.gz
freebsd-ports-gnome-21edffcead6b136bd3efd9cf7b032787bbed0aa3.tar.zst
freebsd-ports-gnome-21edffcead6b136bd3efd9cf7b032787bbed0aa3.zip
- Remove always-true/false conditions after FreeBSD 9, 10.1, 10.2 EOL
- Switch to new test framework Approved by: portmgr blanket
Diffstat (limited to 'lang')
-rw-r--r--lang/micropython/Makefile17
1 files changed, 4 insertions, 13 deletions
diff --git a/lang/micropython/Makefile b/lang/micropython/Makefile
index d2a9764f3dbe..0491a602c9eb 100644
--- a/lang/micropython/Makefile
+++ b/lang/micropython/Makefile
@@ -24,15 +24,7 @@ WRKSRC_SUBDIR= unix
SHEBANG_FILES= ../tools/make-frozen.py
MAKE_ARGS+= V=1
MAKE_ENV+= PYTHON=${PYTHON_CMD} CFLAGS_EXTRA="${CPPFLAGS} ${CFLAGS}"
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 1000024
-# Our default GCC 4.2.1 build can't handle some quirks correctly.
-# Use an up to date version for FreeBSD releases, which use GCC
-# as default compiler
-USE_GCC= yes
-.endif
+TEST_TARGET= test
post-patch:
@${REINPLACE_CMD} -e 's|-Werror||;/^COPT =/d; \
@@ -49,8 +41,7 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/micropython ${STAGEDIR}${PREFIX}/bin
-regression-test: build
- ${RM} ${WRKSRC}/../tests/basics/memoryerror.py
- cd ${WRKSRC} && ${MAKE_CMD} test
+pre-test:
+ @${RM} ${WRKSRC}/../tests/basics/memoryerror.py
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>