aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2009-01-06 15:59:06 +0800
committermaho <maho@FreeBSD.org>2009-01-06 15:59:06 +0800
commit2696b04a0fb7071ef9681e560d7f8a8957bf9b43 (patch)
tree4b7f76fcc6234a8a1cca8bec4be72f3569815b29 /lang
parentb9397c8e41cf169464e276050b26542f5ea09721 (diff)
downloadfreebsd-ports-gnome-2696b04a0fb7071ef9681e560d7f8a8957bf9b43.tar.gz
freebsd-ports-gnome-2696b04a0fb7071ef9681e560d7f8a8957bf9b43.tar.zst
freebsd-ports-gnome-2696b04a0fb7071ef9681e560d7f8a8957bf9b43.zip
Readd.
audio/tuxguitar depends on lang/gcc42-withgcjawt port. Submitted by: cperciva@
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/gcc42-withgcjawt/Makefile32
-rw-r--r--lang/gcc42-withgcjawt/files/patch-configure84
-rw-r--r--lang/gcc42-withgcjawt/pkg-descr7
4 files changed, 124 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index c8fee56d606d..bf61d652ad8b 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -88,6 +88,7 @@
SUBDIR += gcc34
SUBDIR += gcc41
SUBDIR += gcc42
+ SUBDIR += gcc42-withgcjawt
SUBDIR += gcc43
SUBDIR += gcc44
SUBDIR += gcl
diff --git a/lang/gcc42-withgcjawt/Makefile b/lang/gcc42-withgcjawt/Makefile
new file mode 100644
index 000000000000..566409955cba
--- /dev/null
+++ b/lang/gcc42-withgcjawt/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: gcc with gcj+AWT
+# Date created: 17 April 2006
+# Whom: Maho Nakata <maho@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PKGNAMESUFFIX= -withgcjawt
+
+MAINTAINER= maho@FreeBSD.org
+
+MASTERDIR= ${.CURDIR}/../../lang/gcc42
+
+DESCR= ${.CURDIR}/pkg-descr
+
+WITH_JAVA_AWT= yes
+USE_XORG= xtst xt xaw xmu
+
+#weird libtool issue http://gcc.gnu.org/bugzilla/show_bug.cgi?id=28442
+EXTRA_PATCHES+= ${.CURDIR}/files/patch-configure
+USE_AUTOTOOLS= libtool:15
+
+.if ${MACHINE_ARCH} != i386
+BROKEN= Only for gcj supported platforms
+.endif
+
+pre-build:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${SRCDIR}/libjava/configure
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${SRCDIR}/libjava/classpath/configure
+
+.include "${MASTERDIR}/Makefile"
diff --git a/lang/gcc42-withgcjawt/files/patch-configure b/lang/gcc42-withgcjawt/files/patch-configure
new file mode 100644
index 000000000000..bbbfe8f8ba6a
--- /dev/null
+++ b/lang/gcc42-withgcjawt/files/patch-configure
@@ -0,0 +1,84 @@
+Real tweaks for http://gcc.gnu.org/bugzilla/show_bug.cgi?id=28442
+never be upstreamed. correct solution might be upgrading libtool(?)
+
+--- libjava/configure.orig Sat Jul 15 07:34:33 2006
++++ libjava/configure Fri Jul 21 16:37:48 2006
+@@ -5867,6 +5867,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltconfig $ac_aux_dir/ltmain.sh $ac_aux_dir/ltcf-c.sh"
++cp %%LOCALBASE%%/bin/libtool .
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+--- libjava/classpath/configure~ Wed Jun 14 22:46:33 2006
++++ libjava/classpath/configure Fri Jul 21 16:38:43 2006
+@@ -5449,6 +5449,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltconfig $ac_aux_dir/ltmain.sh $ac_aux_dir/ltcf-c.sh"
++cp %%LOCALBASE%%/bin/libtool .
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+
+--- ltconfig~ Wed Jul 5 05:30:34 2006
++++ ltconfig Fri Jul 21 19:59:52 2006
+@@ -2236,7 +2236,7 @@
+ EOF
+ else
+ echo "appending configuration tag \"$tagname\" to $ofile"
+- echo "### BEGIN LIBTOOL TAG CONFIG: $tagname" >> "$ofile"
++ echo "# ### BEGIN LIBTOOL TAG CONFIG: $tagname" >> "$ofile"
+ fi
+ cfgfile="$ofile"
+ ;;
+@@ -2266,7 +2266,7 @@
+ EOF
+ else
+ echo "appending to $cfgfile"
+- echo "### BEGIN LIBTOOL TAG CONFIG: $tagname" >> "$ofile"
++ echo "# ### BEGIN LIBTOOL TAG CONFIG: $tagname" >> "$ofile"
+ fi
+ ;;
+ esac
+--- libjava/classpath/ltconfig~ Wed Jul 5 05:30:34 2006
++++ libjava/classpath/ltconfig Fri Jul 21 20:00:44 2006
+@@ -2236,7 +2236,7 @@
+ EOF
+ else
+ echo "appending configuration tag \"$tagname\" to $ofile"
+- echo "### BEGIN LIBTOOL TAG CONFIG: $tagname" >> "$ofile"
++ echo "# ### BEGIN LIBTOOL TAG CONFIG: $tagname" >> "$ofile"
+ fi
+ cfgfile="$ofile"
+ ;;
+@@ -2266,7 +2266,7 @@
+ EOF
+ else
+ echo "appending to $cfgfile"
+- echo "### BEGIN LIBTOOL TAG CONFIG: $tagname" >> "$ofile"
++ echo "# ### BEGIN LIBTOOL TAG CONFIG: $tagname" >> "$ofile"
+ fi
+ ;;
+ esac
+
+--- libjava/configure~ Sun Jul 23 11:01:24 2006
++++ libjava/configure Sun Jul 23 11:04:35 2006
+@@ -6118,11 +6118,11 @@
+ objext="$OBJEXT" exeext="$EXEEXT" reload_flag="$reload_flag" \
+ deplibs_check_method="$deplibs_check_method" \
+ file_magic_cmd="$file_magic_cmd" \
+-${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig -o libtool $libtool_flags \
+---build="$build" --add-tag=CXX $ac_aux_dir/ltcf-cxx.sh $host \
+-|| { { echo "$as_me:$LINENO: error: libtool tag configuration failed" >&5
+-echo "$as_me: error: libtool tag configuration failed" >&2;}
+- { (exit 1); exit 1; }; }
++#${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig -o libtool $libtool_flags \
++#--build="$build" --add-tag=CXX $ac_aux_dir/ltcf-cxx.sh $host \
++#|| { { echo "$as_me:$LINENO: error: libtool tag configuration failed" >&5
++#echo "$as_me: error: libtool tag configuration failed" >&2;}
++# { (exit 1); exit 1; }; }
+ CC="$lt_save_CC"
+ CFLAGS="$lt_save_CFLAGS"
+
diff --git a/lang/gcc42-withgcjawt/pkg-descr b/lang/gcc42-withgcjawt/pkg-descr
new file mode 100644
index 000000000000..248d2faf569a
--- /dev/null
+++ b/lang/gcc42-withgcjawt/pkg-descr
@@ -0,0 +1,7 @@
+GCC, the GNU Compiler Collection includes C, C++, Java with AWT peer for
+gtk.
+
+This port installs the various front ends as gcc42, g++42, gcj42,
+like master port, *AND* installs gcj+AWT peer for gtk as well.
+
+WWW: http://gcc.gnu.org/