aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorian <ian@FreeBSD.org>2016-02-21 03:19:50 +0800
committerian <ian@FreeBSD.org>2016-02-21 03:19:50 +0800
commit2f7b674d066d40eeab805c1d96723d403c510d22 (patch)
tree5010fade097bac5325d7bd4e7964e6ee479a7172 /lang
parent4e81b5b8f16b4f470ae20f98937b43528c18446b (diff)
downloadfreebsd-ports-gnome-2f7b674d066d40eeab805c1d96723d403c510d22.tar.gz
freebsd-ports-gnome-2f7b674d066d40eeab805c1d96723d403c510d22.tar.zst
freebsd-ports-gnome-2f7b674d066d40eeab805c1d96723d403c510d22.zip
Use -fPIC on all arches; lua builds the object files into a shared lib.
Since the object files get built into a shared lib, using -fPIC on all arches is the right thing to do, instead of adding it to each new arch that comes along which doesn't accidentally allow non-PIC modules in shared libs. PR: 207324 Approved by: mat(mentor) Differential Revision: https://reviews.freebsd.org/D5362
Diffstat (limited to 'lang')
-rw-r--r--lang/lua51/Makefile4
-rw-r--r--lang/lua52/Makefile4
-rw-r--r--lang/lua53/Makefile4
3 files changed, 3 insertions, 9 deletions
diff --git a/lang/lua51/Makefile b/lang/lua51/Makefile
index 08556a45dee8..c99e2a20d401 100644
--- a/lang/lua51/Makefile
+++ b/lang/lua51/Makefile
@@ -52,9 +52,7 @@ LUA_SUBDIR?= lua${PKGNAMESUFFIX}
LUA_INCDIR?= ${LUA_PREFIX}/include/${LUA_SUBDIR}
LUA_LIBDIR?= ${LUA_PREFIX}/lib
-CFLAGS_aarch64= -fPIC
-CFLAGS_amd64= -fPIC
-CFLAGS_powerpc= -fPIC
+CFLAGS+= -fPIC
post-patch:
@${REINPLACE_CMD} -e 's,rand *(,random(,g' \
diff --git a/lang/lua52/Makefile b/lang/lua52/Makefile
index 02beccac1b2a..b7877b2ef47e 100644
--- a/lang/lua52/Makefile
+++ b/lang/lua52/Makefile
@@ -57,9 +57,7 @@ SUB_LIST= version=${PORTVERSION} \
libdir=${LUA_LIBDIR} \
soname=lua-${LUA_VER}
-CFLAGS_aarch64= -fPIC
-CFLAGS_amd64= -fPIC
-CFLAGS_powerpc= -fPIC
+CFLAGS+= -fPIC
post-patch:
@${REINPLACE_CMD} -e 's,rand *(,random(,g' \
diff --git a/lang/lua53/Makefile b/lang/lua53/Makefile
index 1d145f3e3a9c..8fa0b6ea20cd 100644
--- a/lang/lua53/Makefile
+++ b/lang/lua53/Makefile
@@ -58,9 +58,7 @@ SUB_LIST= version=${PORTVERSION} \
libdir=${LUA_LIBDIR} \
soname=lua-${LUA_VER}
-CFLAGS_aarch64= -fPIC
-CFLAGS_amd64= -fPIC
-CFLAGS_powerpc= -fPIC
+CFLAGS+= -fPIC
post-patch:
@${REINPLACE_CMD} -e 's,rand *(,random(,g' \