aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2011-10-27 23:22:09 +0800
committerbeat <beat@FreeBSD.org>2011-10-27 23:22:09 +0800
commit35e378e26628e8ea60825224176e9fdf78fe23ba (patch)
treeb6e7bfeba6a844cf34b18547e2001b48124237d1 /lang
parent65ca03baffe4cd2710928a0d32c787d193813a32 (diff)
downloadfreebsd-ports-gnome-35e378e26628e8ea60825224176e9fdf78fe23ba.tar.gz
freebsd-ports-gnome-35e378e26628e8ea60825224176e9fdf78fe23ba.tar.zst
freebsd-ports-gnome-35e378e26628e8ea60825224176e9fdf78fe23ba.zip
- Replace pre-configure target with WITH_FBSD10_FIX as we have a fix in
bsd.port.mk now. Approved by: miwi
Diffstat (limited to 'lang')
-rw-r--r--lang/python27/Makefile9
1 files changed, 1 insertions, 8 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 4730839f8665..fc0bc78e91ee 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -24,6 +24,7 @@ CONFIGURE_ENV= OPT="${CFLAGS}" SVNVERSION="echo freebsd"
MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
+WITH_FBSD10_FIX= yes
INSTALL_TARGET= altinstall
MAN1= ${PYTHON_VERSION}.1
@@ -195,14 +196,6 @@ post-patch:
${PATCH_WRKSRC}/setup.py
.endif
-pre-configure:
- @${REINPLACE_CMD} -e 's|freebsd1\*)|freebsd1\.\*)|' \
- -e 's|freebsd2\*)|freebsd2\.\*)|' \
- -e 's|freebsd\[123\]\*)|freebsd\[123\]\.\*)|' \
- -e 's|freebsd\[\[123\]\]\*)|freebsd\[\[123\]\]\.\*)|' \
- ${PATCH_WRKSRC}/Modules/_ctypes/libffi/m4/libtool.m4 \
- ${PATCH_WRKSRC}/Modules/_ctypes/libffi/configure
-
post-configure:
${TAR} -C ${WRKSRC} -cf - . | ${TAR} -C ${SHARED_WRKSRC} -xf -
${LN} -sf ${PYTHON_WRKSRC}/Lib ${WRKSRC}/Lib