aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2012-08-05 04:07:19 +0800
committermezz <mezz@FreeBSD.org>2012-08-05 04:07:19 +0800
commit416dbc6ffa3f09bc49437a1197b95565a041d37d (patch)
treeabab6c1728b4529e8884b4303d93308678590255 /lang
parent4d630fef8aea609afd7e6e7c51dfac2c7d05cc1d (diff)
downloadfreebsd-ports-gnome-416dbc6ffa3f09bc49437a1197b95565a041d37d.tar.gz
freebsd-ports-gnome-416dbc6ffa3f09bc49437a1197b95565a041d37d.tar.zst
freebsd-ports-gnome-416dbc6ffa3f09bc49437a1197b95565a041d37d.zip
Add missing patches.... Wasn't pay attention when I ran 'cvs add'...
Diffstat (limited to 'lang')
-rw-r--r--lang/opa/files/patch-Makefile11
-rw-r--r--lang/opa/files/patch-lib_stdlib_extract-import-plugin.sh8
-rw-r--r--lang/opa/files/patch-tools_manpages_Makefile31
3 files changed, 50 insertions, 0 deletions
diff --git a/lang/opa/files/patch-Makefile b/lang/opa/files/patch-Makefile
new file mode 100644
index 000000000000..40e2c8f4e032
--- /dev/null
+++ b/lang/opa/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2012-08-04 12:35:50.000000000 -0500
++++ Makefile 2012-08-04 12:36:10.000000000 -0500
+@@ -239,7 +239,7 @@
+ @if [ -d $(BUILD_DIR)/man/man1 ]; then \
+ mkdir -p $(INSTALL_DIR)/share/man/man1; \
+ fi
+- @$(if $(wildcard $(BUILD_DIR)/man/man1/*.1.gz),$(INSTALL) -r $(BUILD_DIR)/man/man1/*.1.gz $(INSTALL_DIR)/share/man/man1)
++ @$(if $(wildcard $(BUILD_DIR)/man/man1/*.1),$(INSTALL) -r $(BUILD_DIR)/man/man1/*.1 $(INSTALL_DIR)/share/man/man1)
+ @printf "Installation to $(INSTALL_DIR)/share/man done.\n"
+
+ install: install-lib install-share install-plugins install-packages install-node-packages install-man $(OPA_TOOLS) install-bin
diff --git a/lang/opa/files/patch-lib_stdlib_extract-import-plugin.sh b/lang/opa/files/patch-lib_stdlib_extract-import-plugin.sh
new file mode 100644
index 000000000000..2b653916098b
--- /dev/null
+++ b/lang/opa/files/patch-lib_stdlib_extract-import-plugin.sh
@@ -0,0 +1,8 @@
+--- lib/stdlib/extract-import-plugin.sh.orig 2012-08-02 22:02:49.000000000 -0500
++++ lib/stdlib/extract-import-plugin.sh 2012-08-02 22:03:27.000000000 -0500
+@@ -4,4 +4,4 @@
+ # source platform_helper (for sed)
+ . ${OPA_SOURCE_DIR:-$(dirname $0)/../../}/tools/platform_helper.sh
+
+-sed -n "s%^ *import-plugin *\\(.*\\) *$%\\1%p" $1 | sed -e "s/{//" -e "s/}//" -e "s/, */\n/g"
++sed -n "s%^ *import-plugin *\\(.*\\) *$%\\1%p" $1 | sed -e "s/{//" -e "s/}//" | tr ', ' '\n'
diff --git a/lang/opa/files/patch-tools_manpages_Makefile b/lang/opa/files/patch-tools_manpages_Makefile
new file mode 100644
index 000000000000..dd7c837ae3e5
--- /dev/null
+++ b/lang/opa/files/patch-tools_manpages_Makefile
@@ -0,0 +1,31 @@
+--- tools/manpages/Makefile.orig 2012-08-04 11:56:25.000000000 -0500
++++ tools/manpages/Makefile 2012-08-04 11:57:01.000000000 -0500
+@@ -32,7 +32,6 @@
+ $(TARGETDIR)/%.1: %.man
+ @mkdir -p $(TARGETDIR)
+ cp $< $@
+- gzip -f --best $@
+
+ # --
+ # second run specific manpage generation programs
+@@ -43,7 +42,6 @@
+ $(TARGETDIR)/opa.1: $(BLDDIR)/compiler/opa/gen_opa_manpage.native
+ @mkdir -p $(TARGETDIR)
+ $< > $@
+- gzip -f --best $@
+
+ $(BLDDIR)/compiler/opatop/gen_opatop_manpage.native: ../../compiler/opatop/gen_opatop_manpage.ml
+ cd ../..; $(OCAMLBUILD) compiler/opatop/gen_opatop_manpage.native
+@@ -51,7 +49,6 @@
+ $(TARGETDIR)/opatop.1: $(BLDDIR)/compiler/opatop/gen_opatop_manpage.native
+ @mkdir -p $(TARGETDIR)
+ $< > $@
+- gzip -f --best $@
+
+ # --
+ # third run our hackish conversion tool help->manpage
+@@ -72,4 +69,3 @@
+ $(TARGETDIR)/%.1: $(TARGETDIR)/%.help $(GENMAN)
+ @mkdir -p $(TARGETDIR)
+ $(GENMAN) $* $(TARGETDIR)/$* > $@
+- gzip -f --best $@