aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-06-04 03:28:57 +0800
committerpgj <pgj@FreeBSD.org>2012-06-04 03:28:57 +0800
commit4675ddfc7f29e0caa87b185eb4cb14e9f9a32e82 (patch)
treea084337e24d3b7d65649f94666e99fae92f9c6ae /lang
parentbae60d380c2639709d4a52d2ea2af60c69539b96 (diff)
downloadfreebsd-ports-gnome-4675ddfc7f29e0caa87b185eb4cb14e9f9a32e82.tar.gz
freebsd-ports-gnome-4675ddfc7f29e0caa87b185eb4cb14e9f9a32e82.tar.zst
freebsd-ports-gnome-4675ddfc7f29e0caa87b185eb4cb14e9f9a32e82.zip
This package provides parsing and rendering functions for XML. It is
based on the datatypes found in the xml-types package. This package is broken up into the following modules: * Text.XML: DOM-based parsing and rendering. This is the most commonly used module. * Text.XML.Cursor: A wrapper around Text.XML which allows bidirectional traversing of the DOM, similar to XPath. * Text.XML.Unresolved: A slight modification to Text.XML which does not require all entities to be resolved at parsing. The datatypes are slightly more complicated here, and therefore this module is only recommended when you need to deal directly with raw entities. * Text.XML.Stream.Parse: Streaming parser, including some streaming parser combinators. * Text.XML.Stream.Render: Streaming renderer. WWW: http://github.com/snoyberg/xml Obtained from: FreeBSD Haskell
Diffstat (limited to 'lang')
-rw-r--r--lang/ghc/bsd.hackage.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index 83c38645d962..f122d9852116 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -315,6 +315,7 @@ X11_port= x11/hs-X11 # lib_depends
X11-xft_port= x11/hs-X11-xft
xhtml_port= textproc/hs-xhtml
xml_port= textproc/hs-xml
+xml-conduit_port= textproc/hs-xml-conduit
xml-enumerator_port= textproc/hs-xml-enumerator
xml-types_port= textproc/hs-xml-types
xmlhtml_port= textproc/hs-xmlhtml