aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2002-04-01 02:08:40 +0800
committerolgeni <olgeni@FreeBSD.org>2002-04-01 02:08:40 +0800
commit4772c97c55d36afb8ed98dcb60d1a017f8b63236 (patch)
tree0174b497eb1b092a6832cb7673b71bb88e868e7e /lang
parentca36f0fba7d4cc5294d712c512189c9056ad3832 (diff)
downloadfreebsd-ports-gnome-4772c97c55d36afb8ed98dcb60d1a017f8b63236.tar.gz
freebsd-ports-gnome-4772c97c55d36afb8ed98dcb60d1a017f8b63236.tar.zst
freebsd-ports-gnome-4772c97c55d36afb8ed98dcb60d1a017f8b63236.zip
Add a link to the erl_call utility in ${LOCALBASE}/bin (useful for shell
scripts controlling erlang nodes).
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang/Makefile1
-rw-r--r--lang/erlang/pkg-plist1
-rw-r--r--lang/erlang14/Makefile1
-rw-r--r--lang/erlang14/pkg-plist1
4 files changed, 4 insertions, 0 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 22a651e422fc..49a10f4b4277 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -94,6 +94,7 @@ pre-configure:
# rest, not in share/doc/erlang as it should, because of relative
# links in the documentation.
post-install:
+ @${LN} -sf ${LOCALBASE}/lib/erlang/lib/erl_interface-*/bin/erl_call ${LOCALBASE}/bin/erl_call
@${TAR} --unlink -xzpf ${DISTDIR}/${DIST_SUBDIR}/${ERLANG_MAN} \
-C ${PREFIX}/lib/erlang
@${RM} -rf ${PREFIX}/lib/erlang/man/cat?
diff --git a/lang/erlang/pkg-plist b/lang/erlang/pkg-plist
index 280fb7457609..26d6a1304b1d 100644
--- a/lang/erlang/pkg-plist
+++ b/lang/erlang/pkg-plist
@@ -1,4 +1,5 @@
bin/erl
+bin/erl_call
bin/erlc
@comment Insert PLIST.lib-erlang here
@comment -=[ begin PLIST.lib-erlang ]=-
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index 22a651e422fc..49a10f4b4277 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -94,6 +94,7 @@ pre-configure:
# rest, not in share/doc/erlang as it should, because of relative
# links in the documentation.
post-install:
+ @${LN} -sf ${LOCALBASE}/lib/erlang/lib/erl_interface-*/bin/erl_call ${LOCALBASE}/bin/erl_call
@${TAR} --unlink -xzpf ${DISTDIR}/${DIST_SUBDIR}/${ERLANG_MAN} \
-C ${PREFIX}/lib/erlang
@${RM} -rf ${PREFIX}/lib/erlang/man/cat?
diff --git a/lang/erlang14/pkg-plist b/lang/erlang14/pkg-plist
index 280fb7457609..26d6a1304b1d 100644
--- a/lang/erlang14/pkg-plist
+++ b/lang/erlang14/pkg-plist
@@ -1,4 +1,5 @@
bin/erl
+bin/erl_call
bin/erlc
@comment Insert PLIST.lib-erlang here
@comment -=[ begin PLIST.lib-erlang ]=-